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IEVADS 

Šī rokasgrāmata ir piemērota ikvienam – gan lietotājam ar minimālām zināšanām par datoru, gan 

pieredzējušam rastra grafika programmu lietotājam. 

Rokasgrāmatā atrodamie apzīmējumi: 

PADOMS šeit atradīsiet vērtīgu padomu. 

 
PIEZĪME par lietām, kas būtu jāievēro un jāiegaumē. 

 
UZMANĪBU brīdinājums par iespējamajām negatīvajām darbības sekām. 

 

(Nosaukums angĜu valodā) 

Atsauce uz citu sadaĜu , kas atrodas šajā rokasgrāmatā. 

Klaviatūras TaustiĦš. 
 

Rokasgrāmatā papildināta ar krāsainiem autores ekrānuzĦēmumiem un fotogrāfijām no personīgā 

arhīva. 

No sirds ceru, ka šī pamācība noderēs plašam GIMP lietotāju lokam. 

 



 

6 

I daĜa SĀKOT DARBU 

1. noda Ĝa IEVADS 

1. Esiet sveicināti GIMP 

GIMP ir daudzplatformu foto manipulēšanas rīks. GIMP ir GNU Image Manipulation Program akronīms. 

GIMP ir piemērots dažādu foto manipulācijas uzdevumu veikšanai, tai skaitā fotogrāfiju pielabošanai, 

attēla komponēšanai un atjaunošanai. 

 

Tam ir daudzas iespējas. GIMP var tikt lietots kā vienkārša zīmēšanas programma, augstas kvalitātes 

foto pielabošanas programma, tiešsaistes pakešu apstrādes sistēma, masu produkcijas attēlu renderers, 

attēlu formāta pārveidotājs utt. 

 

GIMP ir domāts patērēšanai un paplašināšanai. Tas ir veidots tā, lai tā iespējas varētu paplašināt ar 

spraudĦiem un darīt gandrīz visu iespējamo. Uzlabotā skriptu saskarne Ĝauj darīt visu sākot ar 

vienkāršāko uzdevumu un beidzot ar vissarežăītāko attēla manipulāciju procedūru skriptu veidošanu. 

 

Vieno no GIMP stiprajām pusēm ir tā brīvā pieejamība un savietojamība ar daudzām operētājsistēmām. 

Lielākajā daĜā GNU/Linux piedāvājuma GIMP ir iekĜauts kā standartaplikācija. Tāpat GIMP ir pieejams 

citām operētājsistēmām, piemēram, Microsoft Windows™ vai Apple’s Mac OS X™ (Darwin). GIMP ir 

bezmaksas aplikācija, kas atrodas zem General Public licences. GPL nodrošina lietotājiem brīvu 

piekĜūšanu pirmkodam un tā mainīšanu. 

 

1.1.Autori 

GIMP pirmo versiju uzrakstīja Pīters Matis (Peter Mattis) un Spensers Kimbals (Spencer Kimball). 

Pēdējā laikā arī daudzi citi attīstītāji ir devuši savu ieguldījumu, kā arī tūkstoši cilvēku ir snieguši atbalstu 

testēšanā. Šobrīd GIMP jauno laidienu vada Svens ĥūmans (Sven Neumann) un Mičs Naterers (mitch 

Natterer), un daudzi citi cilvēki, saukti par GIMP-komandu. 

 

1.2. GIMP Palīdzības sistēma 

GIMP Dokumentācijas Komanda un citi lietotāji ir jūs nodrošinājuši ar informāciju, kas nepieciešama, lai 

saprastu, kā lietot GIMP. Lietotāja Rokasgrāmata ir šīs palīdzības svarīga sastāvdaĜa. Patreizējā versija 

ir Dokumentācijas Komandas mājas lapā (http://docs.gimp.org/) HTML formātā. HTML versija ir 

pieejama arī kā kontekstjūtīgā palīdzība (ja esat to uzinstalējis), kas pieejama nospiežot F1 pogu, 

strādājot ar aplikāciju. Palīdzība konkrētam izvēlnes vienumam ir pieejama nospiežot F1 taustiĦu, kamēr 

peles kursors atrodas uz izvēlnes vienuma. Turpiniet lasīt, lai sāktu savu GIMP ceĜojumu. 
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1.3. Raksturpazīmes un iespējas 

Sekojošais saraksts ir īss raksturpazīmju un iespēju pārskats, ko piedāvā GIMP: 

• Pilns zīmēšanas rīku komplekts, kurā iekĜautas otas, zīmulis, pulverizators, klonēšanas rīks u.c. 

• ApakšpikseĜu iztveršana visiem zīmēšanas rīkiem, paredzēta augstas kvalitātes 

kropĜojumnovēršanai. 

• Pilns alfa kanālu atbalsts darbam ar caurspīdīgumu. 

• SlāĦi un kanāli. 

• Procesuāla datubāze GIMP funkciju izsaukšanai no ārējām programmām, piemēram, Script-Fu 

• Uzlabotas skriptu veidošanas iespējas 

• Daudzkārtīgas atsaukšanas un atsaukšanas atcelšanas iespējas, ko ierobežo tikai vieta diskā 

• Transformācijas rīki, kuros iekĜauta pagriešana, rotēšana, mēroga mainīšana, apmešana un 

apgriešana 

• GIF, JPEG, PNG, XPM, TIFF, TGA, MPEG, PS, PDF, PCX, BMP un citu formātu atbalsts. 

• Iezīmēšanas rīki, piemēram, taisnstūris, elipse, brīvrokas, bezier un inteliăentā iezīmēšana. 

• SpraudĦi, kas Ĝauj vieglu failu formātu un efektu filtru pievienošanu. 

 



 

8 

2. Kas jauns GIMP? 

GIMP 1.0. pakāpeniski uzvērsās par stabilo un plaši izmantoto 1.2. versiju. Pēc trīs gadiem, kad GIMP 

attīstība pietuvinājās jaunas stabilas versija izlaišanai, viĦi nolēma, ka būtiskas izmaiĦas programmas 

iekšienē bija pietiekams pamatojums 2.0. versijas izlaišanai. 2.0.0. tika izlaista 2004.gada 23.martā. 

Savukārt versijā 2.2. izstrādātāji pievienoja vairumu jaunu raksturpazīmju, kam nebija nepieciešamas 

lielas, stabilitāti apdraudošas izmaiĦas. Šī versija tika izlaista 2004.gada 19.decembrī. Šajā nodaĜā īsi 

aprakstītas jaunās raksturpazīmes, kas tika pievienotas GIMP 2.2., kā arī tās, kas bija arī versijā 2.0. 

GIMP jaunākajai 2.4 versijai ir uzlabots izskats, kas liek tam izskatīties „iederīgam” jebkurā 

operētājsistēmā. Jaunums ir arī otu izmēra ēnas, priekšplāna iezīmēšanas rīki, izlīdzināšanas rīks, 

pilnekrāna skatījums un daudz kas cits. 

Šeit jūs atradīsiet īsu svarīgāko GIMP 2.4. raksturpazīmju kopsavilkumu. Ir arī daudzi citi mazāki 

labojumi, ko ilgtermiĦa lietotāji no teikti pamanīs un novērtēs (un par kurām sūdzēsies!). Tāpat jaunajā 

versijā ir veiktas lielas izmaiĦas spraudĦu programmēšanā un sfript-fu veidošanā, kas šeit nav 

aprakstītas. 

 

2.1. Saderība un standartu atbalsts 

• Jūs varat vilkt-un-nomest vai kopēt-un-ielīmēt attēla datus no GIMP uz jebkuru citu aplikāciju, kas 

atbalsta attēlu/png nomešanu (pašlaik vismaz Abiword un Kword) un attēla/xml+svg nomešanu 

(atbalsta Inskcape). Tātad jūs varat kopēt-un-ielīmēt līknes no Inkscape uz GIMP, un tad pārvilkt 

iezīmēto formu uz Abiword, lai tas ierindotu attēlu Jūsu dokumentā. 

• Paraugi tagad ir GtkPixbuf atbalstīts formāts, ieskaitot png, jpeg, xbm uc. 

• GIMP var ielādēt gradientus no SVG failiem, un paletes no ACT un RIFF failiem. 

• Ir paplašināts pārvilkšanas un nomešanas atbalsts. Tagad Jūs varat nomest failus un URL uz 

attēla loga un tie atvērsies jau esošajā attēlā kā papildus slāĦi. 
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2. nodaĜa Iedarbinot GIMP 

1. GIMP palaišana 

Visbiežāk darbu ar GIMP sāk vai nu uzlikšėinot uz ikonas, vai ierakstot gimp  komandrindā. Ja Jums ir 

uzinstalētas vairākas GIMP versijas, var gadīties, ka būs nepieciešams ierakstīt gimp-2.2. , lai izsauktu 

jaunāko versiju. Ja vēlaties, Jūs varat komandrindā pievienot arī attēlu failu sarakstu pēc programmas 

nosaukuma, un GIMP tos automātiski atvērs. Ir iespējams arī atvērt failus caur GIMP, kad tas ir palaists. 

Vairumā operētājsistēmu Jūs varat uzstādīt iespēju, ka dažādi attēlu failu formāti tiek „asociēti” ar GIMP, 

kas liks tiem atvērties GIMP logā pēc šo ikonu izsaukšanas. 

 

1.1. Atbalstītājplatformas 

GIMP ir visplašāk atbalstītā attēlu programma, kas šobrīd pieejama. Platfromas, uz kurām GIMP strādā 

ir: 

GNU/Linux™, Apple Mac OS X (Darwin)™, Microsoft Windows 95, 98, Me, XP, NT4, 2000™, 

OpenBSD™, NetBSD™, FreeBSD™, Solaris™, SunOS™, AIX™, HP-UX™, Tru64™, Digital UNIX™, 

OSF/1™, IRIX™, OS/2™ and BeOS™. 

GIMP var viegli pieslēgt arī citām operētājsistēmām, tāpēc, ka tā pirmkods ir brīvi pieejams. 

 

1.2. Valoda 

Vairumā gadījumu GIMP pats uztver sistēmas valodu. Taču reizēm tas var neizdoties vai Jūs vēlēsieties 

citu valodu. Valodu mainīt ir iespējams šādi: 

Linux 

LINUX: konsolē ierakstiet LANGUAGE=en gimp vai LANG=en gimp, nomainot en uz fr, de, 

lv... attiecīgi jūsu izvēlētājai valodai. 

Windows XP 

Control Panel\System\Advanced\Enviroment Variables\System Variables\New ierakstiet 

LANG „name” lauciĦā un eng, fr, de vai lv pie „value”. Uzmanību! Jums sava izvēlē 

jāapstriprina ar trīs OK pogām. 

Ja valodu vēlaties mainīt bieži, varat izveidot paketes failu. Atveriet NotePad. Ieraksties 

sekojošo komandu (piemēram, latviešu valodai): 

set lang=lv 

cd c:\Program Files\GIMP-2.0\bin 

GIMP-2.2.exe 

Saglabājiet šo failu kā GIMP-LV.BAT (vai citu nosaukumu, bet vienmēr beigās rakstiet .BAT) 

Izveidojiet īsinājumikonu un pārvelciet to uz darbvirsmas. 

Windows ME  
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Start->Programs->Accesories->System Tools->System Informations->Tools->System 

Configuration Utility->”Enviroment” cilne->”New” poga: ierakstiet LANG „name” lauciĦā un 

eng, fr, de vai lv pie „value”. 

Windows 95/Windows 98  

Pierakstiet set lang=lv failā, kas atrodas C:\autoexex.bat. 

Apple Mac OS X 

Ejiet uz System Preferances\International\Language un izvēlieties valodu. 
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2. Sākot GIMP pirmo reizi 

Pirmo reizi palaižot GIMP, tas iziet cauri vairākiem soĜiem, lai uzstādītu opcijas un direktorijas. Šī 

procesa laikā izveidojas Jūsu sākumdirektorija apakšdirektorija ar nosaukumu .gimp.-2.2. Visa 

informācija par Jūsu izdarītajām izvēlēm saglabājas šajā direktorijā. Ja Jūs vēlāk to dzēšat vai 

pārsaucat, nākamajā GIMP palaišanas reizē tas atkārtoti iziet cauri visiem soĜiem un izveido jaunu 

.gimp.-2.2 direktoriju. Jūs to varat izmantot savā labā, ja vēlaties izpētīt dažādu izvēĜu ietekmi bez jau 

eksistējošas instalācijas dzēšanas, vai arī, ja esat izmainījis kaut ko tik Ĝoti, ka tam nepieciešams 

labojums. 

Lielāka daĜa GIMP instalācijas ir tik vienkārša, ka varat tikai apstiprināt noklusētās izvēles katrā solī, un 

vēlāk pieregulēt Jums nepieciešamo izmantojot Izvēles dialoglodziĦu (Preferances). Svarīgākā lieta 

pārdomām ir tas, cik daudz atmiĦas esat gatavs dot GIMP kešatmiĦai. 

 

2.1. Beidzot... 

Vēl pāris ieteikumi, pirms sākat darbu. Pirmkārt, katru reizi, kad Jūs palaižat GIMP, pēc noklusējuma tas 

parāda Padomu(Tip). Šajos padomos ietvertas lietas, ka ir Ĝoti noderīgas, bet grūti apgūstamas 

pašmācības ceĜā, tāpēc ir vērts tām pievērst uzmanību. Ja Jums traucē Padomu logs, to var arī atslēgt, 

taču Jums tas būtu jāizlasa. Ērtības labad jūs tos varat lasīt jebkurā laikā izmantojot izvēlnes komandu 

Help→Tips. Otrkārt, ja pamanāt, ka GIMP nedarbojas pavisam vai tā darbībā vērojamas kĜūdas, lūdzu, 

apskatiet nodaĜu KĜūdas. Laimīgu GIMPošanu! 
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3. nodaĜa PIRMIE SOěI 

1. Pamatkoncepcija 

Šī nodaĜa ir īss ievads GIMP pamatkoncepcijā un terminoloăijā, kas nepieciešama, lai atvieglotu 

turpmāko darbu ar šo rokasgrāmatu. Viss šeit rakstītais visur citur ir aprakstīts daudz padziĜinātāk. 

Pārsvarā šajā nodaĜā ir maz saišu un norādēm uz citām lapām: viss sekojošais ir viegli atrodams satura 

rādītājā. 

Att ēli ( Images ) 

Attēli ir GIMP darba būtība. Vispārināti ar „attēlu” saprot konkrētu failu, piemēram, JPEG vai TIFF 

failu. Jūs varat iedomāties attēlu arī kā vienu logu, taču tas nav korekti, jo ir iespējams atvērt vienu 

failu vairākos logos. Nav iespējams, ka vienā logā atvērti vairāki attēli. 

GIMP attēls var būt visai sarežăīts. Tā vietā, lai attēlu uztvertu kā papīra lapu ar bildīti uz tās, Jums 

būtu jāiedomājas, ka attēls ir grāmata, kuras lapas ir SlāĦi(Layers). Bez kaudzes ar SlāĦiem, GIMP 

attēls var saturēt arī iezīmējumu, kanālus un ceĜiem. Patiesībā, GIMP nodrošina mehānismu, kas 

savā starpā savieno patvaĜīgas attēla datu daĜiĦas, ko sauc par „parazītiem”. 

GIMP var atvērt vienlaikus vairākus attēlus. Ja tie ir lieli, katrs attēls var aizĦemt daudzus atmiĦas 

megabaitus, taču GIMP ir izstrādāta tādas atmiĦas sistēma, kas Ĝauj tam veikli tikt galā arī ar 

lieliem attēliem. Taču visu ierobežo atmiĦa, tāpēc, strādājot ar attēliem, ir derīgi maksimāli 

palielināt sava datora operatīvo atmiĦu (RAM). 

SlāĦi (Layers ) 

Ja attēls ir kā grāmata, tad slāĦi ir tās lapas. Vienkāršākie attāli satur tikai vienu slāni, un ar tiem 

var apieties tāpat, kā ar papīra gabalu, taču pieredzējuši GIMP lietotāji bieži strādā ar attēliem, 

kuriem ir vairāki slāĦi, dučiem slāĦu. SlāĦiem jābūt caurspīdīgiem un tiem nebūtu jāapklāj viss 

attēls, tāpēc, kad skatāties uz attēlu, Jūs varat redzēt vairāk, nekā tikai pirmo attēla slāni: Jūs 

redzat arī pārējo slāĦu elementus. 

Kanāli (Channels ) 

GIMP kanāli ir mazākās slāĦu apakšgrupas, no kurām sastāv attēls. Katrs slāĦa kanāls ir tikpat 

liels kā pats slānis, kuram tas pieder, un tātad sastāv no tiem pašiem pikseĜiem. Katrs pikselis, 

savukārt, tiek uztverts kā konteineris, kuram var piešėirt vērtību no 0 līdz 255. Konkrētā šīs vērtības 

nozīme atkarīga no kanāla veida, piemēram, RGB krāsu shēmā vērtība R-kanālā nozīmē sarkanā 

daudzumu, kas pievienots dažādu pikseĜu krāsai. Selekcijas kanāla vērtība nosaka, cik izteikti 

pikseĜi tiek iezīmēti, bet alfa kanālā vērtība nosaka, cik caurspīdīgi ir attiecīgie pikseĜi. 

Atlase ( Selection ) 

Bieži vien darbojoties ar attēlu, Jūs vēlaties, lai tiktu mainīta tikai kāda tā daĜa. To padara 

iespējamu „atlases” mehānisms. Katram attēlam ir sava atlase, ko Jūs parasti redzat kā punktētu 

līniju, kas atdala atlases daĜu no neatlasītās (tā saucamās „skudriĦas”). Patiesībā tas ir nedaudz 

maldinošs priekšstats: atlasi pārstāv pelēkais kanāls. Punktētā līnija, ko Jūs redzat, ir tikai kontūra. 

Jūs jebkurā laikā varat apskatīt atlases kanālu visā krāšĦumā, nospiežot QuickMask pogu. 
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Lielu lomu GIMP efektīvā apguvē spēlē māksla veidot labas atlases – daĜiĦas, kas satur tikai to, 

kas Jums nepieciešams – ne vairāk, ne mazāk. Darbs ar atlasēm ir Ĝoti svarīgs, tāpēc GIMP Jums 

piedāvā virkni ar atlases rīkiem, izvēlni atlašu pārvaldīšanai, un iespēju pārslēgties uz QuickMask 

režīmu, kurā Jūs varat ar atlasi darboties kā ar krāsu kanālu. 

Atsaukšana ( Undo ) 

Ja Jums gadījusies kĜūda, Jums ir iespēja to atsaukt. Gandrīz viss, ko darāt ar attēlu ir atsaucams 

– atgriežams sākotnējā stāvoklī. Faktiski, Jūs varat atsaukt būtisku daudzumu pēdējo izmaiĦu, ja 

nolemjat, ka tās ir nepareizas. GIMP to padara iespējamu, glabājot izmaiĦu vēsturi. Taču šī vēsture 

patērē atmiĦu, tāpēc atsaukšana nevar būt bezgalīga. Dažas darbības patērē pavisam maz 

atmiĦas, tāpēc varat atsaukt dučiem tādu, pirms vecākās no vēstures tiek automātiski izdzēstas. 

Jūs varat manīt atmiĦas daudzumu, kas atvēlēta šai vēsturei, taču parasti vismaz 2-3 jaunākās 

darbības var tikt atsauktas. (Svarīgākā darbība ir attēla aizvēršana, pēc kuras pēdējās izmaiĦas 

atsaukt vairs nav iespējams. Tāpēc, pirms attēla aizvēršanas, GIMP Jums jautās apstiprinājumu, 

ka tiešām vēlaties aizvērt attēlu un saglabāt izmaiĦas tajā.) 

Spraud Ħi (Plug-ins ) 

Daudzas, visdrīzāk visas lietas, ko var darīt ar attēlu, GIMP aplikācija veic pati. Taču GIMP Ĝauj 

plašu spraudĦu lietošanu – ārējās programmas, kas cieši sadarbojas ar GIMP un spēj veiktu 

manipulācijas ar attēlu un citām GIMP sastāvdaĜām. Daudzi nepieciešamākie spraudĦi ir pievienoti 

GIMP komplektācijai, kā arī daudzi citi ir pieejami citviet. Faktiski, iespēja rakstīt spraudĦus un 

skriptus ir vienkāršākais veids, kā cilvēki, kas nav GIMP attīstības komandā, var veikt izmaiĦas un 

uzlabojumus GIMP darbā. 

Visas komandas Filtru izvēlnē (Filters) un vairums komandu citās izvēlnēs īsteno spraudĦi. 

Skripti ( Scripts ) 

Bez spraudĦiem, kas ir C valodā rakstītas programmas, GIMP atbalsta arī skriptu izmantošanu. 

Lielākā esošo skriptu daĜa ir sarakstīta Script-Fu valodā, kas ir raksturīga GIMP. Tāpat skriptu 

veidošana ir iespējama arī  izmantojot Python vai Perl valodas. Šī valodas ir parocīgākas un 

spēcīgākas par Script-Fu, taču to trūkums ir atkarība no programmatūras, kas nenāk komplektācijā 

ar GIMP, tāpēc nav garantijas, ka tie strādās visās GIMP versijās. 
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2. Galvenie logi 
 

Ilustrācija 3.1. EkrānuzĦēmums ar standarta GIMP logiem 
 

 
 

Augstāk redzamajā ekrānuzĦēmumā redzams tipisks GIMP logu izkārtojums, kas ir ērti izmantojams. 

Redzamie pieci logi: 

1. Galvenā Rīku Josla (Main Toolbox): Šī ir GIMP sirds. Tajā iekĜauta izvēlne un ikonu komplekts, ko 

lieto, lai izvēlētos rīku. 

2. Rīku Opcijas (Tool Options): Tajā attēlotas izvēlētā rīka opcijas (šajā gadījumā Taisnstūra Atlases 

Rīks). 

3. Attēla logs (Image Window): Katru attēlu GIMP atver atsevišėā logā. Vienlaikus var tikt atvērti vairāki 

attēli – to skaitu ierobežo tikai atmiĦas daudzums. GIMP var palaist arī bez atvērta attēla, bet tādā 

gadījumā no aplikācijas gandrīz nav jēgas. 

4. SlāĦu Dialogs (Layers Dialog): Šis dialoglodziĦš parāda pašlaik atvērtā attēla slāĦu struktūru un Ĝauj 

to visādi mainīt. Dažas vienkāršākās lietas ir iespējams paveikt arī bez šī lodziĦa, taču pat ne visai 

pieredzējuši GIMP lietotāji atzīst, ka bez tā iztikt ir Ĝoti grūti. 

5. Otas/ModeĜi/Gradienti (Brushes/Patterns/Gradients): Zem slāĦu dialoglodziĦa atrodas lodziĦš otu, 

modeĜu un gradientu pārvaldīšanai. 
 

Šie ir minimālie uzstādījumi. GIMP vēl ir vairāk par duci dažādu dialoglodziĦu dažādiem mērėiem, bet tos 

lietotāji parasti atver, kad nepieciešams un pēc darba aizver. Zinoši lietotāji parasti vienmēr atstāj Rīku 

joslu (Toolbox) ar opcijām un SlāĦu (Layers) dialogu. Rīku josla ir nepieciešama daudzām operācijām ar 
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GIMP, faktiski, to aizverot, arī pati GIMP aplikācija aizvērsies (tiesa, Jums pārjautās, vai tiešām to 

vēlaties). Rīku Opcijas ir atsevišės lodziĦš, ekrānuzĦēmumā parādīts pievienots Galvenajai Rīku Joslai. 

Zinoši lietotāji gandrīz vienmēr tos izkārto šādi – neredzot rīku opcijas ir grūti tos lietot. SlāĦu 

dialoglodziĦš nepieciešams strādājot ar vairākslāĦu attēlu – tiklīdz Jūs sāksiet darboties ar sarežăītākām 

funkcijām, tas būs nepieciešams visu laiku. Un visbeidzot ērts attēla izkārtojums uz ekrāna ir pats par 

sevi saprotams. 
 

PADOMS 

Ja pazūd standarta izkārtojums, jūs to varat viegli atgūt. Rīku joslā izvēloties File→Dialogs→Create New 

Dock→Layers, Channels, and Paths, parādīsies tāds SlāĦu dialogs kā ekrānuzĦēmumā. Savukārt 

izvēloties File→Dialogs→Tool Options, parādīsies jauns Rīku opciju logs. 
 

Atšėirībā no citām programmām, GIMP neĜauj izvietot visu – vadības rīkus un attēlus – vienā 

visaptverošā logā. GIMP attīstītāji vienmēr uzskatījuši, ka tas ir nepraktiski, jo liek programmai izpildīt 

dažādas funkcijas, kuras efektīvāk ir kontrolēt atsevišėos logos. Tas ne tikai izniekotu programmētāju 

laiku, bet ir arī gandrīz pilnīgi neiespējami panākt, lai tas darbotos visās operētājsistēmās, kurās GIMP ir 

paredzēts lietot. 

GIMP sākotnējās versijas (līdz 1.2.5.) šėiedās ar dialoglodziĦiem – pieredzējušiem lietotājiem bija 

vienlaicīgi jāoperē ar duci dažādu pa ekrānu izmētātu lodziĦu. GIMP 2.0 šajā aspektā ir daudz pilnīgāks, 

jo tas Ĝauj savā starpā ērti savienot dažādus lodziĦus. Pie šīs sistēmas ir jāpierod, taču GIMP veidotāji 

cer, ka Jums tas patiks. 

Turpmākās nodaĜas Jūs iepazīstinās ar katra ekrānuzĦēmumā parādītā lodziĦa sastāvdaĜām, 

paskaidrojot, kas tie ir un ko tie dara. Tiklīdz būsiet izlasījis par dialoglodziĦiem, kā arī nodaĜu par GIMP 

attēlu pamatstruktūru, Jūs zināsiet pietiekami, lai sāktu izmantot GIMP vienkāršākajām attēlu 

manipulācijām. Vēlāk Jūs varēsiet izskatīt pārējo lietotāja rokasgrāmatas daĜu, lai iepazīstos ar 

neierobežotu skaitu daudz sarežăītāku un specializētāku funkciju aprakstiem. Lai jautri iet! 
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2.1. Galvenā Rīku Josla (Main Toolbox) 
 

 

Ilustrācija 3.2. Rīku joslas ekrānuzĦēmums 
 

 
 

Galvenā Rīku josla ir GIMP sirds. Tā ir vienīgā aplikācijas daĜa, ko jūs nevarat dublēt vai aizvērt. Lūk, īss 

ieskats tās sastāvā. 

 

PADOMS 

Rīku joslā, tāpat kā vairumā GIMP daĜu, uzbīdot peles kursoru uz ikonas un kādu brīdi to nekustinot, 

parasti parādīsies rīkpadoms (tooltip) – ziĦa, kas Jums varētu palīdzēt saprast, kas šī par funkciju un 

kam tā domāta. Tāpat, vairumā gadījumu, jūs varat nospiest F1 taustiĦu, lai iegūtu vairāk informācijas 

par to, kas atrodas zem kursora. 

 

1. Rīkjoslas Izvēlne (Toolbox Menu). Šī izvēlne ir īpaša ar to, ka satur komandas, kuras nevar atrast 

izvēlnēs, kas piesaistītas attēlam. Piemēram, izvēles, dažādi dialoglodziĦi u.c. Tās sastāv sīkāk 

aprakstīts nodaĜā Rīkjoslas Izvēlne. 

2. Rīku ikonas (Tool icons). Šīs ikonas ir pogas, kas iedarbina rīkus dažādiem pielietojumiem: attēla 

fragmentu atlasei, zīmēšanai uz tiem, to pārveidošanai u.c. NodaĜā Iepazīšanās ar Rīkjoslu stāstīts 

par to, kā strādāt ar rīkiem, savukārt to funkcijas sistemātiski apskatītas nodaĜā Rīki. 

3. Priekšplāna/Fona krāsas (Foreground/Background colors). Redzamajos krāsu laukumiĦos parādītas 

pašlaik GIMP izmantotās priekšplāna un fona krāsas, kuras tiek izmantotas dažādās operācijās. 

Uzklikšėinot uz kādas no tām, parādās krāsu izvēlne, kas Ĝauj mainīt šīs krāsas. Uzklikšėinot uz 

dubultās bultiĦas, fona krāsa mainās vietām ar priekšplāna krāsu. Uzklikšėinot uz mazā simboliĦa 

apakšējā labajā stūrī, krāsas paliek melnbaltas. 

4. Otas/ModeĜi/Gradienti. Šie simboli parāda GIMP pašreizējos uzstādījumus otai, kurus izmanto arī 

pārējie rīki, kas Ĝauj zīmēt uz attēla (starp citu, „zīmēšana” ietver arī dzēšanu un izsmērēšanu); 

modeli, kuru izmanto atlasītā fragmenta aizpildīšanai; gradientam, ko izmanto plūstošai krāsu pārejai. 

Uzklikšėinot uz jebkura no šiem simboliem, parādīsies dialoglodziĦš, kurā šos uzstādījumus un 

krāsas var mainīt. 
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5. Aktīvais attēls (Active Image): GIMP Jūs varat strādāt vienlaicīgi ar vairākiem attēliem, bet aktīvs var 

būt tikai viens logs. Šeit Jūs redzat samazinātu aktīvā attēla ikonu. Noklikšėinot uz tās, atvērsies 

dialoglodziĦš ar visiem pašlaik atvērtajiem attēliem, Ĝaujot Jums izvēlēties citu aktīvo logu. To pašu 

var paveikt uzklikšėinot uz atvērtā attēla loga. 

PIEZĪME 

Pēc noklusējuma Aktīvā attēla ikona ir noslēpta. Ja vēlaties, Jūs varat to padarīt redzamu Rīkjoslas 

Iestatījumu (Toolbox Preferances) cilnē. 
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2.2. Attēla Logs (Image Window) 
 

Ilustrācija 3.3. Attēla Loga svarīgāko sastāvdaĜu ekrānuzĦēmums. 
 

 
 

Katrs attēls GIMP atveras atsevišėā logā. Sāksim ar īsu attāla loga sastāvdaĜu (pēc noklusējuma) 

aprakstu. Dažas šī loga sastāvdaĜas iespējams noslēpt, izmantojot Skatījuma (View) izvēlni, taču diez 

vai Jūs to gribēsiet darīt. 

1. Nosaukuma Josla (Title Bar): Attēla augšpusē Jūs visticamāk redzēsiet joslu ar faila nosaukumu un 

tā īsu pamatinformāciju. Šo joslu nodrošina logošanas sistēma, nevis pats GIMP, tāpēc tās izskats 

dažādās operētājsistēmās var mainīties. Iestatījumu dialogā (Preferances) Jūs varat pielāgot 

informāciju, kurai tur jāparādās. 

2. Attēla Izvēlne (Image Menu): Tieši zem nosaukuma joslas atrodas attēla izvēlne (ja vien tā nav 

pasplēpta). Ar šīs izvēlnes palīdzību Jūs varat veikt gandrīz visas attēla izmaiĦas. Jūs varat izsaukt 

attēla izvēlni, uzklikšėinot ar labo peles taustiĦu uz attēla, vai arī uzklikšėinot ar kreiso peles taustiĦu 

uz mazās bultiĦas augšējā kreisajā stūrī. Daudzas izvēlnes operācijas var veikt arī ar tastatūras 

palīdzību, nospiežot Alt taustiĦu un kādu no „akcelerācijas” taustiĦiem, kas izvēlnē ir pasvītroti. Jūs 

varat veidot arī paši savas taustiĦu kombinācijas, izmantojot Dynamic Keyboard Shortcuts 

Iestatījumu dialoglodziĦā. 

3. Izvēlnes Poga (Menu Button): Uzklikšėinot uz šīs pogas, atveras Attēla izvēlne, tikai rindiĦas vietā 

kolonnas veidā. Izvēlnei var piekĜūt arī nospiežot Shift+F10 taustiĦus. 

4. Lineāls (Ruler): Noklusējuma izkārtojumā, lineāli atrodas augšā un pa kreisi no attāla un nosaka 

attēla punktu koordinātes. Ja vēlaties, Jūs varat izvēlēties, kādas koordinātes rādīt. Pēc noklusējuma 

tiek izmantoti pikseĜi, taču Jūs tos varat nomainīt uz citām vienībām. 

5. AtrāsMaskas slēdzis (QuickMask toggle): Attēla apakšējā kreisajā stūrī atrodas maza poga, kas 

ieslēdz un izslēdz AtrāsMaskas režīmu, kas reidzēm var būt Ĝoti noderīgs atlases apskates veids. 
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6. Kursora koordinātes (Pointer Coordinates): Attēla apakšējā kreisajā stūrī atrodas taisnstūra laukums, 

kas norāda pašreizējās kursora koordinātes (t.i. peles atrašanās vietu, ja to lietojat), kad vien kursors 

atrodas uz attēla. Vienības ir tās pašas, kas lineālam. 

7. Vienību Izvēlne (Units menu): Pēc noklusējuma, vienības, ko izmanto lineāli ir pikseĜi. Izmantojot šo 

izvēlni, Jūs tās varat nomainīt uz collām, centimetriem un milimetriem uc. 

8. TālummaiĦas poga (Zoom button): Ir daudz veidu, kā var pietuvināt un attālināt attēlu, taču šis ir 

visvienkāršākais. 

9. Statusa lauciĦš (Status area): Statusa lauciĦš parādās zem attēla. Pēc noklusējuma tas norāda, kura 

attēla daĜa pašlaik ir aktīva, un atmiĦas daudzumu, kuru attēls patērē. Jūs varat pielāgot šeit 

atspoguĜoto informāciju, izmanot to izvēles (Preferances) dialoglodziĦā. Kad Jūs veicat laikietilpīgas 

operācijas, statusa lauciĦš parāda progresa joslu. 

PIEZĪME 

Ievērojiet, ka patērētās atmiĦas izmērs ir atkarīgs no faila izmēra. Piemēram, 69.7Kb .PNG attēls 

aizĦems 246Kb atmiĦas, kad tiks atvērts. Tam ir divi iemesli. Pirmkārt, attēls tiek atvērts no saspiestā 

.PNG faila. Tad, GIMP šī attēla kopiju saglabā Jūsu datora atmiĦā, lai varētu izmantot Atsaukšanas 

(Undo) komandu. 

10. Atcelšanas poga (Cancel button): Loga apakšējā labajā stūrī atrodas Atcelšanas poga. Ja Jūs sākat 

laikietilpīgu procesu, piemēram, spraudni, un vēlāk izlemjat, ka to nemaz nevēlaties, šī poga atcels šo 

procesu. 

PIEZĪME 

Daži spraudĦi slikti reaăē uz atcelšanas komandu, un mēdz pēc sevis atstāt nepabeigtus attēla 

fragmentus. 

11. Navigācijas Vadība (Navigation Control): Tā ir maza krustveida poga attēla apakšējā labajā stūrī. 

Uzklikšėinot uz tās un turot nospiestu peles kreiso taustiĦu, parādās logs, kas parāda miniatūru attēlu, 

kurā ir apvilkts pašlaik redzamais attēla fragments. Turot nospiestu peles taustiĦu un kustinot kursoru, 

Jūs varat apskatīt citus attēla fragmentus. Tas ir ērti strādājot ar lielizmēra attēliem, kad apskata tikai tā 

fragmentu. (Ja Jūsu pelei ir trešais taustiĦš, izmantojiet to, lai pārvietotos pa fragmentiem. 

12. Neaktīvais Fona Laukums (Inactive Padding Area): Šīs fons domāts attēla aktīvā un neaktīvā 

laukuma atšėiršanais. Jūs nevar piemērot filtrus vai krāsas neaktīvajam fona laukumam. 

13. Attēla Demostrējums (Image Display): Attēla loga galvenā daĜa ir attēla demonstrējums jeb audekls. 

Tas ir izvietos loga centrā un to apjož dzeltena punktēta līnija, kas norāda attēla un neaktīvā dona 

laukuma robežu. Jūs varat pietuvināt vai attālināt attēlu izmantojot TālummaiĦas pogu (Zoom). 

14. Attēla Loga Izmēra MaiĦas Slēdzis (Image Window Resize Toggle): Pēc šis pogas nospiešanas 

attēla izmērs mainīsies līdz ar loga izmēru. 
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2.3. DialoglodziĦi un dokošana 

 

2.3.1. Joslu dokošana 

GIMP 2.0 un 2.2 versijās, Jums ir dotas plašas iespējas dialoglodziĦu izkārtošanā uz ekrāna. Tā vietā, 

lai katru dialogu atvērtu savā logā, Jūs tos varat grupēt, izmantojot dokus. „Doks” ir aptverošs logs, kurā 

var satilpināt vairākus patstāvīgus dialoglodziĦus, piemēram, Rīku opciju lodziĦu, Otu dialogu, Paletes 

dialogu utt. Doki nevar saturēt attēla logus – katram attēlam vienmēr ir savs logs. Tāpat tie nevar saturēt 

nepastāvīgus logus, tādus kā IzvēĜu vai Jauna attēla dialoglodziĦu. 
 

Ilustrācija 3.4. Doks ar izceltām dokošanas joslām. 
 

 
 

Katram dokam ir dokošanas joslu komplekts, kā parādīts ilustrācijā augstāk. Tās ir tievas, pelēkas joslas, 

Ĝoti neuzbāzīgas un grūti pamanāmas: daudzi lietotāji nezin, ka tādas eksistē, ja vien viĦiem nepatrāda. 

 

2.3.2. Doku Pārvilkšanas Rokturi 

Katram dokošanai paredzētam dialoglodziĦam ir „pārvilkšanas rokturu lauciĦi”. Jūs tos varat pazīt pēc tā, 

ka kursora bultiĦa pārvēršas par roku, kad novieto virs roktura. Lai apvienotu dialoglodziĦus, vienkārši 

uzklikšėiniet uz tā pārvilkšanas roktura un pārvelciet uz vienu no doku joslām – dialoglodziĦš tiks 

pievienots izvēlētajam logam. Ja jūs pārvilksiet dialoglodziĦu vienkārši uz citu logu, tas tiks pievienots kā 

cilne. 
 

Ilustrācija 3.5. DialoglodziĦš dokā ar izceltu pārvilkšanas roktura lauciĦu. 
 

 
 

Šajā ekrānuzĦēmumā ir parādīts laukums, kas Ĝauj izĦemt dialogu no doka. 
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Jūs varat pārvilkt vairākus dialogus vienā doka joslā. Tādā gadījumā tie pārvērtīsies par cilnēm, kurās 

atspoguĜota katra dialoga ikona. Uzklikšėinot uz cilnes ikonas, izvirzīs konkrēto cilni priekšplānā, lai Jūs 

ar to varētu darboties. 

 

2.3.3. Attēla izvēlne ( Image Menu ) 
 

Daži doki satur attēla izvēlni: izvēlni, kurā paradīti atvērtie attēli un to nosaukumi. Jūs varat izmantot 

Attēla izvēlni, lai izvēlētos citu attēlu (nesajauciet šo izvēlni ar attēla izvēlni, kas ir aktīvā attēla izvēlne). 

Ja Auto poga ir nospiesta, tad izvēlne vienmēr rādīs GIMP pašlaik aktīvā attēla nosaukumu, t.i. attēlu, ar 

kuru pašlaik strādājat. 
 

Ilustrācija 3.6. Doks ar izceltu attēla izvēlni. 
 

 

 

2.3.4. Cilnes Izv ēlne (Tab Menu ) 
 

Ilustrācija 3.7. DialoglodziĦš dokā ar izceltu Cilnes izvēlni. 
 

 
 

Katrā dialoglodziĦā Jūs varat piekĜūt īpašai izvēlnei ar ciĜĦa operācijām, nospiežot Cilnes izvēlnes (Tab 

menu) pogu. Konkrētas komandas, kas attēlotas šajā izvēlnē, katrā dialogā var atšėirties, bet tur vienmēr 

atrodas operācijas jaunu ciĜĦu veidošanai, to aizvēršanai vai atdalīšanai. 
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Ilustrācija 3.8. Cilnes izvēlne SlāĦu (Layers) dialoglodziĦā 
 

 
 

Cilnes izvēlne piedāvā piekĜuvi dažādām komandām: 

Konteksta Izv ēlne 

Katras cilnes izvēlnes augšpusē atrodas ieraksts, kas atveras kā konteksta izvēlnes dialoglodziĦš, 

un satur katram dialogam specifiskas operācijas. Piemēram, konteksta izvēlne ModeĜu (Patterns) 

dialogam satur operācijas modeĜu manipulēšanai. 

Pievienot Cilni  

Šis ieraksts atveras kā apakšizvēlne un Ĝauj pievienot lielu daudzumu dokojamu dialogu jaunas 

cilnes izskatā. 
 

Ilustrācija 3.9. „Pievienot Cilni” apakšizvēlne 
 

 

Aizvērt Cilni ( Close Tab ) 
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Šis ieraksts aizver dialoglodziĦu. Aizverot pēdējo cilni lodziĦā, aizveras arī pats doks. Šīs izvēlnes 

ieraksta izvēlēšanās ir tas pats, kas nospiest „Aizvērt Cilni” pogu. 

Atvienot Cilni ( Detach Tab ) 

Šīs ieraksts atvieno dialoglodziĦu no doka, izveidojot jaunu doku atvienotajam dialoglodziĦam. Tas 

ir tas pats, kas cilnes pārvilkšana no doka uz jebkuru vietu uz ekrāna. 

Apskates Izm ērs (Preview Size ) 
 

Ilustrācija 3.10. Cilnes izvēlnes apskates izmēra apakšizvēlne. 
 

 
 

Vairumam, taču ne visiem dialoglodziĦiem ir Cilnes izvēlne ar Apskates izmēra (Preview Size) opciju, 

kas atveras kā apakšizvēlne, piedāvājot sarakstu ar izmēriem dialoga sastāvdaĜām. Piemēram, Otu 

dialoglodziĦš atspoguĜo piedāvāto otu attēlus: Apskates izmērs nosaka, cik lieli šie attēli ir. Pēc 

noklusējuma tie ir Vidēja lieluma (Medium). 

Cilnes Izskats ( Tab Style ) 
 

Ilustrācija 3.11. Cilnes izvēlnes apakšizvēlne Cilnes Izskats. 
 

 

Šis ierakts ir pieejams, kad vienā dokā ir apvienoti vairāki dialoglodziĦi: tas atveras kā apakšizvēlne un 

Ĝauj izvēlēties ciĜĦu izskatu. Ir piecas iespējas, taču ne visas ir pieejamas dažādos dialogos: 

Ikona (Icon) 

Šī izvēle liek dialoglodziĦiem pārvērsties par ikonām. 

Pašreizējais Statuss (Current Status) 

Šī izvēle ir pieejama tikai dialogiem, kas Ĝauj kaut ko izvēlēties, piemēram, otām, modeĜiem, 

gradientiem uc. Tas Jums dod cilni, kas parāda pašreiz izvēlēto vienību. 

Teksts (Text) 

Šī izvēle Jums dod cilni, kas dialoglodziĦu apzīmē kā tekstu. 

Ikona un Teksts (Icon and Text) 

Šī izvēle Jums dod platākas cilnes, kurās ir gan ikona, gan teksts. 

Statuss un Teksts (Statuss and Text) 

Šī izvēle, ja iespējams, attēlo pašreiz izvēlēto vienību kopā ar dialoga veidu. 

Parādīt kā sarakstu; Par ādīt kā režăi (View as List; View as Grid)  
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Šie ieraksti attēloti dialogos, kas Jums Ĝauj izvēlēties vienību no kolekcijas: otas, modeĜi, fonti uc. 

Jūs varat izvēlēties, vai rādīt šīs vienības kā vertikālu sarakstu nosaukumiem, vai kā režăi bez 

nosaukumiem. Katram variantam ir sava priekšrocība: saraksta izskats Jums sniedz vairāk 

informācijas, taču režăis Ĝauj redzēt vairāk iespēju vienlaicīgi. Katram dialogam ir savs noklusējuma 

izskats. 

Parādīt Att ēla Izvēlni (Show Image Menu)  

Šis ir pārslēdzējs. Ja tas ir izvēlēts, Attēla izvēlne tiek parādīta doka augšpusē. Tas nav pieejams 

dialogiem, kas atrodas zem Rīku joslas. Nejauciet šo izvēlni ar Attēla izvēlni, kas ir aktīvā attēla 

izvēlne. 

Autom ātiski Sekot Akt īvajam Att ēlam (Auto Follow Active Image ) 

Ja ir izvēlēta šī opcija, dialogs attieksies uz aktīvo attēlu un manīsies līdz ar aktīvā attēla maiĦu. 

Piemēram, ja Jums ir atvērti divi attēli un histogrammas dialogs (un izvēlēta šī opcija), tad tiks 

attēlota izvēlētā attēla histogramma. 
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3. Atsaukšana (Undoing) 

Gandrīz viss, ko Jūs izdarāt ar attēlu GIMP, var tikt atsaukts. Pēdējās darbības atsaukt ar Edit→Undo, 

izmantojot Attēla izvēlni, bet tas ir nepieciešams bieži, tāpēc ir vērts iegaumēt taustiĦu Ctrl+Z 

kombināciju. 

Arī pašu atsaukšanu iespējams atsaukt. Pēc kādas darbības atsaukšanas, Jūs to varat atatsaukt, 

izvēloties Edit→Redo no attēla izvēlnes, vai izmantot tastatūras īsinājumtaustiĦu Ctrl+Y kombināciju. 

Reizēm tas ir vērtīgi, lai apskatītu izmaiĦas attēlā. 

UZMANĪBU  

Ja Jūs atsaucat vairākas darbības un tad veicat jaunas izmaiĦas attēlā jebkādā veidā, izĦemot 

Atsaukšanu vai Atatsaukšanu, tās virs nebūs iespējams atatcelt. Risinājums ir izveidot attēla dublikātu 

un darboties tajā. Atsaukšanas/Atatsaukšanas vēsture nekopējas, dublējot attēlu. 

Ja bieži izmantojat atsaukšanu un atatsaukšanu, Jums varētu būt ērtāk izmantot Atsaukšanas Vēstures 

dialogu (Undo History dialog) – dokojamu dialogu, kas attēlo katra vēstures punkta mazu uzmetumu, 

Ĝaujot jums viegli pārvietoties Atsaukšanas vēsturē. 

PIEZĪME  

Kaut arī atsaukšanas vēsture ir attēla daĜa, pēc tā saglabāšanas šī vēsture tiek dzēsta. 

 

3.1. Darbības, kuras nevar tikt atsauktas 

Vairumu izmaiĦu attēlā ir iespējams atsaukt. Darbības, kas neko nemaina attēlā, atsaukt nav iespējams. 

Tās ir tādas operācijas kā attēla saglabāšana faila formātā, attēla dublēšana, attēla daĜas kopēšana uz 

starpliktuvi uc. Nevar tikt atsauktas arī izmaiĦas attēla izskatā, piemēram, tuvināšana un tālināšana. 

IzĦēmums ir ĀtrāsMaskas (QuickMask) ieslēgšana un atslēgšana. 
 

Pastāv vairākas svarīgas darbības, kas maina attēlu, taču nevar tikt atsauktas. 

Att ēla aizvēršana 

Atsaukšanas atmiĦa ir daĜa no attēla, tāpēc pēc attēla aizvēršanas, visi tās patērētie resursi 

atbrīvojas, tai skaitā atsaukšanas atmiĦa. Tāpēc, ja vien attēls pēc iepriekšējās saglabāšanas nav 

mainīts, GIMP Jums vienmēr jautās, vai tiešām vēlaties to aizvērt. 

Att ēla atgriešana 

Atgriešana nozīmē attēla pārielādi no faila. Parasti GIMP to paveic, aizverot attēlu un izveidojot 

jaunu, kā sekas ir atsaukšanas atmiĦas dzēšana. Tāpēc, ja attēls ir neskaidrs, GIMP Jums vienmēr 

pārjautās, vai tiešām vēlaties to atgriezt. 

Darb ību da Ĝas 

Dažiem rīkiem nepieciešams, lai Jūs veiktu vairākas manipulācijas, pirms tie sāks darboties, bet 

Ĝauj atsaukt tikai visu darbību kopumu, nevis atsevišėus elementus. Piemēram, Gudrajām šėērēm 

(Intelligent scissors) nepieciešams, lai Jūs izveidojat noslēgtu ceĜu, klikšėinot vairākās attēla vietās 

un tad klikšėinot atlases vidū, lai izveidotu atlasi. Jūs nevarat atsaukt atsevišėus klikšėus. Tāpat ir 
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arī ar Teksta rīku (Text tool) – tas neĜauj atsaukt atsevišėus burtus vai fontu izmaiĦas, tā vietā 

atsaukts tiek viss teksta slānis. 
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4. GIMPLite steigā 

Šīs pamācības pamata teksta autortiesības pieder Karolai Spīrsai (Copyright © Carol Spears) 

 

4.1. Nolūks 

Tātad, Jūs esiet uzinstalējis GIMP savā datorā un Jums nepieciešams veikt ātru izmaiĦu attēlā kādam 

projektam, taču šobrīd nevēlaties neko mācīties par datorgrafiku tikai tāpēc, ka jāveic mazs attēla 

labojums. Tas ir pilnībā saprotams. GIMP ir spēcīga attēlu manipulācijas programma ar daudz iespējām 

un rīkiem. Tomēr tas ir ātrs un savā ziĦā intuitīvi apgūstams arī maziem darbiĦiem. Cerams, šie ātrie 

risinājumi Jums palīdzēs tikt galā ar savu problēmu un arī turpmāk palikt draugos ar GIMP, lai apgūtu arī 

sarežăītākus rīks un metodes tad, kad Jums būs laiks un iedvesma. 

Pāris vārdos par šeit izmantotajiem attēliem. Tie nāk no Olgas VasiĜjevas personīgā arhīva. 

Lai sāktu darbu, Jums būtu jāzina, kā savā datorā atrast un atvērt attēlu. (File→Open no Rīku izvēlnes). 
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4.2. Attēla izmēra mainīšana (Scale) 

Problēma: Jums ir milzīgs attēls, ko vēlaties izvietot kādā tīmekĜa lappusē. GIMP ir ātrs risinājums. Mūsu 

parauga attēla autore ir Olga VasiĜjeva. 
 

Ilustrācija 3.12. Parauga attēla izmēra maiĦai. 
 

 
 

Pirmā lieta, ko droši vien pamanījāt, ir tā, ka GIMP attēlu atver un izvieto proporcionāli loga izmēram. 

Tāpēc, ja attēls ir liels, GIMP to atvērs samazinātu, lai tas precīzi iekĜautos logā. Jūs to varat noteikt pēc 

procentuālās vērtības joslā zem attēla. Tas vien, ka attēls izskatās „labi” šajā apskates režīmā vēl neko 

nenozīmē. 

Otra lieta, kam jāpievērš uzmanība nosaukuma joslā, ir režīms (mode). Ja tas ir RGB, viss ir kārtībā. Ja 

tas ir Indeksēts (Indexed) vai Pelēcīgs (Grayscale), Jums būtu jāizlasa nodaĜa 4.1. Režīma maiĦa. 
 

Ilustrācija 3.13. Attēla izmēra maiĦa izmantojot GIMP 
 

 
 

Ieraksts Attēls (Image) pats atveras par apakšizvēlni. Uzklikšėiniet uz Attēla Izmēra MaiĦa (Scale 

Image...). Kas klikšėināt uz izvēlnes ieraksta, kas beidzas ar ... , gaidiet dialoglodziĦu. Šoreiz jāparādās 

Attēla Izmēra MaiĦas (Scale Image) dialogam. 
 

Ilustrācija 3.14. Attēla izmēra maiĦa pikseĜos 
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Izvēlēto platumu ierakstiet ailē Platums (Width). Ja Jūs nevarat to izdomāt, varat „nozagt” GIMP attēla 

izmēru, kas ir 265 pikseĜi. 

Ja vēlaties, Jūs varat izteikt izmēru arī citās mērvienībās, piemēram, centimetros vai collās. Tādā 

gadījumā, Jums pie pixels jānomaina mērvienības. 

ěaujiet GIMP izmainīt otru (platumu vai garumu) izmēru pašam. Lai to varētu izdarīt manuāli un liktu 

attēlam izskatīties proporcionālam, Jums būs nepieciešamas zināšanas par attēla izmēriem. 

Lai mainītu citus izmērus, lasiet sadaĜu 4.4. Attēla Apcirpšana. 
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4.3. JPEG failu izmēra samazināšana 

 

Ilustrācija 3.15 Parauga attēls saglabāšanai JPEG formātā 
 

 
 

Jūs varat samazināt JEPG failus bez platuma/garuma maiĦas pikseĜos, tādējādi Jūs varat būtiski 

samazināt attēla izmēru megabaitos. Oriăinālais attēls ir liels(2600 pikseĜu garumā), tāpēc tas ir 

samazināts. Lai šo attēlu sagatavotu tīmeklim, vispirms Jums būtu jāsamazina tā izmēri pikseĜos līdz 

vēlamajam (skat. 4.2. „Attēla izmēra mainīšana”). Uzklikšėiniet uz samazinātā attēla ar labo peles 

taustiĦu un sekojiet izvēlnēm Fails→Saglabāt kā.. (File→Save As..). Parādīsies saglabāšanas dialogs. 

Ierakstiet vēlamo nosaukumu un Norādīt Faila Formātu (Select File Type) Jums piedāvās iespējamos 

formātus. 

JPEG saglabāšanas dialoglodziĦā jūs varat samazināt attēla izmēru, vizuāli nemazinot tā kvalitāti. Šis ir 

ātrākais veids, kā to izdarīt. 
 

Ilustrācija 3.16. JPEG saglabāšanas dialoglodziĦš. 
 

 
 

Lai samazinātu attēla izmēru, pārliecinieties, ka ir ieslēgts Apskates režīms (Preview) un, bīdot 

Kvalitātes (Quality) slīdini, vērojiet izmaiĦas attēlā. Jūs redzēsiet, kā attēla kvalitāte samazinās, sevišėi 
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bīdot slīdni pa kreisi. Augstāk redzams šīs darbības ekrānuzĦēmums. Kā redzat, Ĝoti mazs ir arī Ĝoti 

slikts. Zemāk ir šīs pašas darbības ekrānuzĦēmums, taču ir atrasts labāks līmenis. 
 

Ilustrācija 3.17. JPEG attēla saglabāšanas dialogs. 
 

 
 

Tālāk redzami lielas un vidējas saspiešanas piemēri. 
 

Ilustrācija 3.18. Lielas JPEG saspiešanas piemērs. 
 

 
Kvalitāte: 7; izmērs: 8.3kB 

 
Kvalitāte: 42; izmērs 22,6kB 
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Ilustrācija 3.19. Vidējas JPEG saspiešanas piemērs. 
 

 

 
Kvalitāte 85 (GIMP standarts); izmērs: 46.8kB 

 
Kvalitāte: 100; izmērs: 184,6kB 
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4.4. Attēla apcirpšana (Crop) 
 

Ilustrācija 3.20. Attēla apcirpšanas piemērs. 

 
Attēla oriăināls 

 
Attēls pēc apcirpšanas 

 

Ir vairāki iemesli attēla apciršanai. Piemēram, taisnstūru pārvēršana par kvadrātiem un otrādi. 

Nevajadzīgā fona nogriešana, lai labāk izceltu objektu uc. Lai izsauktu apcirpšanas rīku, Jums vai nu 

jānospiež  Rīku joslā vai arī ar labo peles klikšėi uz attēla jāizsauc Rīki→Pārveidošanas 

rīki→Apcirpšana uz izmēra maiĦa (Tools→Transform Tools→Crop and Resize). Tas pārveidos kursoru 

un Ĝaus Jums, turot nospiestu peles kreiso taustiĦu, uzvilkt taisnstūri. Pogas uz Rīku joslas ir ērtākais 

veids, kā izsaukt rīku. 
 

Ilustrācija 3.21. Apciršanas laukuma iezīmēšana. 

 
 

Parasti izvēlas attēla augšējo kreiso stūri un velk uz apakšējo labo stūri. Šajā solī precizitāte nav 

galvenais, jo Jūs vēlāk varēsiet mainīt iezīmētā laukuma izmērus. Pārliecinieties, ka Jums ir ieslēgts 

Rīku opciju (Tool Options) dialogs. Ja nav, to var ieslēgt sekojoši: File→Dialogs→Tool Options. 
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Ilustrācija 3.22. Apcirpšanas dialogs 

 
 

Pēc iezīmēšanas Rīku opciju (Tool Options) vietā parādās neliels Apcirpšanas (Crop) dialogs. Tajā 

atspoguĜota informācija par iezīmētā laukuma robežām. Ir pienācis brīdis uzstādīt nepieciešamos 

izmērus. Piemēram, lai iegūtu kvadrātveida attēlu, jāĦem vērā tā īsākā mala. Dotā attēla izmēri ir 

450x600 pikseĜi, tāpēc lielākais iespējamais kvadrāts ir 450x450 pikseĜi. To var panākt, abās ailītēs pie 

Izmēra (Size) ierakstot 450. Iezīmēto laukumu var pārvietot attēlā, ja kursors ir četrvirzienu bultiĦa. Kad 

esat apmierināts ar rezultātu, noklikšėiniet uz attēla vai nospiediet Enter. 
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4.5. Attēla režīma maiĦa (Mode) 

Tāpat kā daudz kas cits, arī attēli ir dažādi un kalpo dažādām vajadzībām. Reizēm ir svarīgs attēla 

mazais izmērs (piemēram, tīmekĜa vietnē), citu reizi svarīgas ir dzidras krāsas (piemēram, ăimenes foto). 

GIMP to visu var paveikt, pārveidojot attēlus vienā no trīs pamatrežīmiem. Lai pārveidotu attēlu kādā no 

tiem, Jums ir jāatver attēls un jāuzklikšėina un izvēlētā režīma. 

RGB 

Šis ir standarta režīms, ko izmanto augstas kvalitātes krāsu attēliem. Tāpat šis režīms ir ieteicams 

dažādu darbību veikšanai – izmēra maiĦai, apcirpšanai un pagriešanai – jo tas datoram sniedz vairāk 

informācijas, ar ko strādāt. Lielais informācijas daudzums ir iemesls, kāpēc RGB attēli uz diska aizĦem 

visvairāk vietas. 

Dažas detaĜas. Katrs pikselis jeb punkts sastāv no trīs dažādām daĜām. R-Red (sarkans), G-Green 

(zaĜš), B-Blue (zils). Katra šo parametru vērtība var svārstīties no 0-225. Tāpēc, katrs pikselis, ko Jūs 

redzat, ir šo trīs sastāvdaĜu kombinācija. Visas šīs kombinācijas veido miljoniem krāsu. 

Lai izsauktu režīmu izvēlni, uzklikšėiniet ar labo peles taustiĦu uz attēla un sekojiet Attēls→Režīms 

(Image→Mode). 

Indeks ēts 

Šo režīmu izmanto tad, kad ir svarīgs faila izmērs vai tad, kad strādājat ar attēlu, kuram ir tikai 

dažas krāsas. Indeksētias režīms izmanto nosacītu daudzumu krāsu – 256 vai mazāk. Izmēăiniet 

dažādas krāsu paletes (Custom palette), ko piedāvā GIMP, vai ăenerējiet savu optimālo paleti 

(Generate optimum palette). 
 

Ilustrācija 3.23. Dialogs Pārvēršanai indeksētās krāsās (Indexed Color Conversion). 

 
 

Kā jau paredzējāt, sakarā ar to, ka informācijas par katru punktu kĜuvis mazāk, samazinājies ir arī 

faila izmērs. Taču reizēm opcijas dažos dialogos var rādīties pelēkas(nepieejamas). Tas parasti 

nozīmē, ka filtrs vai opcijas nevar tikt piemērot attēlam dotajā režīmā. Režīma maiĦa uz RGB to 

visticamāk atrisinās. Ja arī tas nedarbojas, iespējams, ka Jūsu izvēlētajai opcijai nepieciešams 
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caurspīdīgs slānis (layer). Tas ir viegli izdarāms: peles labais klikšėis uz attēla un 

Slānis→Causrpīdīgs→Pievienot Alfa kanālu (Layer→Trasparancy→Add Alpha Channel). 
 

Ilustrācija 3.24. Alfa kanāla pievienošana. 

 
 

Pelēkie to Ħi 

Gadījumā, ja vēlaties pārveidot krāsainu attēlu par melnbaltu (ar daudz pelēkajiem toĦiem), šis ir 

vieglākais veids, kā to izdarīt. 
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4.6. Attēla Apmešana (Flip) 
 

Ilustrācija 3.25. Attēla pagriešanas piemērs. 

 

Oriăinālais attēls 

 

Apmests attēls 
 

Kad Jums nepieciešams, lai cilvēks attēlā skatītos uz citu pusi vai, lai attēla augšpuse būtu apakšā 

(spoguĜattēlā), nepieviešams izmantot attēla apmešanu (flip). To var izdarīt sekojoši: peles labais klikšėis 

un Rīki→Pārveidošanas rīki→Apmest (Tools→Transform Tools→Flip) vai izmatojiet  pogu Rīku joslā. 

Šī poga pēc noklusējuma apmetīs attēlu pa vertikālo asi, taču ir iespējama arī horizontālā apmešana. 
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II daĜa KĀ KěŪT PAR GIMP LIETPRATĒJU?  

4. noda Ĝa ATTĒLU IEGŪŠNA 

Šajā nodaĜā stāstīts par to, kā dabūt attēlus GIMP aplikācijā. Tajā paskaidrots, kā izveidot jaunus attēlus, 

ielādēt tos no failiem, ieskanēt vai veidot ekrānuzĦēmumus. 

Visupirms, iepazīsimies ar GIMP attēlu pamatuzbūvi. 

1. Attēlu veidi 

Visbiežāk attēlu uztver kā vienu lodziĦu uz ekrāna, vai vienu failu, piemēram, JPEG formātā. Patiesībā 

GIMP attēla uzbūve ir sarežăītāka. Tas sastāv no vairākiem slāĦiem un citiem objektiem: iezīmēšanas 

maskas (selection mask), kanāliem (channels), ceĜiem (paths), atsaukšanas vēstures (undo history) utt. 

Šajā nodaĜā apskatīsis dažādas attēla sastāvdaĜas un darbības, ko ar tām var veikt. 

Viena no attēla pamatīpašībām ir tā režīms (mode). Ir trīs iespējamie režīmi: RGB, Pelēkie toĦi 

(Grayscale) un Indeksētais režīms (Indexed). RGB režīmā katrs pikselis tiek apzīmēts ar sarkanā, zaĜā 

un zilā daudzumu – tieši tā cilvēka acs uztver krāsas, tāpēc RGB attēli ir krāsaini. Katram krāsas 

kanālam ir iespējami 256 piesātinātības līmeĦi. 

Pelēcīgajos toĦos (grayscale), katrs punkts tiek apzīmēts ar spilgtuma koeficientu, kas var būt no 0 

(melns) līdz 255 (balts), visas starpvērtības apzīmē dažādus pelēkā toĦus. 
 

Ilustrācija 4.1. RGB un CMY krāsu režīmu sastāvdaĜas. 

 
RGB krāsu režīmā, sarkanā, zaĜā un zilā sajaukums dod baltu. 

 
CMY(K) krāsu režīmā, sajaucoties ciāna, fuksīna un dzeltenajai krāsai, rodas melna. Tas notiek tad, kad drukājat 

uz balta papīra. Taču printeris ekonomiskos nolūkos un labākai krāsas attēlošanai izmantos melnās krāsas kaseti. 
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RGB un Pelēcīgo toĦu režīmu galvenā atšėirība ir krāsu kanālu skaits: pelēcīgajiem toĦiem tas ir viens, 

RGB attēlam ir trīs. RGB attēlu varētu iztēloties kā trīs vienu virs otra novietotu pelēcīgo toĦu attēlus, kas 

katrs nokrāsots sarkanā, zaĜā un zilā krāsā. 

Taču gan RGB, gan Pelēcīgo toĦu režīmiem ir vēl viens papildus kanāls, ko sauc par alfa kanālu (alpha 

channel), kas nosaka caurredzamību. Kad alfa vērtība attēla slānim ir nulle, tas ir pilnīgi caurspīdīgs, un 

krāsu tajā vietā nosaka slānis, kas atrodas zem tā. Kad alfa kanāla vērtība ir lielākā, tas ir necaurspīdīgs 

un krāsu tai vietā nosaka dotais slānis. Savukārt vidēja vērtība nosaka krāsas caurspīdību, tāpēc tādā 

gadījumā krāsu nosaka abu – augšējā un apakšējā – krāsu sajaukums. 
 

 

Ilustrācija 4.2. RGB un Pelēcīgo toĦu režīmu piemēri. 

 
Attēls RGB režīmā ar sarkano, zaĜo un zilo krāsu kanālu. 

 
Attēls Pelēcīgo toĦu režīmā, kur kanāls apzīmē spilgtumu. 

 

GIMP katram krāsu kanālam, tai skaitā alfa kanālam, iespējamās vērtības ir no 0-255, 

datorterminoloăijā, 8 bitu dziĜums. Dažas digitālās fotokameras spēj radīt attēlu failus ar 16 bitu krāsu 

dziĜumu. GIMP nevar ielādēt šādus failus bez izšėirtspējas zuduma. Vairumā gadījumu atšėirība ir 

cilvēka acij nepamanāma, taču reizēm, kad ir lieli laukumi ar plūstošām krāsu pārejām, atšėirība var būt 

manāma. 
 

 

Ilustrācija 4.3. Attēla piemērs ar alfa kanālu. 

 
Sarkanais kanāls 

 
ZaĜais kanāls 

 
Zilais kanāls 
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Alfa kanāls, kas parāda laukumu, kas ir caurspīdīgs. 

 
Krāsu attēls RGB režīmā ar alfa kanālu. 

 

Trešais, Indeksēto krāsu režīms, ir daudz sarežăītāks. Indeksētā attēlā tiek izmantots ierobežots skaits 

atsevišėu krāsu, parasti 256 vai mazāk. Šīs krāsas veido attēla krāsu karti (colormap), katram punktam 

tiek piešėirta krāsa no krāsu kartes. Indeksētu attēlu priekšrocība ir tā, ka tie patērē maz atmiĦas, un 

„viduslaikos” (teiksim, gadus 10 atpakaĜ) tie tika plaši izmantoti. Lai arī mūsdienās to izmanto arvien 

mazāk, indeksētie attēli ir gana svarīgi, lai GIMP tos izmantotu. (Tāpat, ir daudz svarīgu attēlu 

manipulāciju, kuras vieglāk veikt ar indeksētiem attēliem nekā RGB režīmā.) 

Vairāki visbiežāk sastopamie failu tipi (tai skaitā GIF un PNG) rada indeksētus attēlus, kad tiek atvērti ar 

GIMP. Daudzi GIMP rīki un filtri strādā slikti vai vispār nedarbojas ierobežoto krāsu skaita dēĜ. Tāpēc 

vislabāk ir pārkonvertēt attēlus RGB režīmā pirms sākat darbu ar tiem. Ja nepieciešams, pēc darba 

pabeigšanas, varat to atkal saglabāt kā indeksētu attēlu. 

GIMP Ĝauj viegli pārlēgties uz dažādiem attēlu režīmiem, izmantojot Režīmu (Mode) komandu Attēla 

izvēlnē (Image Menu). Daži konvertācijas veidi (tais skaitā RGB uz Pelēkajiem toĦiem vai Indeksēto 

režīmu), protams, zaudē informāciju, kuru nav iespējams atgūt, konvertējot atpakaĜ. 

PIEZĪME 

Ja vēlaties attēlam pielietot kādu filtru un tas izvēlnē parādās pelēks(neizmantojams), bieži vien iemesls 

tam ir attēla (vai slāĦa) veida nepiemērotība. Daudzi filtri nestrādā indeksētajos attēlos. Daži, savukārt, 

strādā tikai RGB vai tikai Pelēcīgo toĦu režīmā. Citiem nepieciešams alfa kanāls vai tā neesamība. 

Izplatītākais risinājums ir attēla konvertēšana citā, visbiežāk RGB, režīmā. 

 

2. Jauna faila veidošana 

Jaunus failus veido, izmantojot sekojošās izvēlnes vienības: Fails→Jauns (File→New). Tas atver Jauna 

faila veidošanas dialogu (Create a new image), kur Jūs varat izvēlēties attēla platumu un garumu vai 

izmantot standarta vērtības. 
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3. Faila Atvēršana 

Ir vairākas iespējas, kā atvērt failu GIMP aplikācijā. 

3.1. Atvērt Failu (Open File) 

Failu atver, izmantojot Rīku joslas vai Attēla izvēlni: Fails→Atvērt (File→Open). Tas atvērs Faila Izvēles 

(File Chooser) dialogu, un Ĝaus Jums savā datorā atrast failu un uzklikšėināt uz tā nosaukuma. Šī 

metode darbojas, ja zināt faila nosaukumu un atrašanās vietu, savukārt, šis veids nav piemērots, ja 

vēlaties atrast failu pēc tā sīktēla (thumbnail). 

PIEZĪME 

Kad atverat failu izmantojot Faila izvēlni vai citu metodi, GIMP jānosaka faila veids. Ja nav citas 

alternatīvas, GIMP nevar vienkārši paĜauties uz tā paplašinājumu (piemēram, „.jpg”), lai noteiktu tā veidu, 

jo tas nav drošs veids – paplašinājumi katrā sistēmā ir dažādi, katrs fails var tikt pārsaukt, izmantojot 

jebkuru paplašinājumu, un ir vairāki iemesli, kāpēc failam var trūkt paplašinājuma. Tā vietā GIMP 

sākumā mēăinās atpazīt failu, izpētot tā saturu: vairumam visbiežāk lietoto grafisko failu formātiem ir 

„maăiskie virsraksti” (magic headers), kas Ĝauj tos atpazīt. Vienīgi gadījumā, ja maăija ir bez 

panākumiem, GIMP izmanto doto paplašinājumu. 
 

 

Ilustrācija 4.4. „Faila Atvēršanas” dialoglodziĦš. 

 
 

DialoglodziĦa centrā atrodas izvēlētās direktorijas saraksts. Apakšdirektoriji norādīti virs šī saraksta, failu 

veidi – zem. Pēc noklusējuma parādās visi direktorijā esošie faili, bet jūs varat izvēlēties attēlojamo failu 

veidu, uzklikšėinot un Faila veida (File type). 

Ja sarakstā izvēlētais fails ir attēls, dialoglodziĦa labajā pusē parādīsies tā priekšskatījums (preview) un 

faila pamatinformācija. Ja priekšskatījuma attēls ir pavisam neskaidrs, Jūs varat mēăināt to labot, turot 

Ctrl taustiĦu un klikšėinot uz priekšskatījuma lauciĦa. 
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Pirmā lieta, kas izbrīna cilvēkus, kad tie pirmo reizi redz Faila Atvēršanas dialoglodziĦu, ir lodziĦa 

trūkums, kur ierakstīt faila nosaukumu. Tomēr tas ir iespējams, jo šī funkcija ir paslēpta. Ja jūs 

nospiedīsiet Ctrl+L kombināciju, atvērsies Atvērt Atrašanās Vietu (Open location) lodziĦš ar lauciĦu, kur 

ierakstīt faila nosaukumu. Šis lodziĦš ir sīkāk aprakstīts zemāk. 

PIEZĪME 

Vairumā gadījumu, Jūs izvēlaties failu no saraksta un nospiežat Atvēršanas (Open) pogu dialoga labajā 

apakšējā stūrī, un GIMP pats automātiski noteiks faila veidu. Tomēr reizēm, parasti gadījumos, kad faila 

veids ir neparasts vai tam trūkst paplašinājuma, tas var neizdoties. Ja tā notiek, Jūs varat pateikt GIMP 

faila veidu, atverot Izvēlēties Faila Veidu (Select File Type) opciju dialoga apakšā un izvēloties ierakstu 

no dotā saraksta. Visbiežāk, ja GIMP nevar atvērt attēlu, tas ir vai nu sabojāts, vai arī GIMP neatbalsta 

tā formātu. 

 

3.2. Atvērt atrašanās vietu 

Ja faila nosaukuma vietā jums ir URL (piemēram, tīmekĜa adrese), Jūs to varat, izmantojot Fails→Atvērt 

atrašanās vietu (File→Open Location) no Rīku joslas vai Attēla izvēlnes. Tas atver mazu dialogu, kas 

Ĝauj Jums ierakstīt vai ielīmēt (paste) attēla adresi. 

Ilustrācija 4.5. Dialogs „Atvērt atrašanās vietu” 

 

 

3.3. Atvērt Pēdējos (Open Recent) 

Ja nepieciešamais attēls jau tika atvērts ar GIMP, iespējams, ātrākais veids, kā to atkal atvērt, ir 

izmantot izvēlnes komandas Fails→Atvērt pēdējos (File→Open recent). Tas atver pēdējo atvērto attēlu 

sarakstu, ar ikonām pie attēliem. Jums tikai jāizvēlas kāds no tiem un GIMP Jums to atvērs. 

 

3.4. Failu Pārlūks (File Browser) 

Ja esat asociējis failu veidu ar GIMP instalācijas laikā vai pēc tās, tad varat meklēt failus, izmantojot failu 

pārzini (piemēram, Linux Nautilus vai Windows Explorer), un veikt dubultklikšėi uz tā ikonas. Ja visi 

uzstādījumi ir pareizi, GIMP atvērs attēlu. 
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3.5. Pārvilkšana un Nomešana (Drag and Drop) 

Kad esat atradis failu ar savas operētājsistēmas failu pārlūku, uzklikšėiniet uz tā ikonas un velciet to uz 

GIMP Rīku joslu. Savukārt, ja failu uzvilksiet uz jau atvērta attēla, tas uzveidos jaunu slāni vai slāĦus. 

Daudzās aplikācijās, Jūs varat uzklikšėināt uz attēla (ne tikai uz sīktēla, bet arī uz pilna attēla) un pārvilkt 

to uz GIMP Rīku joslu. 

 

3.6. Kopēt un Ielīmēt (Copy and Paste) 

Ja aplikācija nodrošina iespēju attēlu iekopēt starpliktuvē (clipboard) (piemēram, Print Screen taustiĦš 

Ĝauj iekopēt ekrāna attēlu starpliktuvē), Jūs varat šo attēlu atvērt ar GIMP, izvēloties 

Fails→Iegūt→Ielīmēt kā jaunu (File→Acquire→Paste as New) no Rīkjoslas izvēlnes. Šīs funkcijas 

atbalsts nav garantēts, tāpēc Jums vienkārši jāizmēăina, lai uzzinātu, vai tas darbojas ar konkrēto 

aplikāciju. 

 

3.7. Attēlu Pārlūks (Image Browser) 

Izmantojot Linux operētājsistēmu, iespējams vēlēsieties iepazīties ar programmu gThumb – attēlu 

vadības aplikāciju, kas daudzējādi papildina GIMP. gThumb var likt attēlam atvērtiem GIMP vai nu ar 

labo peles klikšėi izvēloties GIMP no operāciju saraksta, vai nu pārvelkot attēla ikonu uz GIMP Rīkjoslu. 

Līdzīgas aplikācijas ir GQview un XnView. 
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5. noda Ĝa ATTĒLU IZĥEMŠANA NO GIMP  

1. Faili 

GIMP spēj lasīt un rakstīt dažāda veida grafisko failu formātus. IzĦemot XCF faila tipu, ar failiem rīkojas 

spraudĦi (plugins). Tāpēc ir samērā vienkārši likt GIMP atpazīt arī citus failu formātus, ja rodas 

nepieciešamība. 

Ne visi failu formāti ir vienlīdz labi dažādām vajadzībām. Šī pamācības nodaĜa palīdzēs Jums saprast 

katra failu formāta stiprās un vājās puses. 

 

1.1. Attēlu Saglabāšana (Saving Images) 

Kad būsiet beidzis darbu ar attēlu, vēlēsieties saglabāt rezultātu. (Faktiski, Jums vajadzētu ik pa laikam 

saglabāt attēlu, lai arī GIMP ir spēcīga programma, ir dzirdēts, ka retos gadījumos tā var sabrukt.) 

vairumu formātu, ko GIMP var atvērt, var izmantot arī saglabāšanai. Tomēr viens faila formāts ir īpašs: 

GIMP radniecīgais formāts XCF, jo tas saglabā visu informāciju par attēlu, izĦemot atsaukšanas vēsturi. 

Tāpēc XCF formāts ir parocīgs starprezultātu saglabāšanai un tādu attēlu saglabāšanai, kuri vēlāk tiks 

atvērti GIMP. XCF formātu nelasa vairākums grafisko aplikāciju, tāpēc pēc darba beigšanas, Jūs 

iespējams vēlēsieties attēlu saglabāt citos, populārākos, formātos, piemēram, JPEG, PNG, TIFF utt. 

 

1.2. Failu saglabāšana (Saving files) 

Attēlu saglabāšanai ir vairākas komandas. 

GIMP Ĝauj Jums saglabāt radītos attēlus daudz dažādos formātos. Ir svarīgi atcerēties, ka vienīgais 

formāts, kurā iespējams saglabāt visu informāciju par attēlu, tai skaitā slāĦus, caurspīdību utt. ir XCF. 

Pārējie formāti saglabā tikai daĜu informācijas un zaudē pārējo. Kad Jūs saglabājat attēlu, GIMP cenšas 

Jums to paziĦot, taču tieši Jums jāsaprot izvēlētā formāta iespējas. 
 

 

Ilustrācija 5.1. Eksporta dialoglodziĦa piemērs. 
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Kā jau minēts, izĦemot XCF, nav tāda faila formāta, kas spētu saglabāt visus GIMP attēla datus. Kad 

Jūs vēlaties saglabāt attēlu tādā formātā, kas to pilnībā neatbalsta, GIMP Jums to paziĦo, norādot 

informāciju, kas tiks pazaudēta un jautā, vai vēlaties „eksportēt” attēlu tādā formātā, kas to spēj. Attēla 

eksportēšana nemaina pašu attēlu, tāpēc, to darot, Jūs neko nezaudēsiet. 

PIEZĪME 

Kad Jūs aizverat attēlu (visticamāk aizverot GIMP), Jūs tiekat brīdināti, ja attēls ir „netīrs”, t.i., ja tas nav 

saglabāts pēc pēdējām veiktajām izmaiĦām. Saglabājot attēlu jebkurā formātā, liks tam izskatīties 

„tīram” pat tad, ja tas neatspoguĜo visu attēla informāciju. 

 

1.2.1. Saglabājot GIF form ātā 
 

Ilustrācija 5.2. GIF saglabāšanas dialoglodziĦš. 

 
 

UZMANĪBU 

Lūdzu, ievērojiet, ka GIF faila formāts nav spējīgs saglabāt daĜu pamatinformācijas, kā drukas 

izšėirtspēja (print resolution). Ja šie uzstādījumi Jums ir svarīgi, izvēlieties citu faila formātu, piemēram, 

PNG. 
 

GIF Opcijas 

Pārklājums (Interlace) 

Kad ir izvēlēta šī opcija, attēls tīmekĜa lapā tiks attēlots pakāpeniski. Tas bija svarīgi tad, kad 

datori un modemi bija lēni, jo tas Ĝāva apstādināt neinteresējošā attēla ielādēšanu. 

GIF komentārs (GIF comment) 

Izvairieties no simboliem, kas nav ASCII, jo GIF formāts atbalsta 7-bitu ASCII tekstu, ko GIMP 

nevar nodrošināt. Ja netīšām būsiet ievadījis simbolu, kas nav ASCII, šī opcija automātiski tiks 

atslēgta. 

Anim ētu GIF opcijas ( Animated GIP options ) 

Atkārtot bez apstājas (Loop forever) 

Kad ir izvēlēta šī opcija, animācija atkārtosies no jauna, līdz netiks apstādināta. 
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Kadru aizkavēšana (Delay Frames) 

Ja laika intervāls starp kadriem nebija noteikt, tagad Jūs to varat uzstādīt milisekundēs. Tādā 

gadījumā varat mainīt intervālu SlāĦu dialogā (Layers). 

Kadru maiĦa (Frame disposal) 

Ja izvēlēta šī opcija, Jums jāizvēlas, kā kadri tiks uzlikti viens otram virsū. Jūs varat izvēlēties 

vienu no sekojošajiem variantiem: 

o Man vienalga (I don’t care): Jūs varat izvēlēties šo variantu, ja slāĦi ir caurspīdīgi. Tādā 

gadījumā tie pārrakstīsies viens otram pāri. 

o Kopīgi slāĦi (Cumulative layers): iekpriekšējie kadri netiks dzēsti pēc jauno parādīšanās. 

o Viens kadrs uz slāni (One frame per layer): iekriekšējais slānis tiks dzēsts pirms jauna 

parādīšanās. 

 

1.2.2. Saglabājot JPEG form ātā 

JPEG failu paplašinājumi ir .jpg, .JPG vai .jpeg. Tas ir plaši izmantots formāts, jo tas Ĝoti efektīvi saspiež 

attēlu, tai pat laikā samazina attēla kvalitātes zudumu. Neviens cits formāts nespēj attēlu saspiest tādā 

līmenī kā JPEG. Tomēr tas neatbalsta caurspīdīgumu un vairākus slāĦus. Tāpēc, lai saglabātu attēlu 

JPEG formātā, bieži vien tas ir jāeksportē no GIMP. 
 

Ilustrācija 5.3. JPEG saglabāšanas dialoglodziĦš. 

 
 

JPEG algoritms ir diezgan sarežăīts, un ietver sevī mulsinošu opciju skaitu, kuru nozīme ir pārāk 

komplicēta, lai aprakstītu šajā rokasgrāmatā. Ja vien neesat JPEG eksperts, kvalitāte ir vienīgais 

parametrs, kas Jums būs jāielāgo. 
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UZMANĪBU 

Pēc attēla saglabāšanas JPEG formātā, GIMP to vairs neuzskata par „netīru”, tāpēc, ja vien negrasāties 

veikt tālākas izmaiĦas, nesaĦemsiet nevienu brīdinājumu to aizverot. TādēĜ, ka JPEG ir zudumradošs un 

neatbalsta caurspīdīgumu un daudz slāĦu, daĜa informācijas šajā solī tiks zaudēta. Ja vēlaties saglabāt 

visu attēla informāciju, izvēlieties XCF formātu. 
 

Kvalit āte (Quality ) 

Kad saglabājat attēlu JPEG formātā, parādās dialoglodziĦš, kas Ĝauj pielāgot kvalitātes līmeni, kura 

diapazons ir no 0 līdz 100. Vērtības, ka lielākas par 95 nav īsti noderīgas. Noklusējuma kvalitātes 

vērtība 85 uzrāda lieliskus rezultātus, bet bieži vien arī zemāka vērtība nemazina vizuālo kvalitāti. 

Jūs varat sekot kvalitātes izmaiĦām attēla logā, ja esat atėeksējis Rādīt priekšskatījumu attēla logā 

(Show preview in image window). 

PIEZĪME 

Lūdzu, Ħemiet vērā, ka JPEG kvalitātes vērtība var atšėirties. Saglabājot attēlu kvalitātē 80 nenozīmē, ka 

tas izskatīsies tāpat, kā attēls, kas saglabāts kvalitātē 80 citā aplikācijā. 
 

Rādīt priekšskat ījumu att ēla log ā (Preview in image window ) 

Atėeksējot šo opciju, jebkuras izmaiĦas (kvalitāte uc.) tiks attēlotas attēla logā. Tomēr tas neveic 

izmaiĦas attēlā un tas atgriežas sākuma stāvoklī pēc JPEG dialoga aizvēršanas. 

Paplašin āti uzst ādījumi  

Optimizēt (Optimize) 

Ja izvēlaties šo opciju, entropijas kodēšanas parametriem tiks veikta optimizācija. 

Progresīvs (Progressive) 

Ja izvēlēta šī opcija, attēla daĜas failā tiks sakārtotas noteiktā secībā. Tas ir paredzēts 

kvalitatīvam attēla izskatam, ja interneta pieslēgums ir lēns. Šīs opcijas ēnu puse ir nedaudz 

lielāks faila izmērs. 

Saglabāt EXIF datus (Save EXIF data) 

JPEG faili no daudzām digitālajām kamerā satur papildus informāciju, ko sauc par EXIF datiem. 

Tā atspoguĜo informāciju par kameru un apstākĜiem, kādos attēls tika uzĦemts. Tas, vai GIMP ir 

spējīgs rīkoties ar EXIF datiem ir atkarīgs no tā, vai Jūsu sistēmā ir pieejama „libexif” bibliotēka. 

Ja GIMP ir pieeja šai bibliotēkai, EXIF dati tiek saglabāti, kad atverat JPEG failu, strādājat ar 

attēlu un tad saglabājat to JPEG formātā.  Šīs darbības nemaina EXIF datus. 

Saglabāšanas priekšskatījums (Save preview) 

Šī opcija Ĝauj saglabāt sīktēlu kopā ar attēlu. 

Saglabāt XMP datus 

Ja šī opcija ir izvēlēta, attēla metadati failā tiks saglabāti kā XMP struktūra. 

Izmantot kvalitātes uzstādījumus no oriăināla (Use quality settings from original image) 

Ja konkrēti kvalitātes uzstādījumi tika atvērti ar failu, tad tie var tikt izmantoti standarta 

uzstādījumu vietā. 
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Ja attēlā veiktas tikai pāris izmaiĦas, oriăināla kvalitātes uzstādījuma izmantošana novedīs pie 

gandrīz tādas pašas kvalitātes attēla kā sākumā. Tas mazinās kvantizēšanas zaudējumus, 

salīdzinājumā ar to, kas notiktu, ja Jūs izmantotu citus attēla kvalitātes uzstādījumus. 

Ja attēla failā atrastie kvalitātes uzstādījumi ir zemāki par pašreizējiem, šī opcija būs pieejama, 

taču pēc noklusējuma izslēgta. 

Izlīdzināšana (Smoothing) 

Saspiešana var atstāt pēdas. Jūs tās varat mazināt, izmantojot šo opciju, kas izlīdzinās attēlu, 

tomēr attēls kĜūs nedaudz miglains. 

Pārlādes marėieri (Restart markers) 

Attēla fails var saturēt marėierus, kas Ĝauj to segmentēt. Ja šī attēla ielādēšana tīmekĜa 

lapaspusē ir pārtrūkusi, to var atsākt no sekojošā marėiera. 

 Apakšparaugošana (Subsampling) 

Cilvēka acs neuztver visu krāsu spektru vienādi. To Ħem vērā saspiešanā, kad veido jaunas, 

līdzīgas krāsas. Ir iespējams trīs metodes: 

o 1x1, 1x1,1x1 (augstākā kvalitāte): saglabā kontrastējošo krāsu robežas, tomēr saspiešana 

ir mazāka. 

o 2x1, 1x1, 1x1 (4:2:2) 

o 1x2, 1x1, 1x1 

o 2x2, 1x1, 1x1 (mazākais fails): zīmīga saspiešana, piemērota izplūdušām robežām, bet 

denaturē krāsas. 

DCT metode (DCT method) 

Diskrēta kosinusu transformēšana, pirmais solis JPEG algoritmos. Iespējamās izvēles: 

o Peldošs (Float): šī metode ir nedaudz precīzāka par integrāĜu metodi, bet it Ĝoti lēna. 

o Nedalīts (Integer): (pēc noklusējuma). Šī metode ir ātrāka par peldošo, bet nav tik precīza. 

o Ātrs nedalījums (Fast integar): ātra nedalījuma metode, visneprecīzākā no visām. 

Attēla komentāri (Image Comments) 

TekstlodziĦš, kurā varat pierakstīt komentāru, kas tiks saglabāts kopā ar attēlu. 
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1.2.3. Saglabājot PNG form ātā 
 

Ilustrācija 5.4. PNG saglabāšanas lodziĦš. 

 
 

Rindp ārlēces izv ērse ( Interlacing ) 

Rindpārlēces izvērse: kad atėeksēta šī opcija, attēls tiek progresējoši attēlots tīmekĜa lapā. Tāpēc 

lēnu datoru īpašnieki var apstādināt attēla ielādi, ja tas viĦus neinteresē. 

Saglabāt fona kr āsu (Save background color ) 

Saglabāt fona krāsu: ja attēlam ir vairāki caurspīdīgi slāĦi, interneta pārlūkprogrammas, kas 

atpazīst tikai divus līmeĦus, izmantos Jūsu Rīkjoslas krāsu. Internet Explorer šī informāciju 

neizmanto. 

Saglabāt gammu ( Save gamma ) 

Saglabāt gammu: informācija par Jūsu monitoru tiks saglabāta, tāpēc attēls izskatīsies vienādi 

visos datoros, kas aprīkoti ar šo informāciju atbalstošu displeja programmu. 

Saglabāt sl āĦa nob īdi (Save layer offset ) 

Saglabāt slāĦa nobīdi: attēli ar slāĦiem pirms saglabāšanas PNG tiek saplacināti, un slāĦa nobīde 

tiek Ħemta vērā. 

Saglabāt izšėirtsp ēju (Save resolution ) 

Saglabāt izšėirtspēju: Saglabā attēla izšėirtspēju dpi. 

Saglabāt izveidošanas laiku (Save  creation time)  

Saglabāt izveidošanas laiku: tas ir pēdējās saglabāšanas laiks. 

Saglabāt koment āru (Save comment ) 

Saglabāt komentāru: šo komentāru varat izlasīt attēla parametros. 

Saglabāt caursp īdīgo pikse Ĝu kr āsu vērt ības (Save color values from transparent pixels ) 

Kad ir atėeksēta šī opcija, krāsu vērtības tiek saglabātas pat tad, ja pikseĜi ir pilnīgi caurspīdīgi. 

Saspiešanas l īmenis ( Compression level ) 

Saspiešanas līmenis: tā kā saspiešana nav zudumradoša, vienīgais iemesls mazāka par 9 

sapiešanas līmeĦa izvēlei varētu būt ilgais saspiešanas laiks vai lēns dators. Izplešana ir tikpat 

ātra, neskatoties uz saspiešanas līmeni. 
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Saglabāt noklus ējumu ( Save defaults ) 

Saglabāt noklusējumu: ja noklikšėināt uz šīs pogas, Jūsu uzstādījumi tiks saglabāti un varēs tikt 

izmantoto citās saglabāšanas reizēs, izmantojot Ielādēt noklusējumu (Load defaults) 

PIEZĪME 

Tā kā PNG formāts atbalsta indeksētos attēlus, būt labāk, ja Jūs samazinātu krāsu skaitu pirms 

saglabāšanas, ja vēlaties maksimālu mazu faila izmēru. 

 

1.2.4. Saglabājot TIFF  
 

Ilustrācija 5.5. TIFF saglabāšanas dialoglodziĦš. 

 
 

Saspiešana ( Compression ) 

Šī opcija Ĝauj izvēlēties Jūs attēlam piemērotāku saspiešanas metodi: 

o Nemaz (None): ātra metode, taču rezultāts ir lielizmēra fails. 

o LZW: attēls tiks saspiests, izmantojot „Lempel-Ziv-Welch” algoritmu, bezzudumu tehniku. Tā ir 

sena metode, tomēr joprojām iedarbīga un ātra. 

o Sapakot bitus (Pack bits): PackBits ir ātra, vienkārša saspiešanas shēma izpildbūvējuma datu 

kodēšanai. Apple ieviesa PackBits formātu, kad izlaida MacPaint aplikāciju Macintosh datoros. 

PackBits datu plūsma sastāv no viena bita galvenes datu paketēm. 

o Saplacināt (Deflate) 

o JPEG 

Saglabāt caursp īdīgo pikse Ĝu kr āsu vērt ības (Save color values from transparent pixels ) 

Kad ir atėeksēta šī opcija, krāsu vērtības tiek saglabātas pat tad, ja pikseĜi ir pilnīgi caurspīdīgi. 

Saglabāt koment āru (Save comment ) 

Šo komentāru varat izlasīt attēla parametros. 
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2. Attēlu sagatavošana internetam 

Viens no izplatītākajiem GIMP izmantošanas mērėiem ir attēlu sagatavošana un apstrāde izvietošanai 

tīmekĜa lapās. Tas nozīmē, ka attēlam jāizskatās maksimāli labi un tā failam jāaizĦem maksimāli maz 

vietas. Šī mazā pamācība soli-pa-solim Jums parādīs, kā iegūt mazāku faila izmēru, nemazinot kvalitāti. 

 

2.1. Attēli ar optimālām izmēra un kvalitātes proporcijām 

Optimālais attēls internetam ir atkarīgs no faila attēla veida un faila formāta, kas jāizmanto. Ja internetā 

vēlaties izvietot daudzkrāsainu attēlu, Jums jāizmanto JPEG formāts. Ja attēls satur maz krāsas, t.i., nav 

fotogrāfija, bet, piemēram, zīmējums (poga vai ekrānuzĦēmums), Jums būtu jālieto PNG formāts. Kā to 

izdarīt aprakstīts zemāk. 
 

1. Pirmkārt, atveriet attēlu kā parasti. 
 

Ilustrācija 5.6. Attēls atvērts RGBA režīmā. 

 
 

2. Tagad attēls ir RGB režīmā, ar pievienotu alfa kanālu (RGBA). TīmekĜa attēlam nav nepieciešams 

alfa kanāls, tāpēc to var noĦemt, saplacinot attēlu. 

Ja atverat fotogrāfiju, alfa kanāls nav jādzēš, jo fotogrāfijām parasti tāda nav, tāpēc attēls jau 

sākotnēji atveras RGB režīmā. 

PIEZĪME 

Ja attēla krāsas plūstoši pāriet caurspīdīgajos laukumos, Jūs nevarat izĦemt alfa kanālu, jo informācija 

par šo pāreju netiks saglabāta attēla failā. Ja vēlaties saglabāt attēlu ar caurspīdīgiem laukumiem bez 

plūstošas krāsu pārejas, alfa kanālu drīkst noĦemt. 

 

3. Pēc attēla saplacināšanas, Jūs varat to saglabāt PNG formātā izvietošanai tīklā. 

 

PIEZĪME 

Jūs varat saglabāt attēlu PNG formātā ar noklusējuma parametriem, bet izmantojot maksimālu 

saspiešanu. Tas nenovedīs pie attēla kvalitātes zuduma, atšėirībā no JPEG formāta. Ja Jūsu attēls ir 

daudzkrāsaina fotogrāfija, Jums tā būtu jāsaglabā JPEG formātā. Galvenais ir atrast piemērotāko 

kompromisu starp kvalitāti un saspiešanu. 
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2.2. Vēl lielāka faila izmēra samazināšana 

Ja vēlaties vēl vairāk samazināt faila izmēru, Jūs to varat konvertēt Indeksētajā (Indexed) režīmā. Tas 

nozīmē, ka visas krāsas tiks samazinātas līdz 256 vērtībām. Plūstošas pārejas un gradientu saturošu 

attēlu konvertēšana indeksētajā režīmā sniegs sliktus rezultātus, jo tas pārejas pārvērtīs joslu rindās. Šī 

metode nav piemērota arī fotogrāfijām, jo liks attēliem izskatīties graudainiem. 
 

Ilustrācija 5.7. Indeksēts attēls. 

 
 

1. Lai konvertētu attēlu indeksētajā režīmā, Attēla izvēlnē izvēlieties Attēls→Režīms→Indeksēts 

(Image→Mode→Indexed). 

2. Pēc attēla režīma konvertēšanas varat to saglabāt PNG formātā. 

 

2.3. Caurspīdību saturošu attēlu saglabāšana 

Ir divas dažādas pieejas, ko grafisko failu formāti izmanto, lai atbalstītu caurspīdīgos laukumus: 

vienkāršā binārā caurspīdība (atbalsta GIF) un alfa caurspīdība (atbalsta PNG). 
 

PIEZĪME 

Nav nepieciešams saglabāt attēlus GIF formātā, jo PNG atbalsta visas GIF piedāvātās iespējas 

(piemēram, alfa caurspīdība). Tomēr šis formāts joprojām tiek lietots animācijā. 
 

Alfa kanāla saturoša attēla veidošana. 

1. Pirmkārt, atver attēlu RGBA režīmā. 
 

Ilustrācija 5.8. RGBA režīmā atvērts attēls. 

 
 

2. Lai saglabātu attēlu ar alfa caurspīdību, Jums nepieciešams alfa kanāls. Lai pārbaudītu, vai 

attēlam ir alfa kanāls, ejiet uz Kanālu dialogu (Channel dialog) un pārliecinieties, ka blakus 

Sarkanajam, ZaĜajam un Zilajam pastāv „Alfa” (Alpha) ieraksts. Ja nav, pievienojiet jaunu alfa 

kanālu, izmantojot slāĦu izvēlni. 
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3. Tagad Jūs varat noĦemt fona slāni, lai iegūtu pilnīgi caurspīdīgu fonu, vai izveidotu krāsu parēju 

uz caurspīdīgo laukumu. Lai nodemonstrētu alfa caurspīdības iespējas, uztaisīsim kvēlojošu fonu 

apkārt Vilberam. 
 

4. Kad darbs ar attēlu ir pabeigts, varat to saglabāt PNG formātā. 
 

 

Ilustrācija 5.9. Pelēcīgais rūtojums fona slānī attēlo caurspīdīgo laukumu, kamēr strādājat ar GIMP. 
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6. noda Ĝa ZĪMĒŠANA AR GIMP 

1. Atlase (Selection) 

Reizēm, darbojoties ar attēlu, Jūs vēlēsieties mainīt tikai tā daĜu. To var panākt ar konkrēta laukuma 

atlasi. Vairums GIMP operāciju darbojas tikai uz iezīmētām attēla daĜām. 
 

 

Ilustrācija 6.1. Kā izolēt taureni? 

 
 

Ir Ĝoti daudz gadījumu, kad korektas atlases izveidošana ir panākumu atslēga. Piemēram, augstāk 

redzamajā attēlā vēlamies izgriezt taureni un ielīmēt to citā attēlā. Lai to izdarītu, jāizveido atlase, kura 

saturētu tikai taureni un neko vairāk. Tas ir sarežăīti, jo taurenim ir komplicēta kontūra un dažos 

laukumos grūti to nošėirt no fona. 
 

 

Ilustrācija 6.2. Vienkārša atlase, ko ierobežo punktēta līnija 

 
 

Tagad seko moments, kas noteikti jāsaprot. Parasti, kad atlasāt kādu objektu, to ierobežo punktēta līnija. 

Lietotāji bieži iedomājas, ka atlase ir kā konteineris, kura iekšpusē ir atlasītā attēla daĜa, bet ārpusē – 

neatlasītā. Bieži vien šī pieeja ir pareiza, taču tā nav īsti korekta. 

Patiesībā, atlase ir kanāls, kas ir identisks sarkanā, zilā, zaĜā un alfa kanāliem. Tādā veidā, katra atlases 

pikseĜa vērtība svārstās no 0 (neatlasīts) līdz 255 (pilnīgi atlasīts). Šīs pieejas priekšrocība ir tā, ka tas 
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Ĝauj tikai daĜēji atlasīt pikseli, piešėirot tiem vērtību no 0 līdz 255. Kā redzēsiet turpmāk, ir daudz 

gadījumu, kad vēlēsieties plūstošu pāreju starp atlasīto un neatlasīto laukumu. 

Kas tad ir punktētā līnija, kas parādās, kad veidojat atlasi? 

Tā ir kontūrlīnija, kas sadala attēla daĜas, kurās vismaz puse pikseĜu ir atlasīti no tām daĜām, kurās ir 

atlasīta mazāk kā puse. 
 

 

Ilustrācija 6.3. Tā pati atlase ĀtrāsMaskas(QuickMask) režīmā 

 
 

Skatoties uz punktēto līniju, būtu jāpatur prātā, ka tā attēlo tikai daĜu atlases būtības. Ja vēlaties apskatīt 

atlasi detalizētāk, visvienkāršāk ir nospiest ĀtrāsMaskas podziĦu attēla apakšējā kreisajā stūrī. Tas liek 

atlases parādīties kā caurspīdīgam attēla pārklājumam. Atlasītie laukumi nemainās, neatlasītie 

iekrāsojas sarkani. Jo pilnīgāk atlasīts laukums, jo mazāk sarkanā to noklāj. 

ĀtrāsMaskas režīms un tā pielietojumi aprakstīti zemāk. Jums būtu jāzina, ka daudzas lietas 

ĀtrāsMaskas režīmā izskatās citādāk, tāpēc pamēăiniet ieslēgt un izslēgt to, veicot dažādas darbības. 
 

 

Ilustrācija 6.4. Tā pati atlase ĀtrāsMaskas režīmā pēc atstarpošanas 

 

1.1. Atstarpošana (Feathering) 

Pēc noklusējuma uzstādījumiem, vienkāršie atlases rīki, piemēram, Taisnstūra Atlases Rīks (Rectangle 

Select Tool), veido asas kontūras. PikseĜi punktētās līnijas iekšpusē ir pilnībā iezīmēti, un ārpusē pilnīgi 

neiezīmēti. Jūs to varat pārbaudīt, ieslēdzot ĀtrāsMaskas režīmu: redzamas asas taisnstūra kontūras, 
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kurām apkārt ir vienmērīgi sarkans fons. Rīkjoslas Opcijās (Tool Options) ir redzama atzīmes rūtiĦa ar 

nosaukumu „Atstarpot malas” (Feather Edges). Ja to izvēlēsieties, rīks radīs atlases ar pāreju. 

Atstarpošanas rādiuss (ko varat pielāgot) nosaka pārejas platumu. 

Atstarpošana ir noderīga izgriešanā un ielīmēšanā, jo tas palīdz ielīmēt objektu tā, lai tas maksimāli 

iekĜautos attēlā. 

Ir iespējams atstarpēt atlasi jebkurā brīdī, pat tad, ja tā vispirms tika radīta ar asām malām. To var izdarīt 

caur attēla izvēlni, sekojot Iezīmēt→Atstarpēšana (Select→Feather). Parādīsies dialoglodziĦš, kas Ĝauj 

pielāgot atstarpēšanas rādiusu. Iespējams arī pretējais – plūstošu pāreju padarīt asu, izvēlēties 

Iezīmēt→Saasināt (Select→Sharpen). 

 

1.2. Atlases pataisīšana par daĜēji caurspīdīgu 

Jūs varat izvēlēties slāĦa intensitāti (opacity), bet to nevar piemērot atlasei. Ir noderīgi stikla attēlu 

padarīt caurspīdīgu. To var panākt sekojoši: 

o Vienkāršām atlasēm izmantojot Dzēšgumijas (Eraser) rīku ar vēlamo intensitāti. 

o Sarežăītākām atlasēm: lietojiet komandu Atlase→Peldošs (Select→Floating), lai izveidotu 

peldošu atlasi. Tas izveido jaunu slāni ar nosaukumu „Peldoša Atlase” (Floating Selection). 

Aktivizējiet to un izmantojiet intensitātes slīdni, lai iegūtu vēlamo rezultātu. Tad noenkurojiet 

atlasi: ārpus atlases peles kursors pārvēršas par enkura ikonu. Pēc klikšėa peldošā atlase pazūd 

no SlāĦu dialoga (Layer dialog) un atlase kĜūst daĜēji caurspīdīga. 

Ja šo funkciju izmantojat bieži: Ctr+C, lai kopētu atlasi un Ctrl+V, lai to ielīmētu – rodas peldoša 

atlase, kurai varat mainīt intensitāti. Tad izveidojiet jaunu slāni Slānis/Jauns slānis (Layer/New 

Layer), kas peldošo atlasi ielīmē jaunā slānī. 

o Vēl viens variants: Slānis→Maska→SlāĦa Maska (Layer→Mask→Layer Mask), lai pievienotu 

slānim ar atlasi masku. Tad izmantojiet Otu ar vēlamo intensitāti un nokrāsojiet atlasi melnu – 

nokrāsojiet to ar caurspīdību. Tad Slānis→Maska→Piemērot SlāĦa Masku (Layer→Mask→Apply 

Layer Mask). 

o Ja vēlaties padarīt caurspīdīgu fonu, pievienojiet alfa kanālu un iezīmējiet fonu ar Burvju NūjiĦu 

(Magic Wand). Tad ar Pipetes Rīku (Color Picking Tool), izvēlēties fona krāsu, kas kĜūst par 

priekšplāna krāsu Rīku joslā. Izmantojiet Aizpildīšanas Rīku (Fill Tool) uz atlases, „Krāsu 

dzēšanas” (Color Erase) režīmā. Šī metode izdzēsīs pikseĜus, kas ir izvēlētajā krāsā, pārējo 

pikseĜu krāsu dzēšot tikai daĜēji. 

Vienkāršākā metode ir Rediăēt→Dzēst (Edit→Erase) komanda, kas dod pilnīgu caurspīdību un 

neĜauj izmantot Aizpildīšanas rīka intensitātes uzstādījumus. 
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2. Atlases veidošana un pielietojums 

2.1. Atlases pārvietošana 

GIMP versijā 2.4. atlases pārvietošana ir mainījusies. Taisnstūra un elipses atlases parādās divējādi – ar 

rokturiem pēc noklusējuma. Ja noklikšėināt uz atlases, parādīsies tikai punktēta līnija. Turpretī citi 

atlases rīki „uzvedas” citādāk. 
 

2.1.1. Taisnstūra un elipses atlases pārvietošana 

Ja noklikšėināt uz atlases un pārvietojat to, pēc noklusējuma pārvietosies tikai atlases kontūra, nevis tās 

saturs. 
 

Ilustrācija 6.5. Atlases kontūras pārvietošana 

   
 

Jūs varat izmantot arī Alt (vai Ctrl+Alt dažās operētājsistēmās) un bulttaustiĦus, lai pārvietotu atlases 

kontūru par vienu pikseli. Savukārt ar Shift+Alt un bulttaustiĦiem kontūra pārvietojas par 25 pikseĜiem. 

Ja mēăināsiet pārvilkt atlasi neizmantojot rokturus, izveidosies jauna atlase. Lai pārvietotu atlases 

saturu, Jums ir 

o Jānospiež Shift+Ctrl+L taustiĦi un tad ar peli jāpārvieto atlase. Tādā veidā atlases sākotnējais 

fons paliks balts. Ir izveidota peldošā atlase. 
 

Ilustrācija 6.6. Atlases satura pārvietošana, atstājot tukšumu fonā 
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o Jānospiež Shift+Alt taustiĦi un ar peli jāpārvieto atlase – tās saturs pārvietojas neatstājot baltu 

tukšumu (fonu). 
 

Ilustrācija 6.7. Atlases satura pārvietošana, neatstājot tukšumu fonā 

 

 

2.1.2. Citu atlašu pārvietošana 

Citām atlasēm (Laso (Lasso), Maăiskās NūjiĦas (Magic Wand), Krāsu (By Color)) nav rokturu. Tās nevar 

pārvietot ar peles palīdzību. Lai pārvietotu to saturu, tāpat kā taisnstūra un elipses atlasēm, jānospiež 

Shift+Ctrl+L vai Ctrl+Alt taustiĦi un tad tās jāpārvieto ar peles palīdzību. 

Ja izmantosiet tastatūras bulttaustiĦus, pārvietosies tikai atlases kontūra. 

 

2.1.3. Cita metode 
 

PIEZĪME 

Atlases pārvietošanai var izmantot arī „apkārtceĜu”. Pataisiet to par peldošu atlasi. Tad varēsiet pārvietot 

tās saturu, atstājot tukšu fonu ar peles vai bulttaustiĦu palīdzību. Lai pārvietotu bez tukša fona 

atstāšanas, izmantojiet kopēt-ielīmēt (copy-paste). 

 

2.2. Brīvas atlases veidošana 

 

Ilustrācija 6.8. Brīvās atlases rīka izmantošana 

 
Pavirša atlase 

 
Jaunas atlases pievienošana jau esošajai 
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Kad izmantojat Laso objekta atlasei, dažas objekta daĜas var būt neprecīzi atlasītas. Jūs varat labot šos 

defektus, kamēr darbojaties ar Laso rīku, turot Shift vai Ctrl taustiĦus. Turot Shift taustiĦu, apvelciet 

jaunu atlases kontūru, ietverot daĜu jau esošās. Tiklīdz atlaidīsiet peles taustiĦu, abas atlases 

savienosies vienā. Tāpat varat atĦemt daĜu atlases, turot nospiestu Ctrl taustiĦu. 
 

PIEZĪME 

Lai precīzāk labotu atlases kontūru, izmantojiet ĀtrāsMaskas (QuickMask) režīmu. 

 

3. ĀtrāsMaskas (QuickMask) režīms 
 

Ilustrācija 6.9. Attēls ĀtrāsMaskas režīmā 

 
 

Reizēm atlases rīki neĜauj izveidot precīzas atlases. Tādos gadījumos ir noderīgs ĀtrāsMaskas režīms, 

jo tas Ĝauj zīmēt nevis apvilkt atlasi. 

 

3.1. Pārskats 

Parasti, izveidojot atlasi GIMP, Jūs redzat punktētu līniju gar tās kontūru. Patiesībā, atlase var būt lielāka 

vai mazāka par šo līniju, jo tā tiek attēlota tur, kur atlasīto pikseĜu skaits ir lielāks par pusi. 

ĀtrāsMaskas režīms ir veids, kā GIMP Jums palīdz ieraudzīt atlasi pilnā tās krāšĦumā. Tā ieslēgšana 

paver jaunas iespējas darbībā ar atlasi. Lai to izdarītu, jānoklikšėina uz mazā kvadrātiĦa attēla loga 

apakšējā kreisajā stūrī. Šī poga ir pārslēdzējs, tāpēc nospiežot to atkārtoti, var izslēgt ĀtrāsMaskas 

režīmu. Otrs veids kā ieslēgt šo režīmu ir attēla loga izvēlnē izvēloties Atlase→Ieslēgt ĀtroMasku 

(Select→Toggle QuickMask) vai izmantojot Shift+Q īsinājumtaustiĦus. 

Ieslēdzot ĀtrāsMaskas režīmu, atlase tiek parādīta kā caurspīdīgs ekrāns, ar ko noklāts attēls, un kura 

caurspīdību nosaka katra pikseĜa atlases vērtība. Pēc noklusējuma, ĀtrāMaska ir sarkana, bet Jūs tās 
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krāsu varat mainīt. Jo mazāka pikseĜa atlases vērtība, jo tumšāka maska. Pilnīgi atlasīti pikselī tiek 

attēloti pilnīgi skaidri. 

Kad esat ĀtrāsMaskas režīmā, daudzas attēla manupulācijas iedarbojas uz atlases kanālu nevis pašu 

attēlu, piemēram, zīmēšanas rīki. Zīmēšana ar baltu atlasa pikseĜus; zīmēšana ar melnu tos izĦem no 

atlases. Jūs varat izmantot jebkurus zīmēšanas rīkus, tai skaitā krāsas spainīti (paint bucket) un 

gradientas aizpildīšanas rīkus (gradient fill tool). Pieredzējuši GIMP lietotāji atzīst, ka atlases 

„uzzīmēšana” ir ātrākais un efektīvākais veids, kā ar to manipulēt. 
 

PADOMS 

Lai ĀtrāsMaskas režīmā izveidoto atlasi saglabātu kā jaunu kanālu, pārliecinieties, ka pastāv atlase un ir 

ieslēgts ĀtrāsMaskas režīms. Attēla izvēlnē izvēlieties Atlase→Saglabāt kā kanālu (Selection→Save to 

Channel). Tas izveidos jaunu kanālu ar nosaukumu AtlasesMaska1 (SelectionMask1). 

 
 

PADOMS 

Kad aktivizēts ĀtrāsMaskas režīms, Izgriezt un Ielīmēt darbojas atlasē nevis attēlā. Jūs to varat 

izmantot, lai pārkopētu atlasi no attēla uz attēlu. 

 

3.2. Parametri 

ĀtrāsMaskas režīmam ir divi parametri, kurus var mainīt, noklikšėinot uz ĀtrāsMaskas pogas ar labo 

peles pogu. 

o Parasti ĀtrāsMaskas režīmā attēla neatlasītā daĜa tiek attēlota aizmiglota, bet atlasītā – skaidra. 

To var mainīt, izvēloties „Maskēt Atlasīto Laukumu” (Mask Selected Areas) noklusētā „Maskēt 

Neatlasīto Laukumu” (Mask Unselected Areas) vietā. 

o Izvēloties „Mainīt Krāsu un Intensitāti” (Configure Color and Opacity), atveras dialoglodziĦš, kas 

Ĝauj uzstādīt izvēlētās vērtības standarta sarkans 50% vietā. 

 

4. ĀtrāsMaskas izmantošana 

1. Atveriet attēlu vai izveidojiet jaunu dokumentu. 

2. Aktivizējiet ĀtrāsMaskas režīmu, nospiežot pogu attēla loga apakšējā kreisajā stūrī. Ja pastāv 

atlase, tā parādīsies. 

3. Izvēlieties jebkuru zīmēšanas rīku. Zīmējiet ar melnu krāsu, lai noĦemtu atlasītos laukumu un ar 

baltu, lai tos pievienotu atlasei. Izmantojiet pelēkos toĦus, lai daĜēji atlasītu laukumus. 

Jūs varat izmantot atlases rīkus un aizpildīt šīs atlases ar Krāsu SpaiĦa (Paint Bucket) rīku. Tas 

nemaina ĀtrāsMaskas atlasi. 

4. Izslēdziet ĀtrāsMaskas režīmu, izmantojot pogu attēla loga apakšējā kreisajā stūrī. Atlases 

kontūra kĜūs punktēta. 
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5. Otas (Brushes) 
 

Ilustrācija 6.10. Otu veidi 

 
Otu triepienu veidu piemēri, uzzīmēti, izmantojot otas, no GIMP piedāvātā komplekta. 

 

Ota ir pikseĜkarte vai pikseĜkaršu komplekts, ko izmanto zīmēšanā. GIMP piedāvā 10 zīmēšanas rīkus, 

kuri ne tikai pilda zīmēšanas operācijas, bet arī dzēš, kopē, izpludina, izgaismo, aptumšo utt. Visi 

zīmēšanas rīki, izĦemot Tinti (Ink), izmanto vienu otu komplektu. Otas pikseĜkartes attēlo zīmes, ko rada 

viens otras pieskāriens attēlam. Otas triepiens, parasti veidots, pārvietojot kursoru ar nospiestu peles 

kreiso pogu, rada zīmju sēriju noteiktajā trajektorijā, Ħemot vērā specifiskus otu izstādījumus. 

Otas izvēlas, nospiežot uz Otu dialoga (Brushes dialog) ikonas. GIMP patlaban izmantotā ota tiek 

attēlota Otu/ModeĜu/Gradientu (Brush/Pattern/Gradient) laukumā Rīku joslā. Klikšėis uz otas simbola ir 

viens no Otu dialoga izsaukšanas veidiem. 

GIMP instalācijā ir iekĜauti vairāki pamata otu komplekti, kā arī dažas dīvainas otas (piemēram, „zaĜā 

pipara” ota), lai dotu priekšstatu par GIMP iespējām. Jūs varat veidot jaunas otas, vai lejupielādēt un 

uzinstalēt tās. 

GIMP var izmantot vairākus otu veidus. Tomēr, tie visi tiem izmantoti vienādi, un vairumā gadījumā nav 

jāzina atšėirības starp tiem. Šie ir iespējamie otu veidi: 
 

Vienkāršas otas 

Šajā kategorijā ietilpst lielākā daĜa GIMP standarta otu. Tās tiek attēlotas Otu dialogā kā pelēcīgo 

toĦu pikseĜkartes. Kad Jūs ar tām zīmējat, patreizējā priekšplāna krāsa (kas norādīta Krāsu 

LauciĦā Rīku joslā) aizvieto melno, un pikseĜkarte, kas attēlota otu dialogā attēlo otas atstātās 

zīmes uz attēla. 

Lai izveidotu tādu otu, jāizveido mazs attēls pelēcīgā režīmā, izmantojot Lupu (Zoom) un jāsaglabā 

ar .gbr paplašinājumu. Noklikšėinot uz pogas Atjaunot (Refresh) Otu dialoglodziĦā, parādās tās 

priekšskatījums. 

Krāsu otas 

Šīs kategorijas otas attēlo krāsu attēli Otu dialogā. Tās var būt arī tekstveida. Kad Jūs ar tām 

zīmējat, tiek izmantotas otas krāsas – patreizējā priekšplāna krāsa netiek Ħemta vērā. Visādi citādi 

tās darbojas tāpat kā pārējās otas. 

Lai izveidotu tādu otu, jāizveido mazs attēls RGBA režīmā. Lai to izdarītu, izveidojot jaunu attēlu, 

izvēlieties RGB kā attēla veidu un caurspīdīgu (transparent) aizpildīšanas veidu. Uzzīmējiet attēlu 

un vispirms to saglabājiet ar .xcf paplašinājumu, lai saglabātu tā uzstādījumus. Tad saglabājiet .gbr 
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formātā. Noklikšėinot uz pogas Atjaunot (Refresh), Otu dialoglodziĦā parādīsies Jūsu otas 

priekšskatījums. 
 

PADOMS 

Kad Jūs kopējat vai izgriežat atlasi, starpliktuves saturs (atlase) parādās Otu dialoga pirmajā 

rindiĦā. Jūs to varat izmantot zīmēšanā. 
 

 

Ilustrācija 6.11. Atlase Otu dialogā pēc kopēšanas vai izgriešanas 

 
 

Att ēla š Ĝūtenes / Att ēla caurules ( Image hoses/pipes ) 

Šīs kategorijas otas spēj atstāt vairāk kā viena veida zīmes uz attēla. Tās tiek apzīmētas ar mazu 

sarkanu trijstūri Otu dialoga apakšējā labajā stūrī. Reizēm tās sauc par „animētajām otām”, jo 

atstātās zīmes mainās, kad veidojat triepienus. Principā, attēla cauruĜu otas var būt gana 

sarežăītas, īpaši, ja izmatojat grafisko planšeti. Tās maina formu atkarībā no spiediena, leĦėa utt. 

Tomēr šīs iespējas bieži paliek neizmantotas, lai gan GIMP piedāvātās otas ir pietiekami 

vienkāršas (un noderīgas). 

Parametru otas 

Šīs otas ir izveidotas ar Otu Redaktoru (Brush Editor), kas Ĝauj ăenerēt dažādas otu formas, 

izmantojot vienkāršu grafisko saskarni. Parametru otu lielākā priekšrocība ir iespēja mainīt izmēru. 

Izmantojot Iestatījumu (Preferences) dialogu ir iespējams panākt otu izmēru maiĦu ar peles 

ritentiĦu vai taustiĦiem. 
 

Visām otrām ir mainām augstums. Faktiski, visu zīmēšanas rīku opcijās ir slīdnis, kas Ĝauj palielināt vai 

samazināt aktivizētās otas izmēru. 

Bez otas pikseĜkartes, tai ir vēl viens svarīgs parametrs – otas Atstarpe (Spacing). Tā nosaka attālumu 

starp otas zīmēm triepienā. Šo attālumu var mainīt ar Otu dialoglodziĦa palīdzību. 



 

63 

6. Otu izmēra maiĦa 

Kopš GIMP versijas 2.4. visām otām ir maināms izmērs. 
 

6.1. Otas izmēra maiĦa 

Otas izmēru var mainīt trīs dažādos veidos: 

1. Izmantojot slīdni Stiept vai Samazināt (Stretch or Shrink) rīkam, kas izmanto otu. Vairumam 

zīmēšanas rīku ir izmēra maiĦas slīdnis. 
 

Ilustrācija 6.12. Stiepšanas vai Samazināšanas slīdnis 

 
 

2. Ieprogrammējot peles ritentiĦu: 

 1. GIMP galvenajā logā noklikšėina uz Fails→Parametri (File→Preferances). 

 2. Jaunā loga kreisajā kolonnā, izvēlas Ievadierīces→Ievades Kontrolieri (Input Devices→Input 

Controllers). 

 3. Redz Papildus Ievades Konrolieri (Additional Input Controllers) ar divām kolonnām: Pieejamie 

Kontrolieri (Available Controllers) un Aktīvie Kontrolieri (Active Controllers).  

  Kolonnā Aktīvie Kontrolieri, veic dubultklikšėi uz Galvenais Peles RitentiĦš (Main Mouse 

Wheel). 

 4. Atveras jauns logs Konfigurēt Ievades Kontrolieri (Configure Input Controller). 

  Kreisajā kolonnā Notikums (Event), noklikšėina uz Ritināšana uz leju (Scroll Up), lai tas 

izgaismotos. 

 5. Noklikšėina uz pogas Rediăēt (Edit). 

 6. Atveras logs Izvēlēties Notikuma Kontroliera Darbību (Select Controller Event Action). 

  Atver Rīku (Tools) sarakstu ar mazo bultiĦu kreisajā stūrī. 

 7. Kreisajā kolonnā Darbība (Action), noklikšėina uz Palielināt Otas Izmēru (Increase Brush 

Scale), lai tas izgaismojas, noklikšėina uz OK pogas. 

 8. Aizveriet logu. 

 9. Tāpat ieprogrammējiet arī Ritināšana uz leju (Scroll Down). 

 10. Neaizmirstiet nospiest OK pogu Parametru dialogā. 
  

 Pēc šī garā paskaidrojuma, Jūs varat izmantot savas peles ritentiĦu otas izmēra maiĦai. 

3. Jūs varat ieprogrammēt tastatūras augšuptaustiĦu un lejuptaustiĦu. 

 Šī metode ir līdzīga peles ieprogrammēšanai, tikai” 

o Kolonnā Aktīvie Kontrolieri jāuzklikšėina uz Galvenā Tastatūra (Main Keyboard). 

o Kolonnā Notikums jāizvēlas Kursors Augšup (Cursor Up) pirmajam taustiĦam un Kursors 

Lejup (Cursor Down) otrajam taustiĦam. 

 Tad izmantojiet abus taustiĦus otas izmēra maiĦai. 
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7. Krāsu paletes 

Paletes ir atsevišėu krāsu komplekts. GIMP paletes izmanto diviem mērėiem: 

o Tās Ĝauj zīmēt ar izvēlēto krāsu komplektu, līdzīgi kā mākslinieks glezno ar ierobežotu krāsu 

tūbiĦu skaitu. 

o Tās veido krāsu kartes un indeksētus attēlus. Indeksēts attēls var izmantot tikai 256 dažādas 

krāsas, bet tās var būt jebkādas. Indeksēta attēla krāsu karte GIMP tiek saukta par „indeksēto 

paleti”. 

Neviena no šīm funkcijām netiek izmantota bieži – ir iespējams radīt sarežăītus attēlus neizmantojot 

paletes. Tomēr pieredzējušam lietotājam tās būtu jāsaprot, piemēram, strādājot ar GIF formāta failiem. 
 

Ilustrācija 6. 13. Paletes dialogs 

 
 

GIMP instalācijā ir vairāki duči palešu, bet Jūs varat veidot arī savas. Dažas no oriăinālajām paletēm ir 

visai noderīgas, piemēram, „Web” palete, kas satur krāsas, kuras tiek uzskatītas par „web-drošām”. 

PiekĜūt paletēm var caur Palešu dialogu (Palettes Dialog). Šīs ir arī jaunas paletes veidošanas 

sākumpunkts. 
 

Ilustrācija 6.14. Paletes Redaktors 
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Dubultklikšėis uz paletes Palešu dialoglodziĦā izsauc Paletes Redaktoru (Palettes Editor), kas parāda 

izvēlētās paletes krāsas. Jūs to varat izmantot, lai zīmētu ar šīs paletes krāsām: klikšėis uz krāsas 

nomaina GIMP priekšplāna krāsu. Turot nospiestu Ctrl taustiĦu, varat nomainīt GIMP fona krāsu. 

Paletes Redaktoru var izmantot arī paletes krāsu mainīšanai, ja vien tā ir Jūsu izveidota palete. Nevar 

mainīt GIMP palešu krāsas, taču tās var kopēt un tad rediăēt. 

Kad izveidojat paleti ar Palešu Redaktoru, tās tiek automātiski saglabātas direktorijā palettes ar 

paplašinājumu .gpl pēc GIMP aizvēršanas. Tās tiks automātiski attēlotas Palešu dialogā pēc GIMP 

iedarbināšanas. 

 

7.1. Krāsu karte (Colormap) 

GIMP viedo divu veidu krāsu paletes. Pamanāmākās ir tās, kas redzamas Palešu dialogā: paletes, kas 

pastāv neatkarīgi no attēla. Otrs veids ir indeksētās paletes, kas veidojas no indeksētu attēlu krāsu 

kartēm. Katram indeksētam attēlam ir sava krāsu palete, kas definē attēlā redzamās krāsas, to 

maksimālais skaits ir 256. Šīs paletes sauc par indeksētām, jo katra tās krāsa tiek asociēta ar indeksa 

skaitli. 
 

Ilustrācija 6.15. Krāsu kartes dialogs 

 
 

Indeksēta attēla krāsu karti nevajadzētu jaut ar Palešu dialogu. Palešu dialogs parāda visas iespējamās 

paletes, Krāsu kartes dialogs parāda krāsu karti aktīvajam attēlam vienīgi, ja tas ir indeksēts. 

Jūs varat izveidot prastu paleti no indeksēta attēla krāsām (patiesībā, no jebkura attēla krāsām). Lai to 

izdarītu, jāizvēlas Importēt Paleti (Import Palette) no Palešu dialoga izvēlnes, ko izsauc ar peles labo 

pogu uz tā. Tas ir svarīgi, ja vēlaties izveidot indeksētus attēlus vienādās krāsās. 

Kad konvertējat attēlu uz indeksētu režīmu, rodas attēla indeksēta krāsu palete. 
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8. Vienkāršu objektu zīmēšana 

Šajā nodaĜā Jūs iemācīsieties zīmēt vienkāršus objektus GIMP. Tas ir vienkārši, tiklīdz sapratīsies, kā 

tas darāms. GIMP piedāvā milzīgu rīku komplektu, kurā vairums iesācēju var apmaldīties. 

8.1. Taisnas līnijas zīmēšana 

Sāksim ar taisnas līnijas zīmēšanu. Vienkāršākais veids, kā to izdarīt ir izmantojot Jūsu iecienītāko 

zīmēšanas rīku, peli un tastatūru. 
 

Proced ūra 6.1. Taisnas l īnijas z īmēšana 

1. Izveidojiet jaunu attēlu. Izvēlieties iemīĜotāko zīmēšanas rīku vai lietojiet zīmuli, ja neesat droši. 

Izvēlieties priekšplāna krāsu un pārliecinieties, ka priekšplāna un fona krāsas atšėiras. 
 

 

Ilustrācija 6.16. Dialogā redzams jauns attēls ar baltu fonu 

 
 

2. Izveidojiet līnijas sākumpunktu, noklikšėinot uz attēla loga ar kreiso peles pogu. 
 

Ilustrācija 6.17. Dialogs ar jaunizveidoto attēlu un līnijas sākumpunktu melnā krāsā 

 
 

3. Turiet Shift taustiĦu uz klaviatūras un pārvietojiet peles kursoru prom no sākuma punkta. Jūs 

redzēsiet tievu palīglīniju, kas sniegs priekšskatu par galarezultātu. 
 

Ilustrācija 6.18. EkrānuzĦēmums ar palīglīniju, kas nosaka pabeigtas līnijas izskatu 
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4. Ja Jūs apmierina līnijas garums un virziens, atkārtoti nospiediet peles kreiso pogu, lai pabeigtu līniju. 

Tagad GIMP attēlo taisnu līniju. Ja tā neparādās, pārliecinieties, vai fona un priekšplāna krāsas atšėiras 

un pārliecinieties, vai turējāt Shift taustiĦu nospiestu. 
 

Ilustrācija 6.19. Pabeigta līnija 

 
 

8.2. Vienkāršas formas zīmēšana 

1. Formu zīmēšana nav GIMP galvenais nolūks, tomēr Jūs varat zīmēt formas vai nu tās uzzīmējot 

(Ilustrācija 6.16.), vai izmantojot atlases rīkus. Protams, ir daudz veidu, ka uzzīmēt formas, taču mēs 

pieturēsimies pie vienkāršākajiem. Tātad, izveidojiet jaunu attēlu un pārliecinieties, ka priekšplāna un 

fona krāsas atšėiras. 

2. Pamatformas, kā taisnstūri un elipses, var uzzīmēt izmantojot atlases rīkus. Izvēlieties Taisnstūra 

Atlases rīku (Rectangular Selection Tool) un izveidojiet jaunu atlasi: nospiediet un turiet peles kreiso 

pogu, kamēr pārvietojat kursoru. Atlase izveidojas, kad atlaižat peles pogu. 
 

Ilustrācija 6.20. Nospiediet un turiet kreiso peles pogu un pārvietojiet kursoru sarkanās bultas virzienā 

 
 

3. Pēc atlases izveides, Jūs varat izveidot vainu aizpildītu vai apvilktu taisnstūri Jūsu izvēlētajā 

priekšplāna krāsā. Ja izvēlējāties pirmo iespēju, izvēlieties priekšplāna krāsu un aizpildiet atlasi ar 

SpaiĦa Aizpildīšanas rīku (Bucket Fill Tool). Ja izvēlējāties otro iespēju, izveidojiet kontūru izmantojot 

komandu Apvilkt atlasi (Stroke Selection) no izvēlnes Rediăēt (Edit). Ja rezultāts Jūs apmierina, 

noĦemiet atlasi. 

Ilustrācija 6.21. Taisnstūra atlase aizpildīta ar priekšplāna krāsu 

 



 

68 

7. noda Ĝa ATTĒLU SAVIETOŠANA 

1. Iepazīšanās ar slāĦiem 

Labs veids, kā vizualizēt GIMP attēlu ir to iedomāties kā caurspīdību grēdu: GIMP terminoloăijā, katra 

caurspīdība tiek saukta par slāni. SlāĦu skaits attēlā ierobežo tikai datora atmiĦas daudzums. 

Pieredzējuši lietotāji bieži izmanto dučiem slāĦu. 

SlāĦu izkārtojums attēlā ir atspoguĜots SlāĦu dialogā (Layers dialog), kas ir nozīmīgākais GIMP dialogs 

pēc Rīku joslas. 

Ja slānis ir aktīvs, tas SlāĦu dialogā ir izcelts. Jūs to varat aktivizēt, noklikšėinot uz tā. 

Izvēlnes joslā virs attēla atrodas izvēlne SlāĦi (Layers), kur atrodas komandas, kas ietekmē aktīvo slāni. 

Šo izvēlni var izsaukt arī ar labo peles pogu noklikšėinot uz SlāĦu dialoga. 
 

1.1. SlāĦu parametri (Layer properties) 

Katram attēla slānim ir svarīgas sastāvdaĜas: 

Nosaukums 

Katram slānim ir nosaukums. Tas tiek ăenerēts automātiski līdz ar slāĦa izveidošanos, bet Jūs to 

varat mainīt. To var izdarīt vai nu ar dubultklikšėi uz tā SlāĦu dialogā vai ar labo peles pogu 

izsaucot SlāĦu dialoga izvēlni un izvēloties Rediăēt SlāĦa Īpašības (Edit Layer Attrobutes). 

Alfa kan āla (ne)esam ība (presence of alpha channel ) 

Alfa kanālā atrodas informācija par katra pikseĜa caurspīdību. Tas ir redzams Kanālu dialogā 

(Channel dialog): balts ir intensīvs, melns ir pilnīgi caurspīdīgs un pelēks ir daĜēja caurspīdība. 

Fona slānis ir īpašs. Ja tikko esat izveidojis jaunu attēlu, tam ir tikai viens – fona – slānis. Ja attēlā 

ir izmantota daĜēja aizpildīšanas metode, šim slānim nav alfa kanāla. Ja pievienojat vēl vienu 

slānim, pat ar daĜēju aizpildīšanu, alfa kanāls tiek izveidots automātiski un tiek piemērots visiem 

slāĦiem, izĦemot fona slāni. Lai iegūtu fona slāni ar caurspīdību, Jums ir vai nu jāizveido jauns 

attēls ar daĜēju aizpildīšanu (transparent fill) vai jāpievieno alfa kanāls. 

Katram slānim, izĦemot fona slāni, jābūt alfa kanālam, tas nav obligāts fona slānim. Daudzas 

operācijas nevar veikt slānim bez alfa kanāla. Pārvietojot slāni uz citu vietu slāĦu grēdā ir viens no 

piemēriem, jo tikai pamata slānis drīkst būt bez alfa kanāla. Alfa kanālu var pievienot, izmantojot 

izvēlnes komandu SlāĦi→Caurspīdība→Pievienot Alfa Kanālu (Layer→Transparency →Add Alpha 

Channel), vai ar labo peles pogu no SlāĦu dialoga izsaucot izvēlni ar komandu Pievienot Alfa 

Kanālu.  

SlāĦa veids ( Layer type ) 

 SlāĦa veidu nosaka attēla veids un alfas kanāla esamība vai neesamība. Iespējamie slāĦu veidi: 

o RGB 

o RGBA 

o Pelēks (Gray) 

o PelēksAlfa (grayA) 

o Indeksēts (Indexed) 
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o IndeksētsAlfa (Indexed A) 

Tas ir svarīgi, jo vairums filtru (izvēlnē Filtri (Filters)) pieĦemt tikai dažus slāĦu veidus un tiek 

attēloti pelēki aktīvā attēla izvēlnē. To var mainīt, nomainot attēla režīmu vai noĦemot vai 

pievienojot alfa kanālu. 

Redzam ība (Visibility ) 

 Ir iespējams uz laiku noĦemt slāni no attēla, neizdzēšot to – noklikšėinot uz acis simbola SlāĦu 

dialogā. To sauc par slāĦa „redzamības pārslēgšanu”. Daudzas operācijas attēlā nedarbojas uz 

neredzamiem slāĦiem, it kā tie neeksistētu. Kad strādājat ar attēlu, kuram ir daudz slāĦu ar dažādu 

caurspīdību, bieži vien slāĦa saturu var labāk redzēt, ja paslēpj citus slāĦus. 
 

PADOMS 

Ja klikšėinot uz slāĦa redzamības pogas turēsiet nospiestu Shift taustiĦu, tiks paslēpti visi slāĦi 

izĦemot izvēlēto. 

 Saite uz citiem sl āĦiem (Linkage ) 

 Ja noklikšėina starp acs ikonu un slāĦa sīktēlu, parādās ėēdes ikona, kas Ĝauj grupēt slāĦus 

darbībai ar vairākiem slāĦiem (piemēram, Pārvietošanas rīks (Move tool)). 
 

 

Ilustrācija 7.1. SlāĦu dialogs 
 

 
 

 

Izmērs (Size) 

GIMP slāĦa izmērs ne vienmēr sakrīt ar attēla izmēru. Ja izveidojat tekstu, piemēram, katra teksta 

vienība pārvietojas uz savu atsevišėi slāni, un slānis tiek samazināts, lai tajā iekĜautu tikai tekstu. 

Tāpat, kad izveidojat jaunu slāni izmantojot izgreizt-un-ielīmēt komandu, jaunais slānis pielāgojas 

ielīmētā slāĦa izmēram. Attēla logā aktīvā slāĦa robežas attēlotas ar dzelteni-melnu punktētu līniju. 

Tas ir svarīgi, jo Jūs nevarat mainīt slāni ārpus tā robežām: nevarat darboties ar to, kas nepastāv. 

Ja tas rada sarežăījumus, Jūs varat izmainīt slāĦa izmērus ar komandām, kas atrodas SlāĦu 

izvēlnē. 
 

PIEZĪME 

SlāĦa aizĦemtās atmiĦas izmērs ir atkarīgs to tā izmēra, nevis satura. Tāpēc, strādājot ar lieliem 

attēliem vai attēliem ar daudz slāĦiem, slāĦu samazināšana līdz minimumam var atmaksāties. 
 

 

Intensit āte (Opacity ) 

SlāĦa intensitāte nosaka apmēru, kādā tas Ĝauj apakšā esošajam slānim spīdēt cauri. Intensitāte 

svārstās no 0 līdz 100, kur 0 nozīmē pilnīgu caurspīdību, bet 100 – pilnīgu necaurredzamību. 
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Režīms (Mode ) 

SlāĦa režīms nosaka, kā slāĦa krāsas tiek savietotas ar zem tā esošā slāĦa krāsām. 

SlāĦa maska ( Layer mask ) 

Bez alfa kanāla ir vēl viens veids, kā kontrolēt slāĦa caurspīdību: pievienojot slāĦa masku, kas ir 

papildus pelēcīgais objekts, kas tiek piesaistīts slānim. Slānim pēc noklusējuma nav maskas: tā 

jāpievieno pašam. 

Uzstādījums „Aizsl ēgt Alfa kan ālu” ( Lock Alpha Channel ) 

SlāĦu dialoga augšējā kreisajā stūrī ir maza izvēles rūtiĦa, kas kontrolē „Slēdzenes” uzstādījumus 

attiecībā uz slāĦa caurspīdību. Ja tajā ir ėeksītis, alfa kanāls ir aizslēgts un nevar tikt pakĜauts 

nekādām manipulācijām.  
 

Ilustrācija 7.2. Aizslēgt alfa kanālu 

 
 

2. Jaunu slāĦu veidošana 

Ir vairāki veidi, kā attēlam izveidot jaunu slāni. Mēs apskatīsim tikai svarīgākos: 

o Izvēloties Slānis→Jauns slānis (Layer→New Layer) no attēla loga izvēlnes. Parādās 

dialoglodziĦš, kas Ĝauj uzstādīt jaunā slāĦa parametrus. 

o Izvēlties Slānis→Dublēt slāni (Layer→Duplicate Layer) attēla loga izvēlnē. Tas rada jaunu slāni, 

kas ir aktīvā slāĦa perfekta kopija un novietojas virs tā. 

o Kad jūs „izgriežat” vai „kopējat” kaut ko, un tad to ielīmējat izmantojot Ctrl+V vai Rediăēt→Ielīmēt 

(Edit→Paste), rezultātā rodas „peldoša atlase”, kas pati par sevi ir pagaidu slānis. Pirms Jūs 

varat veikt citas darbības, šī peldošā atlase ir vai nu jānoenkuro jau eksistējošā slānī, vai tā 

jāpārvērš par parastu slāni. Izvēloties pēdējo variantu, slānis tiks samazināt līdz ielīmētā objekta 

izmēram. 
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3. Teksts un Fonts 
 

Ilustrācija 7.3. Teksta vienības piemērs 

 
Teksta vienības piemērs, kas parāda teksta slāĦa robežas. (Fonts: Utopia Bold) 

 

GIMP 2.0. galvenais uzlabojums bija spēja atbalstīt tekstu. Katra teksta vienība veido atsevišėu Teksta 

slāni, tāpēc Jūs vienmēr varat atgriezties pie teksta slāĦa un rediăēt to. Tāpat iespējams tekstu pārvietot 

attēlā, mainīt tā fontu vai izmēru. Var izmantot jebkuru Jūsu datorā esošo fontu. Iespējama arī 

izlīdzināšana un rindu atstarpes maiĦa. 

Teksta slānī var veikt visas tās pašas darbības, kas parastajā slānī. 
 

Ilustrācija 7.4. GIMP teksta redaktors 

 
 

Lai labāk saprastu dažas teksta apstrādes īpatnības, ir jāsaprot, ka teksta slānī atrodas ne tikai dati par 

pikseĜiem, bet arī teksta attēlojums redaktora formātā. To var aplūkot teksta redaktora lodziĦā, kas 

parādās, izmantojot Teksta rīku (Text tool). 

PieĦemsim, esat izveidojis teksta slāni un tad operējat ar to tāpat kā ar parastu slāni neizmantojot 

Teksta rīku – piemēram, to pagriežat. PieĦemsim, vēlāk Jūs atgriežaties pie šī slāĦa, lai to rediăētu ar 

teksta redaktoru. Tiklīdz tas notiek, Teksta rīks pārraksta slāni un dzēš visus pārējos, starp teksta 

rediăēšanu veiktos rezultātus. 

Šī darbība nav pašsaprotama, tāpēc Teksta rīks centīsies Jūs no tā pasargāt. Ja veicat darbības teksta 

slānī un vēlāk mēăināt rediăēt tekstu, parādās ziĦojums, kas brīdina par to, ka Jūsu veiktās izmaiĦas tiks 

atsauktas un piedāvā trīs iespējas: (1) rediăēt tekstu, (2) atcelt rediăēšanu, (3) izveidot jaunu teksta slāni 

ar to pašu tekstu, kas ir jau esošajā slānī, atstājot eksistējošo slāni bez izmaiĦām. 
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Ilustrācija 7.5. Brīdinājums par izmaiĦu atsaukšanu 
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8. noda Ĝa FOTOGRĀFIJU UZLABOŠANA 

1. Darbs ar fotogrāfijām no digitālās fotokameras 

1.1. Ievads 

Viens no GIMP izplatītākajiem pielietojumiem ir digitālo fotogrāfiju uzlabošana. Iespējams fotogrāfija ir 

pārgaismota vai pārāk tumša, nedaudz sašėiebta vai tai trūkst asuma – visiem šiem sarežăījumiem 

GIMP piedāvā veselu lērumu rīku. Šīs nodaĜas mērėis ir iepazīstināt Jūs ar šiem rīkiem un sniegt 

priekšstatu par šo rīku pielietojumu. Šeit Jūs neatradīsiet sīki aprakstītas pamācības to lietošanā, jo 

vislabākais veids, kā iemācīties ar tiem rīkoties, ir izmēăināt pašam, nevis lasīt par tiem. Tāpat šajā 

nodaĜā nav aprakstīti „specefekti”, ko GIMP var piemērot attēliem. Pirms sākat lasīt šo nodaĜu, Jums 

būtu jābūt priekšstatam par GIMP, taču Jums nav jābūt lietpratējam – ja esat, noteikti visu turpmāk 

rakstīto jau zināt. Nebaidieties eksperimentēt, jo GIMP uzlabotā „atsaukšanas” (undo) sistēma Ĝauj labot 

gandrīz visas kĜūdas ar vienkāršu Ctrl+Z taustiĦu kombināciju. 

Visizplatītākās nepatikšanas ar digitālajām fotogrāfijām pamatā ir trīs veidu: kompozīcijas uzlabošana, 

krāsu uzlabošana, ausuma uzlabošana un lieko priekšmetu izĦemšana no attēla. 
 

1.2. Kompozīcijas uzlabošana 

1.2.1. Attēla pagriešana (Rotating an Image) 

Fotografējot bieži ir grūti noturēt kameru perfekti vertikāli, kā rezultātā rodas fotogrāfija, kurā daži objekti 

ir sašėiebti uz vienu vai otru pusi. GIMP veids, kā to labot ir Rotēšanas rīka (Rotate tool) izmantošana. 

Aktivizējiet to, nospiežot  ikonu Rīku joslā, vai nospiežot Shift+R attēla logā. Pārliecinieties, ka Rīka 

opcijas (Tool Options) ir redzamas un tajās ir nospiesta kreisā poga Transformēt slāni (Transform 

Layer). Tad noklikšėiniet uz attēla un izlecošajā logā pārbīdiet slīdni, līdz esat apmierināts ar rezultātu, 

un nospiediet Enter taustiĦu vai pogu Rotēt (Rotate), lai apstiprinātu pagriešanu. 

Pēc šīs metodes nav viegli iegūt vēlamo rezultātu, tāpēc iespējams vēlēsieties attēlu pagriezt vēlreiz, bet 

tam ir savs mīnuss. Katru reizi, kad pagriežat attēlu, tā pikseĜi izkārtojas citādi un attēls kĜūst mazliet 

neskaidrs. Vienai pagriešanas reizei šīs izmaiĦas nav būtiskas, taču ar katru nākamo attēls kĜūst divtik 

izplūdušāks. Nav iemesla izpludināt attēlu vairāk, kā nepieciešams, tāpēc, ja rezultāts Jūs neapmierina, 

atsauciet to un mēăiniet vēlreiz. 

Par laimi, GIMP piedāvā vēl vienu veidu pagriešanas labošanai – tas atrodas zem Rīka opcijām un tā 

nosaukums ir „Labojošs„ (Corrective). Tā vietā, lai pagrieztu attēlu kĜūdas kompensēšanai, šī opcija 

„seko” jau veiktajām izmaiĦām. Tas var šėist mulsinoši, bet izmēăiniet un redzēsiet, cik tas ir vienkārši. 
 

PIEZĪME 

Kopš GIMP versijas 2.2. tajā ir opcija, kas Ĝauj aplūkot pagriešanas rezultāta priekšskatījumu un sekot 

tam attēla logā. Tas palīdz pagriešanu veikt precīzi jau ar pirmo piegājienu. 
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Pēc tam, kad esiet pagriezis attēlu, tā stūros parādīsies neglīti trīsstūrveida „caurumi”. Vieno no veidiem, 

kā to labot, ir fonu nokrāsot kādā neitrālā krāsā, tādā veidā tos aizpildot. Taču visbiežāk labāks 

risinājums ir attēla apcirpšana. Jo vairāk attēls sagriezts, jo vairāk tas jāapcērt, tāpēc vēlams jau attēla 

uzĦemšanas brīdī turēt kameru pēc iespējas taisnāk. 
 

1.2.2. Apcirpšana (Cropping) 

Kad fotografējat ar digitālo fotokameru, Jūs varat kontrolēt, vai objekts tiks vai netiks iekĜauts kadrā, taču 

bieži ar to ir par maz un rezultāts ir fotogrāfijas, kurām nepieciešama malu apgriešana. Bieži iespējams 

uzlabot attēla izskatu, apgriežot liekās malas tādējādi izceĜot galvenos objektus. 

Lai apcirptu attēlu, aktivizējiet Apcirpšanas rīku (Crop tool) Rīku joslā vai nospiežot C taustiĦu attēlā. 

Kad rīks ir aktivizēts, turot nospiestu peles kreiso pogu, uzvelciet taisnstūri – malas, kas atrodas ārpus tā 

tiks nogrieztas. Jūs varat pielāgot taisnstūra izmērus, pavelkot to aiz malām. Kad rezultāts Jūs 

apmierina, veiciet dubultklikšėi uz tā un liekās malas pazudīs. 

1.3. Krāsu uzlabošana 

1.3.1. Automatizētie rīki 

Par spīti jaunāko digitālo fotokameru gaismas un krāsu kontroles sistēmām, fotogrāfijas bieži iznāk 

pārgaismotas vai pārāk tumšas. GIMP piedāvā lērumu rīku, kas paredzēti attēla krāsu labošanai – sākot 

ar automatizētiem, kas darbojas ar vienkāršu peles klikšėi, līdz pat sarežăītiem rīkiem, kas piedāvā 

daudzu parametru pielāgošanu. Sāksim ir vienkāršākajiem. 

GIMP piedāvā vairākus automatizētus krāsu labošanas rīkus. Diemžēl tie ne vienmēr sniedz gaidāmo 

rezultātu, taču to darbināšanai nepieciešams tikai klikšėis, un, sliktākajā gadījumā, tie sniedz priekšstatu 

par attēla krāsu mainīšanas iespējam. Šos rīkus var atrast attēla izvēlnē Krāsas→Automātiski 

(Colors→Automatic). 

Īsumā par katru no tiem: 

Normaliz ēt (Normalize ) 

Šis rīks (patiesībā, spraudnis) piemērots pārāk tumšām fotogrāfijām: tas vienmērīgi piemēro visu 

attēlu, līdz tā gaišāka vieta ir maksimāli piesātināta un tumšākā vieta ir melna. Negatīvā puse ir tā, 

ka gaišo laukumu daudzumu nosaka visgaišākais punkts visā attēlā, tāpēc viens vienīgs 

balts/melns pikselis var šo procesu padarīt neefektīvu. 

Nol īdzināt (Equalize ) 

Šis ir Ĝoti spēcīgs koriăēšanas veids, kas cenšas vienmērīgi izlīdzināt attēla krāsas, Ħemot vērā 

iespējamo intensitāti. Reizēm šis efekts ir pārsteidzošs un Ĝauj saskatīt kontrastus, kas citos veidos 

nav panākmai, ta’vu visbiežāk tas lieka attēlam izskatīties dīvaini. Bet galu galā, tā izmēăināšanai 

nepieciešams tikai mirklis. 

Krāsu izcelšana ( Color Enchance ) 

Šī komanda palielina slāĦa krāsu piesātinājumu bez gaišuma vai nokrāsas mainīšanas. Šī 

komanda nedarbojas pelēcīgajos attēlos. 
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Paplašin āt Kontrastu ( Stretch Contrast ) 

Tas darbojas līdzīgi kā „Normalizēt”, tikai tas iedarbojas atsevišėi uz sarkanā, zaĜā un zilā 

kanāliem. Tas bieži noder krāsu plankumu samazināšanai. 

Paplašin āt HSV (Stretch HSV ) 

Darbojas tāpat kā „Paplašināt kontrastu”, bet strādā HSV krāsu laukumos, nevis RGB. Tas saglabā 

nokrāsu. 

Balt ā līdzsvars ( White balance ) 

Tas var uzlabot attēlus, kuros ir maz baltā vai melnā, jo šī opcija nedaudz samazina izmantotās 

krāsas. 

Autom ātiskie l īmeĦi (Auto levels ) 

Aktivizē LīmeĦu rīku (Levels tool) - Rīki→Krāsu Rīki→LīmeĦi (Tools→Color Tools→Levels) vai 

Krāsas→LīmeĦi (Colors→Levels) attēla loga izvēlnē, un nospiežot Auto pogu dialoga centrā. Tas 

Ĝauj apskatīt rezultāta priekšskatījumu, tāpēc jānospiež OK poga, lai veiktu izmaiĦas attēlā. 

Savukārt poga Atcelt (Cancel) atgriezīs attēlu sākuma izskatā. 
 

Tie ir automatizētie attēla krāsu rediăēšanas rīki – ja neviens no tiem Jums nesniedz vēlamo rezultātu, ir 

laiks izmēăināt kādu no interaktīvajiem krāsu rīkiem. Tie visi, izĦemot vienu, ir atrodami attēla loga 

izvēlnē Rīki→Krāsu rīki (Tools→Color Tools). Pēc krāsu rīka izvēlēšanās, noklikšėiniet uz attēla, lai 

izsauktu tā dialoglodziĦu. 

1.3.2. Problēmas ar ekspozīciju 

Vienkāršākais rīks ir Gaišuma/Kontrasta rīks (Brightness/Contrast tool). Tas ir arī viens no mazāk 

iedarbīgākajiem, tomēr vairumā gadījumu tas ir viss, ko Jums vajadzēs. Šo rīku parasti izmanto 

pārgaismotām vai pārāk tumšām fotogrāfijām, taču tas nedarbojas ar krāsu plankumiem. Šīs rīks 

piedāvā divus pielāgošanas slīdĦus – Gaišumam (Brightness) un Kontrastam (Contrast). Ja esat 

atėeksējis opciju ”Priekšskatījums” (Preview), varēsiet sekot izmaiĦām attēla logā. Kad esat apmierināts 

ar izmaiĦām, nospiediet OK un tās iedarbosies uz attēlu, savukārt, ja neesat apmierināts, poga Atcelt 

(Cancel) atgriezīs attēlam sākotnējo izskatu. 

Sarežăītāks, taču tikai nedaudz grūtāks, ekspozīcijas pielabošanas veids ir LīmeĦu rīka (Levels tool) 

izmantošana. Šī rīka dialogs izskatās Ĝoti sarežăīts, taču pamatā darbosimies tikai ar „Ievades LīmeĦu” 

(Input Levels) lauciĦu – ar trīs trīsstūrveida slīdĦiem zem histogrammas. Vieglākais veids, kā saprast šo 

slīdĦu ietekmi uz attēlu, ir pārliecināties, ka ir ieslēgta priekšskatījuma (preview) opcija, un vērot attēlu. 

1.3.3. Nokrāsas un Piesātinājuma pielāgošana (Adjusting Hue and Saturation) 

Ja attēlā ir par daudz sarkanā, zaĜā vai zilā, vieglākais veids, kā to labot, ir LīmeĦu rīka (Levels tool) 

izmantošana, atsevišėi pielāgojot sarkanā, zaĜā un zilā kanāla līmeĦus. Ja Jūsu gadījumā tas 

nedarbojas, vērts pamēăināt Krāsu līdzsvara (Color balance) rīku, bet tā efektīva izmantošana ir grūtāka. 

Reizēm ir grūti novērtēt, vai esat pienācīgi pielāgojis krāsas. Viegla, objektīva tehnika ir atrast attēlā 

laukumu, par kura krāsu (baltu vai pelēkā nokrāsu) Jūs esat pilnīgi drošs. Tad aktivizējiet Pipetes rīku 

(Color Picker) un noklikšėiniet uz iepriekšminētā laukuma, kas atvērs šī rīka dialogu. Ja krāsas ir korekti 
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pielāgotas, tad sarkanā, zaĜā un zilā daudzums šajā krāsā ir vienāds, ja nav – pielabojiet kādu no tiem. 

Šis paĦēmiens, lietots korekti, Ĝauj pielāgot attēla krāsas pat cilvēkiem ar krāsu uztveres traucējumiem. 

Ja fotogrāfija ir blāva, kas bieži gadās, fotografējot spilgtā gaismā, izmēăiniet Nokrāsas/Piesātinājuma 

(Hue/Saturation) rīku, kas piedāvā trīs slīdĦus Nokrāsai (Hue), Gaišumam (Lightness) un 

Piesātinājumam (Saturation). Piesātinājuma palielināšana visticamāk uzlabos attēla izskatu. Dažos 

gadījumos būs nepieciešams pielabot arī gaišumu. Nokrāsas/Piesātinājuma rīks Ĝauj pielāgot atsevišėu 

krāsu virknes (izmantojot pogas dialoga augšā), taču, ja vēlaties dabiskas krāsas, Jums nevajadzētu 

izmantot šo iespēju. 
 

PADOMS 

Pat tad, ja attēls neizskatās blāvs, palielinot piesātinājumu, tā izskatu var būtiski uzlabot. 
 

Kad fotografējat sliktas gaismas apstākĜos, var rasties pretēja problēma – par daudz piesātinājuma. 

Tādā gadījumā Nokrāsas/Piesātinājuma rīks noder piesātinājuma samazināšanai. 

1.4. Asuma pielāgošana (Adjusting Sharpness) 

1.4.1. Atmiglošana (Unblurring) 

Ja fotokamera nav labi nofokusēta vai tā atradās kustībā fotogrāfijas uzĦemšanas brīdī, rodas miglaina 

bilde. Ja attēls ir Ĝoti izplūdis, diez vai Jums izdosies to labot, taču tikai nedaudz miglainas bildes ir 

iespējams uzlabot. 

Visplašāk izmantotā metode ir Atasināšanas Maskas (Unsharp Mask) izmantošana. Tas ir spraudnis, 

kas atrodas attēla loga izvēlnē Filtri→Uzlabot→Atasināšanas Maska (Filters→Enchance→Unsharp 

Mask). Tam ir divi parametri – „Rādiuss” (Radius) un „Daudzums” (Amount). Noklusējuma vērtības bieži 

vien strādā labi tāpēc vispirms būtu jāizmēăina tās. Rādiusa vai daudzuma palielināšana pastiprina 

efektu. Taču ar to nevajadzētu aizrauties, jo pārāk liels rādiuss vai daudzums var kaitēt attēlam, padarot 

to graudainu. 

Blakus „Atasināšanas maskai” Filtru izvēlnē atrodas vēl viens filtrs – Saasināt (Sharpen), kas dara 

gandrīz to pašu. Ar to ir vieglāk strādāt, taču tas nav gana efektīvs un būtu jāizmanto Atasināšanas 

maska. 

Dažās situācijās, darbojoties ar attēla daĜām, labākus rezultātus var panākt, izmantojot Miglot vai 

Saasināt rīku (Blur or Sharpen) no Rīku joslas režīmā „saasināt” (sharpen). Tas Ĝauj palielināt asumu 

attēlā vienkārši zīmējot tam pāri ar jebkuru zīmēšanas rīku. Tomēr rezultāti mēdz izskatīties nedabīgi – 

saasināšana palielina acīmredzamas robežas, bet paplašina „trokšĦus”. 

1.4.2. Graudainības samazināšana (Reducing graininess) 

Kad uzĦemt fotogrāfijas tumšos apstākĜos vai ar Ĝoti ātru ekspozīciju, kamerai netiek dots pietiekami 

daudz datu par katra pikseĜa patieso krāsu, tāpēc iegūtā fotogrāfija izskatās graudaina. Jūs varat 

izlīdzināt šo graudainumu, aizmiglojot attēlu, taču līdz ar to zaudējot arī asumu. Ir pāris paĦēmieni, kas 

varētu sniegt labākus rezultātus. Iespējams, labākais variants ne pārāk graudainam attēlam ir izmantot 

filtru ar nosaukumu Izvēles Migla (Selective Blur), noregulējot apmiglošanas rādiusu uz 1 vai 2 
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pikseĜiem. Otrs variants ir lietot Attīrīšanas (Despeckle) filtru. Tam ir priekšskatījuma iespēja, tāpēc varat 

spēlēties ar dažādiem uzstādījumiem, līdz iegūstat apmierinošu rezultātu. Gadījumos, kad graudainība ir 

pārāk stipra, ir gandrīz neiespējami kaut ko labot. 

1.4.3. Mīkstināšana (Softening) 

Bieži gadās gluži pretēja problēma – attēls ir pārāk ass. Risinājums ir to mazliet aizmiglot – par laimi, tas 

ir izdarāms vieglāk nekā asināšana. Tā kā Jūs droši vien negribēsiet to pārāk aizmiglot, vienkāršākā 

metode ir Miglas (Blur) spraudnis, kas atrodas attēla loga izvēlnē Filtri→Miglot→Migla 

(Filters→Blur→Blur). Tas nedaudz mīkstinās attēla fokusu. Ja vēlaties lielāku apmiglošanu, atkārtojiet šo 

darbību, līdz iegūstat apmierinošu rezultātu. 

1.5. Nevēlamu objektu izĦemšana no attēla 

Ir divu veidu objekti, ko Jūs vēlēsieties izĦemt no attēla: netīrumu pēdas, piemēram, pie objektīva pielipis 

mats vai putekĜi; vai reāli objekti, kas sabojā skatu, piemēram, telefona vads skaistas kalnu ainavas stūrī. 

1.5.1. Attīrīšana 

Lielisks veids, kā noĦemt putekĜus un citus netīrumus ir Attīrīšanas (Despeckle) filtrs, kas atrodas attēla 

loga izvēlnē Filtri→Uzlabot→Attīrīšana (Filters→Enchance→Despeckle). Svarīgi: lai šo filtru efektīvi 

izmantotu, Jums ir jāizveido maza atlase, kas satur nevēlamo objektu un nelielu laukumiĦu tam apkārt. 

Ja mēăināsiet piemērot Attīrīšanas filtru visam attēlam, Jums nekas nesanāks. Kad esat izveidojis 

piemērotu atlasi, aktivizējiet Attīrīšanu un vērojiet priekšskatījumu, pielāgojot parametrus. Ja paveicas, 

var pilnībā izdzēst netīrumu daudz nemainot tā fonu. Jo vairāk netīrums izceĜas uz fona, jo labākus 

rezultātus iegūsiet. Ja nekas nesanāk, ir vērts atcelt filtru, izveidot jaunu atlasi un mēăināt vēlreiz. 

Ja attēlā ir vairāk kā viens netīrums, Attīrīšanas filtrs jāpiemēro katram atsevišėi. 

1.5.2. Netīrumu noĦemšana 

Lietderīgākā gružu aizvākšanas metode ir  klonēšanas rīka (Clone tool) izmantošana, kas Ĝauj 

pārzīmēt pāri vienam attēla laukumiĦam, izmatojot pikseĜu datus no cita apgabala (vai pat cita attēla). 

Efektīvas klonēšanas rīka izmantošanas noslēpums ir atrast tādu laukumu, no kura varētu „pārkopēt”  

kādu daĜu – ja nevēlamā objekta fons Ĝoti atšėiras no pārējā attēla, diez vai kaut kas iznāks. Piemēram, 

Jums ir jauna pludmales ainava ar nevēlamu cilvēku, kuru Jūs vēlētos aizteleportēt projām, Jūs droši 

vien varēsiet atrast tukšu vietu pludmalē, kas izskatās līdzīgi cilvēka fonam, un izmantot to, lai 

„izkrāsotu” šo cilvēku. Ja viss nostrādā, rezultāti ir pārsteidzoši. 

Sākumā šis process var likties sarežăīts, taču ar laiku Jūs ietrenēsieties. 

Vēl viens Klonēšanas rīkam līdzīgais rīks ir Dziedēšanas rīks (Healing tool), kas arī par piemēru 

klonēšanai Ħem Jūsu izvēlētu attēla daĜu. Parasti to lieto krunciĦu un citu nenozīmīgu detaĜu slēpšanai. 
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1.5.3. Sarkano acu labošana 

Kad fotografējot lietojat zibspuldzi un cilvēks skatās tieši uz to, acs atstaro gaismu un liek tai izskatīties 

sarkanai – tas ir t.s. „sarkano acu” efekts, kas izskatās Ĝoti dīvaini. Daudzām modernajām kamerām ir 

īpaša zibspuldze, kas to daĜēji novērš, taču rezultāti ne vienmēr ir apmierinoši. Līdzīgs efekts rodas arī 

fotografējot dzīvniekus, taču to acis parasti izskatās zaĜas vai dzeltenas. 

GIMP piedāvā īpašu Sarkano acu noĦemšanas (Remove red eye) filtru. Ar vienu no atlases rīkiem 

izveidojiet atlasi, kas satur sarkano aci un izvēlieties „Sarkano acu noĦemšanas” filtru. Iespējams Jums 

būs nedaudz jāpārvieto slīdnis, lai pielāgotu krāsu. 

1.6. Rezultātu saglabāšana 

1.6.1. Faili 

Kādā formātā būtu jāsaglabā attēls un vai nepieciešams to samazināt? Atbilde ir atkarīga no tā, kur Jūs 

grasāties attēlu izmantot. 

o Ja grasāties atkārtoti atvērt attēlu GIMP un turpināt darbu ar to, Jums tas būtu jāsaglabā XCF 

formātā, jo tas ir vienīgais formāts, kas saglabā visu informāciju par attēlu. 

o Ja vēlaties attēlu drukāt uz papīra, būtu jāizvairās no tā samazināšanas, izĦemot apcirpšanu. 

Iemesls tam ir fakts, ka printeru izšėirtspēja ir lielāka nekā monitoru. 3000x5000 pikseĜu liels 

attēls uz ekrāna izskatās milzīgs, taču uz papīra tas ir tikai 13x20 cm liels 600dpi izšėirtspējā. 

Attēla palielināšanai arī nav jēgas – tā Jūs nevarat palielināt tā izšėirtspēju, tikai izmēru uz 

papīra. Runājot par faila formātu, piemērotākais ir JPEG kvalitātē 75 vai 85. Retos gadījumos, 

kas attēlā ir lieli laukumi vienmērīgā krāsā, būtu labāk lietot saudzīgāko TIFF formātu. 

o Ja vēlaties attēlu rādīt uz ekrāna vai video projektora, paturiet prātā, ka vairumam sistēmu lielākā 

ekrāna izšėirtspēja ir 1600x1200 pikseĜi, tāpēc nav nepieciešami lielāki attēli. Izmantojiet JPEG 

formātu. 

o Ja vēlaties attēlu ievietot internetā vai sūtīt pa e-pastu, būtu maksimāla jāsamazina faila izmērs. 

Pirmkārt, maksimāli samaziniet attēlu, lai nezūd detaĜas. Otrkārt, saglabājiet attēlu JPEG formātā 

ar zemāko pieĦemamo kvalitāti. 

1.6.2 Attēlu izdrukāšana 

Vairumā programmu, tai skaitā GIMP, lai drukātu galvenajā izvēlnē jāizvēlas Fails→Drukāt (File→Print). 

Ir pāris lietas, kas būtu jāpatur prātā, lai iegūtu labu rezultātu: 

o Uz ekrāna attēls tiek attēlots RGB režīmā, taču drukāšana notiek CYMK režīmā – rezultāts uz 

papīra atšėirsies no monitora krāsu ziĦā. 

o Ekrāna izšėirtspēja vidēji ir no 75 līdz 100dpi, bet printera izšėirtspēja ir vairāk kā 10x augstāka. 

Izdrukātā attēla izmērs ir atkarīgs no pieejamo pikseĜu skaita un izšėirtspējas, tāpēc tas var 

nesakrist ar izmēru uz ekrāna un nav atkarīgs no papīra formāta. 
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Tātad, pirms drukāšana nepieciešams iet uz Attēls→Drukas izmērs (Image→Print size) un izvēlēties 

ērtāko izvades izmēru, pielāgojot vai nu tā izmēru vai izšėirtspēju – Jūs redzēsiet, ka abas šīs vienības ir 

savstarpēji saistītas. 

Pēdējais ieteikums: pievērsiet izmēru malām un centrēšanas. Būtu nepatīkami, ja pārāk liela mala 

nogrieztu attēla daĜu, vai nepiemērota centrēšana sabojātu Jūsu darbu, it īpaši izmantojot īpašu 

fotopapīru. 
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III daĜa FUNKCIJAS 

9. noda Ĝa RĪKU JOSLA 

1. Rīku josla 

GIMP piedāvā visaptverošu rīku joslu, lai vairāk izmantotās darbības būtu viegli pieejamas. GIMP 

daudzie rīkjoslas rīki šeit ir sīki aprakstīti. 

GIMP ir plašs rīku klāsts, kas Ĝauj veikts dažādas darbības. Rīki iedalās piecās kategorijās: Atlases rīki 

(Selection tools), kas nosaka modifikācijai pakĜaujamo attēla daĜu; Zīmēšanas rīki (Painting tools), kas 

maina attēla laukumu krāsu; Pārveidošanas rīki (Transform tools), kas maina attēla ăeometriju; Krāsu 

rīki (Color tools), kas maina krāsu lietojumu attēlā; Citi rīki (Other tools), kas neietilpst minētajās 

kategorijās. 

Vairumu rīku aktivizē, nospiežot uz tā ikonas rīkjoslā. Citi, savukārt var tikt aktivizēti tikai caur Rīku 

(Tools) izvēlni. Jebkuru rīku aktivizē arī unikāla taustiĦu kombinācija. 

Noklusējuma uzstādījumā, ne visi rīki tiek attēloti kā ikonas rīkjoslā (trūkst krāsu rīku). Rīkjoslā 

attēlojamos rīkus var izvēlēties, izmantojot Rīku dialoglodziĦu. Tam ir divi iemesli: pirmkārt, ja kādu rīku 

izmantojat reti, iespējams pārējos rīkus atrast būtu daudz vieglāk, ja nebūtu lieku ikonu. Otrkārt, Ja bieži 

izmantojat Krāsu rīkus, būs parocīgāk, ja to ikonas būs viegli pieejamas. Katrā gadījumā, neatkarīgi no 

rīkjoslas, jebkuru rīku var aktivizēt caur Rīku (Tools) izvēlni. 

1.1. Rīku opcijas (Tool Options) 
 

Ilustrācija 9.1. Taisnstūra atlases Rīka opcijas 
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Ja neesat īpaši mainījis uzstādījumus, pēc rīka aktivizēšanas zem rīkjoslas parādās Rīka opciju dialogs. 
 

PADOMS 

Rīka opcijas pēc noklusējuma parādās zem rīkjoslas. Ja Jūs to kādā veidā pazaudējat, to var atgūt ar 

Fails→Dialogi→Rīka opcijas (File→Dialogs→Tool options) un tad dokojot to zem rīku joslas. Skatiet 

sadaĜu Dialogi un dokošana, lai iegūtu vairāk informācijas. 
 

Katram rīkam ir specifisks opciju komplekts. Jūsu izvēles tiek saglabātas līdz nākošajai mainīšanas 

reizei. Rīka opciju neatlaidība reizēm var būt kaitinoša, kad rīks uzvedas dīvaini un Jūs nevarat saprast 

kāpēc, līdz atceraties, ka šos dīvainos uzstādījumus lietojāt pirms divām nedēĜām. 

Zem Rīku opciju dialoga atrodas četras pogas: 
 

 Saglabāt opcijas k ā (Save options to ) 

Šī poga Ĝauj saglabāt izvēlētā rīka uzstādījumus, lai Jūs tos varētu izmanot vēlāk. Tā atver mazu 

dialogu, kas piedāvā izveidot nosaukumu opciju kopumam. Kad Atjaunojat (Restore) opcijas, 

parādās tikai saglabātie rīka komplekti, tāpēc nosaukumā nav jāiekĜauj rīka nosaukums. 

 Atjaunot opcijas ( Restore options ) 

Šī poga Ĝauj atjaunot iepriekš saglabātus rīka opciju komplektus. Ja rīkam nav saglabāts neviens 

opciju komplekts, poga nebūs pieejama. Citādi, tās nospiešana izsauks dialogu ar visu saglabāto 

komplektu nosaukumiem, kuru izvēlēšanās piemēros saglabātas opcijas.’ 

 Dzēst opcijas ( Delete options ) 

Šī poga Ĝauj dzēst iepriekš saglabātu opciju komplektus izvēlētajam rīkam. Ja dotajam rīkam nav 

saglabāts neviens opciju komplekts, poga nebūs pieejama. Citādi, tās nospiešana izsauks izvēlni 

ar visu saglabāto komplektu nosaukumiem, kur izvēlēšanās dzēsīs šos uzstādījumus. 

 Atsaukt opcijas ( Reset options ) 

Šī poga atsauc aktīvā rīka opcijas un atgriež to noklusējuma vērtības. 
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2. Atlases rīki 

2.1. Kopīgās raksturpazīmes 
 

Ilustrācija 9.2. Atlases rīki 

 
 

Atlases rīki ir domāti slāĦu laukumu atlasīšanai, kas Ĝautu veikt darbības tikai šo atlašu robežās. Katram 

rīkam ir savi specifisko uzstādījumi, taču visiem atlases rīkiem ir arī kopīgas īpašības. Šīs kopīgās 

īpašības ir aprakstītas tālāk.  

Ir septiĦi atlases rīki: 

o Taisnstūra atlase (Rectangle select) 

o Elipses atlase (Ellipse select) 

o Brīvā atlase jeb Laso (Free select/Lasso) 

o Saistīto laukumu atlase jeb Burvju nūjiĦa (Slect contigous regions/Magic wand) 

o Atlase pēc krāsas (Select by color) 

o Formu atlase jeb Gudrās šėēres (Intelligent Scissors) 

o Priekšplāna atlase (Foreground select) 

2.1.1. PārveidotājtaustiĦi (pēc noklusējuma) 

Atlases rīku uzvedību var mainīt, ja tos izmatojot tur nospiestu Ctrl, Shift vai Alt taustiĦu. 

PIEZĪME 

Pieredzējuši lietotāji bieži izmanto pārveidotājtaustiĦus, taču iesācējiem tie šėiet mulsinoši. Par laimi to 

vietā var izmantot arī Režīma pogas (Mode buttons). 
 

Ctrl 

Atlases veidošanas laikā turot nospiestu Ctrl taustiĦu, var iegūt dažādus rezultātus: 

o Ja turat nospiestu taustiĦu atlases zīmēšanas laikā, ieslēdzas opcija „Izplest no centra” 

(Expand form center). 

o Ja turat nospiestu tautiĦu pirms atlases zīmēšanas, atlase pārslēdzas uz AtĦemšanas 

režīmu (Substract). Tāpēc, tiklīdz atlaidīsiet peles pogu, jaunizveidotā atlase tiks izĦemta no 

jau esošās (ja tām ir kopīgi pikseĜi). 

Alt    
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Alt taustiĦa turēšana Ĝauj pārvietot tikai atlases kontūru. Ja tā vietā pārbīdās viss attēls, mēăiniet 

Shift+Alt. Ievērojiet, ka ne visas operētājsistēmas atbalsta Alt taustiĦu, tāpēc reizēm tas var 

nedarboties. 

Shift 

Shift taustiĦa turēšanai atlases izveides laikā var būt divas funkcijas: 

o Ja turat taustiĦu pirms sākat veidot atlasi, tā būs Pievienošanas režīmā (Addition mode). 

o Ja nospiežat taustiĦu pēc tam ,kad sākat veidot atlasi, efekts būs atkarīgs no izmantotā 

rīka. Piemēram, izmantojot Taisnstūra atlases rīku, tā būs kvadrātveida. 

Ctrl  + Shift  

Izmantojot Ctrl+Shift kopā, Jūs varat panākt dažādus rezultātus, atkarībā no izmantotā rīka. 

Visticamāk rezultātā izveidosies savstarpēji sakrustotas atlases, tāpēc pēc darbības beigām, 

atlases sastāvēs no sakrustotām atlasēm. Jums būtu vērtīgi pašam izmēăināt dažādas darbības ar 

Ctrl+Shift taustiĦu kombināciju, pēc peles pogas atlaišanas, atlaižot kādu vai abus taustiĦus. 

Pārveidot ājtausti Ħi atlases p ārvietošanai 

Ctrl+Alt+Klikšėis-un-pārvilkšana un Shift+Alt+Klikšėis-un-pārvilkšana tiek izmantoti, lai pārvietotu 

atlasi. 

2.1.2. Opcijas 

Šeit aprakstītas opcijas, kas kopīgas visiem atlases rīkiem. Šo opciju pašreizējos uzstādījumus var 

redzēt Rīka opciju dialogā, kas, darbojoties ar rīkiem, būtu vienmēr jātur atvērts (vairums lietotāju to 

sadoko ar Rīkjoslu. Lai saskarni padarītu nemainīgu, visiem atlases rīkiem tiek atspoguĜotas vienādas 

opcijas, kaut arī tās nav piemērojamas dažiem rīkiem. 
 

Ilustrācija 9.3. Atlases rīku izplatītākās opcijas 
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Režīms (Mode) 

Tas nosaka veidu, kādā jaunizveidotā atlase tiek sasaistīta ar jau esošo. Ievērojiet, ka šo pogu funkcijas 

var būt dublētas ar pārveidotājtaustiĦiem. Pieredzējuši lietotāji parasti izmanto taustiĦus kombinācijas, 

iesācēji – režīmu pogas. 

 

Aizvietošanas (replace) režīms dzēš iepriekš esošo atlasi, kad tiek veidota jauna. 

 

Pievienošana režīms (add mode) savienos jaunizveidoto atlasi ar jau esošo. 

 

AtĦemšanas režīms (substract mode) izĦems jaunizveidoto atlasi no jau esošās, ja tās pārklājas. 

 

Pārklāšanas režīms (intersection mode) izveidos jaunu atlasi vietā, kur pārklājas jaunā un jau 

esošā. 

Krop Ĝojumnov ērse (Antialiasing ) 

Šī opcija skar tikai dažus no atlases rīkiem, tā liek atlases kontūrai plūstošāk iekĜauties attēlā. 

Malu atstarpošana ( Feather edges ) 

Šī opcija izpludina atlases robežas tā, ka pikseĜi pie šīs robežas tiek tikai daĜēji atlasīti. 

2.1.3. Papildus informācija 

PIEZĪME 

Kad pārvietojat atlasi ārpus attēla robežām, tā tiek apgriezta pēc attēla izmēra. Atlases ar atrasties tikai 

uz attēla redzamās daĜas. Atlases pārvietojums un citas izmaiĦas tiek īslaicīgi uzglabātas atsaukšanas 

buferī, tāpēc kĜūdas var labot. 
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2.2. Taisnstūra atlases rīks (Rectangle Selection) 
 

Ilustrācija 9.4. Taisnstūra atlases ikona Rīkjoslā 

 
 

Taisnstūra atlases rīks ir paredzēts taisnstūrveida atlašu veidošanai – tas ir viens no parastākajiem 

atlases rīkiem, taču tiek itin bieži izmantots. 

Šo rīku izmanto arī taisnstūra uzzīmēšanai: izveido taisnstūra atlasi un aizpilda to ar „Krāsu spainīša” 

(Paint bucket) rīku. Lai izveidotu atvilktu taisnstūri, visvienkāršāk ir sākt ar taisnstūra atlasi un tad apvilkt 

to. 

Ja vēlaties noapaĜot taisnstūra atlases stūrus, attēla loga izvēlnē atrodiet Atlasīt→NoapaĜots taisnstūris 

(Select→Rounded rectangle). 

2.2.1. Aktivizēšana 

PiekĜūt Taisnstūra atlases rīkam ar trīs dažādos veidos: 

o No attēla loga izvēlnes Rīki→Atlases rīki→Taisnstūra atlase (Tools→Selection tools→Rectangle 

Selection). 

o Noklikšėinot uz  ikonas Rīkjoslā 

o Izmantojot tastatūras taustiĦu R. 

2.2.2. PārveidotājtaustiĦi 

PIEZĪME 

Skaties sadaĜu Atlases rīki, lai iegūtu vairāk informācijas par pārveidotājtaustiĦiem, kas darbojas vienādi 

visiem atlases rīkiem. Šeit apskatīsim tikai specifiskas opcijas, kas raksturīgas konkrētajam rīkam. 
 

Ctrl 

Pēc atlases veidošanas sākšanas nospiežot Ctrl taustiĦu, atlases punkts no stūra tiek pārvietots uz 

centru. Ievērojiet, ka nospiežot Ctrl taustiĦu pirms atlases veidošanas sākšanas, jaunizveidotā 

atlase tiks izĦemta no jau esošās. 

Shift 

Ja nospiežat Shift taustiĦu pirms atlases sākšanas, jaunizveidotā atlase tiks pievienota jau 

esošajai. 
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Nospiežot Shift pēc atlases sākšanas, ieslēdz opciju Fiksēt (Fixed), kas atlasi pārvērš par 

kvadrātu. 

Ctrl  + Shift  

Pēc atlases sākšanas nospiežot abus taustiĦus, savieno divus efektus – kvadrātveida atlase ar 

sākumpunktu centrā. 

2.2.3. Manipulācijas ar rīku 

Kad rīks ir aktivizēts, peles kursors tiek attēlots šādi: , kad tas atrodas virs attēla. Peles pogas 

turēšana to pārvietojot izveido taisnstūra atlasi, kuru, pēc peles atlaišana, ierobežo punktēta līnija. Nav 

nepieciešama liela precizitāte, jo atlases izmēru un formu var vēlāk piekoriăēt. 

Kad kursors atrodas uz audekla, kursora izskats un funkcijas mainās: 

o Ārpus atlases tas izskatās, kā parasti. Tas Ĝauj izveidot vēl vienu atlasi, taču dzēšot jau esošo, 

nav ieslēgts kāds no savienošanas vai izĦemšanas režīmiem. 

o Atlases iekšpusē peles kursora izskats var mainīties, kad tas atrodas uz atlases jūtīgajām vai 

atzīmētajām daĜām. Šie rokturi Ĝauj mainīt atlases izmēru. Piemēram, atlases apakšējā labajā 

stūrī kursors izskatās šādi: . Tāpēc pavilkšana aiz šīm malām samazina vai palielina atlasi. 

Kad peles kursors novietots uz atlases malas, piemēram, uz kreisās malas, tas izskatās šādi: 

 - Jūs to varat pavilkt, lai izstieptu izveidoto atlasi. 

o Atlases vidū peles kursors izskatās šādi: . Tas Ĝauj pārvietot atlasi. 

PADOMS 

Ja pārvietošanai vai izmēra maiĦai izmantojat taustiĦus, varat pārvietoties par vienu pikseli. Savukārt 

turot Shift taustiĦu, pārvietojaties par 25 pikseĜiem. 
 

 

Ilustrācija 9.5. Atlases jūtīgās vietas 

 
Visi iespējamie kursora veidi atlasē. 

Pēc atlases izveides un pielāgošanās, Jums ir jāiziet no rediăēšanas režīma (un jāapstiprina izmaiĦas). 

To var izdarīt ar klikšėi atlases iekšpusē vai nospiežot Enter taustiĦu. Vai arī jāizvēlas kāds ne-atlases 

rīks, piemēram, Ota. 
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2.2.4. Rīka opcijas 
 

Ilustrācija 9.6. Taisnstūra atlases rīka opcijas 

 
 

Režīms; Krop Ĝojumnov ērse; Malu atstarpošana ( Mode, Antialiasing, Feather edges ) 

Opcijas, kas kopīgas visiem atlases rīkiem. 

Noapa Ĝoti st ūri (Rounded corners ) 

Ja aktivizējat šo opciju, parādās slīdnis, kas izmantojams, lai pielāgotu noapaĜojuma rādiusu. 

Izplest no centra ( Expand from center ) 

Ja aktivizējat šo opciju, atlases sākumpunkts no stūra pārvietojas uz centru. 

Fiksēt (Fixed ) 

Šī izvēlne Ĝauj saglabāt atlases formu dažādos veidos: 

Aspekta attiecība (Aspect ratio) 

Šī opcija Ĝauj veidot taisnstūri ar fiksētām malu proporcijām. Pēc noklusējuma tās ir 1:1 

(kvadrāts), taču to var mainīt. 

Platums (Width) 

Šeit Jūs varat pielāgot atlases platumu 

Garums (Height) 

Šeit Jūs varat pielāgot atlases garumu. 

Izmērs (Size) 

Šeit Jūs varat mainīt gan atlases platumu, gan garumu. 

Izcelt ( Highlight ) 

Ja aktivizējat šo iespēju, atlasīto attēla daĜu ieskauj maska, kas Ĝauj to labāk atšėirt no neatlasītās 

daĜas. 

X;Y Platums;Garums ( X;Y Width; Height ) 
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Šie četri teksta lauciĦi atspoguĜo atlases atrašanās vietu attēlā un tās izmēru. 

Palīgl īnijas ( Guides ) 

Ar šo izvēlni Jūs varat izvēlēties palīglīniju veidu, kas palīdz izveidot precīzāku atlasi. 

Bez palīglīnijām (No guides) 

Palīglīnijas netiek attēlotas 

Centra līnijas (Center lines) 

Tiek attēlotas tikai centra palīglīnijas. 

TrešdaĜu likums (Rule of thirds) 

Līnijas tiek izkārtotas pēc trešdaĜu likuma, atlases veidošanas laikā. 

Zelta griezums (Golden sections) 

Šī līnija parāda zelta griezumu. 

Autom ātiski samazin āt atlasi ( Auto shrink selection ) 

Šī izvēles rūtiĦa liks nākamajai atlasei sarauties līdz lielākajam iespējamajam taisnstūrim slānī.  

Samazināt apvienoto ( Shrink merged ) 

Ja ir aktivizēta arī Vienkāršā apvienošana (Simple merge), šī opcija izmantos pikseĜu informāciju 

no redzamās attēla daĜas, nevis tikai no atsevišėa slāĦa. 
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2.3. Elipses atlases rīks (Ellipse Selection Tool) 
 

Ilustrācija 9.6. Elipses atlases rīka ikona Rīkjoslā 

 
 

Elipses atlases rīks ir paredzēts riĦėa vai elipses veida laukuma atlasei. 

Šo rīku izmanto arī riĦėa vai elipses uzzīmēšanai: izveido elipses veida atlasi un aizpilda to, izmantojot 

Krāsu spainīša (Paint Bucket) rīku. Lai izveidotu elipses veida kontūru, vienkāršākais veids ir izveidot 

elipses atlasi un tad to apvilkt. Tomēr KropĜojumnovērse šajā gadījumā darbojas slikti. Labākas 

kvalitātes kontūru var iegūt savietojot divas dažāda izmēra elipses vienu virs otras, augšējo atlasi 

izĦemot no apakšējās, taču tas var būt visai sarežăīti. Šo darbību atvieglo komanda Atlase→Kontūra 

(Selection→Border). 

2.3.1. Aktivizēšana 

Elipses atlases rīku var atvizēt caur attēla izvēlni Rīki→Atlases rīki→Elipses atlase (Tools→Selection 

Tools→Ellipse Selection), Rīkjoslā izvēloties ikonu , vai arī izmantojot taustiĦu e. 

2.3.2. PārveidotājtaustiĦi 

Ctrl 

Nospiežot šo taustiĦu pēc atlases sākšanas un to turot līdz atlases pabeigšanai, pārvieto atlases 

sākumpunktu no stūra uz centru. Ievērojiet, ka Ctrl taustiĦa nospiešana pirms atlases sākšanas, 

jaunizveidoto atlasi izĦems no jau esošās. 

Shift 

Pēc atlases sākšanas nospiežot Shift taustiĦu un to turot līdz atlases pabeigšanai, atlasi pārvērš 

par apli. Ievērojiet, ja taustiĦa nospiešana pirms atlases sākšanas, pievienos jauno atlasi esošajai. 

Ctrl  + Shift  

Abu pogu nospiešana apvieno divus efektus – rodas aplis ar sākumpunktu centrā. 
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2.3.3. Darbošanās ar rīku 

Pēc attēla aktivizēšanas un kursora novietošanas uz attēla, tā kursors pārvēršas par aplīti. Elipses 

iegūšanai Jums ir jānospiež peles kreisā poga un to turot jāpārvieto kursors. Pēc peles pogas atlaišanas, 

atlasi ieskauj punktēta līnija. Precizitāte šajā solī nav noteicoša, jo atlases izmēru varēs piekoriăēt. 

Kad kursors pārvietojas attēlā, tā izskats un funkcijas mainās. Atlases izmēru var mainīt ar rokturu 

palīdzību. Skatiet sadaĜu Manipulācijas ar rīku nodaĜā Taisnstūra atlases rīks. 

2.3.4. Opcijas (Options) 
 

Ilustrācija 9.7. Elipses atlases rīka opcijas 

 
 

Elipses atlases rīka opcijas var atvērt ar dubultklikšėi uz  ikonas. 

Režīms; Krop Ĝojumnov ērse; Malu atstarpošana ( Mode, Antialiasing, Feather edges ) 

Opcijas, kas kopīgas visiem atlases rīkiem. 

Citas opcijas  

Tas strādā tieši tā, kā aprakstīts sadaĜā Taisnstūra atlases rīks. 
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2.4. Brīvās atlases rīks jeb Laso (Free selection tool/Lasso) 
 

Ilustrācija 9.8. Laso rīka ikona Rīkjoslā 

 
 

Brīvās atlases rīks jeb Laso Ĝauj veidot atlasi, to uzzīmējot ar kursoru, turot peles kreiso pogu. Kad 

atlaižat peles pogu, atlase tiek noslēgta, savienojot sākuma un beigu punktus ar taisnu līniju. Laso rīks 

nav domāts precīzas atlases izveidei. Pieredzējuši lietotāji sāk ar Laso rīku un tad pārslēdzas uz 

ĀtrāsMaskas (QuickMask) režīmu tālākam darbam. 
 

PIEZĪME 

Laso rīku parocīgāk izmantot sadarbībā ar grafisko planšeti, nevis peli. 

2.4.1. Aktivizēšana 

Laso rīku var aktivizēt caur attēla loga izvēlni Rīki→Atlases rīki→Brīvā atlase (Tools→Selection 

Tools→Free select); noklikšėinot uz  ikonas rīkjoslā; vai ar f taustiĦa palīdzību. 

2.4.2. PārveidotājtaustiĦi 

Laso rīkam nav specifisku pārveidotājtaustiĦu, tikai tie, kas darbojas visos atlases rīkos. Vairāk 

informācijas meklējiet sadaĜā Atlases rīki. 

2.4.3. Darbošanās ar rīku 

Lai pārvietotu atlasi, lasiet sadaĜu Atlases pārvietošana. 

2.4.4. Opcijas 
 

Ilustrācija 9.10. Laso rīka opcijas 

 
 

Laso rīka opcijas var atvērt ar dubultklikšėi uz  ikonas Rīkjoslā. 
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Brīvās atlases rīkam nav specifisku opciju, kā vien tās, kas kopīgas visiem atlases rīkiem. Skaties sadaĜu 

Atlases rīki, lai uzzinātu par tām vairāk. 

2.5. Burvju nūjiĦas rīks (Magic wand tool) 
 

Ilustrācija 9.11. Burvju nūjiĦas rīka ikona Rīkjoslā 

 
 

Burvju nūjiĦas rīks ir paredzēts uz krāsām balstītas atlases izveidei. 

Kad izmatojat šo rīku, ir svarīgi atrast precīzu sākumpunktu. Ja izvēlaties nepareizo laukumu, neiegūsiet 

gaidīto rezultātu. 

NūjiĦas rīks ir lieliski piemērots objektu atlasīšanai, kam ir skaidras aprises. Tā izmantošana ir jautra, 

tāpēc tas bieži patīk iesācējiem. Taču, pēc iepazīšanās ar šo rīku Jūs sapratīsiet, ka ir grūti atlasīt tikai 

vēlamo. Iespējams šī rīka kaitinošākā puse ir tas, ka pēc peles pogas atlaišanas atlasi nevar labot un 

jāsāk viss no sākuma. Taču šis rīks lieti noder ar kontūru apvilktu objektu atlasīšanai vai nepilnīgu atlašu 

pielabošanai. Bieži to izmanto vienmērīga fona atlasei. 

Atcerieties, ka atlasītais laukums izplešas virzienā no centra, tāpēc šis rīks atlasa ne tikai savienotus, bet 

arī tuvu novietotus pikseĜus. 

2.5.1. Aktivizēšana 

Maăiskās nūjiĦas rīku var aktivizēt caur attēla loga izvēlni Rīki→Atlases rīki→Burvju nūjiĦa 

(Tools→Selection tools→Fuzzy select); noklikšėinot uz  ikonas Rīkjoslā vai izmantojot U taustiĦu. 

2.5.2. PārveidotājtaustiĦi 

Maăiskās nūjiĦas rīkam nav specifisku pārveidotājtaustiĦu, tikai tie, kas darbojas visos atlases rīkos. 

Vairāk informācijas meklējiet sadaĜā Atlases rīki. 

2.5.3. Darbošanās ar rīku 

Tas sāk atlasi tiklīdz esat noklikšėinājis uz attēla un izplešas virzienā no centra, atlasot sākuma pikseĜa 

krāsai līdzīgos pikseĜus. Jūs varat kontrolēt atlasi, pārvietojot peli uz leju vai pa labi – jo tālāk 

pārvietosiet, jo lielāks laukums tiks atlasīts. Atlasi var samazināt, pārvietojot peli uz augšu vai pa kreisi. 

Lai pārvietotu atlasi, lasiet sadaĜu Atlases pārvietošana. Pārvietošana notiek ar bulttaustiĦiem, nevis peli. 
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2.5.4. Opcijas 
 

Ilustrācija 9.12. Maăiskās nūjiĦas opcijas 

 
 

Līdzīgu kr āsu mekl ēšana (Finding similar colors ) 

Šī opcija nosaka atlases rādiusu no sākumpunkta. 

Atlasīt caurspīdīgos laukus (Select transparent areas) 

Šī opcija Ĝauj Maăiskās nūjiĦas rīkam atlasīt laukumus, kas ir pilnīgi caurspīdīgi. Ja šī opcija 

nav aktivizēta, caurspīdīgie attēla laukumi netiks iekĜauti atlasē. 

Sapludināt ar paraugu (Sample merged) 

Šī opcija lieti noder, kad attēlam ir vairāki slāĦi un aktīvais slānis ir vai nu puscaurspīdīgs, vai 

tā režīms atšėiras no Normāla. Šajā gadījumā krāsas slānī nesakratīs ar attēla krāsām. Ja 

opcija „Sapludināt ar paraugu” nav aktivizēta, rīks darbosies tikai ar slāĦa krāsām. Ja šī 

opcija ir aktivizēta, rīks darbosies ar visām redzamo slāĦu krāsām. 

Slieksnis (Treshold) 

Slīdnis nosaka krāsu amplitūdu, kas tiks atlasīta. Jo lielāks slieksnis, jo lielāka atlase.  

Atlase pēc (Selection by) 

Ar šīs opcijas palīdzību Jūs varat izvēlēties, kuru attēla daĜu GIMP izmantos, lai aprēėinātu 

līdzību. Jūs varat izvēlēties starp Sarkans (Red), ZaĜš (Green), Zils (Blue), Nokrāsa (Hue), 

Piesātinājums (Saturation), Vērtība (Value). 
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2.6. Atlase pēc krāsas (Select by color) 
 

Ilustrācija 9.13. Atlases pēc krāsas rīka ikona Rīkjoslā 

 
 

Krāsu atlases rīks ir paredzēts uz krāsu līdzības balstītu attēla laukumu atlasei. Tā darbības princips ir 

līdzīgs Maăiskās nūjiĦas darbībai. Atšėirībā no Maăiskās nūjiĦas, Krāsu atlases rīks atlasa līdzīgas 

krāsas pikseĜus visā attēlā. 

2.6.1. Aktivizēšana 

Krāsu atlases rīku var aktivizēt caur attēla loga izvēlni Rīki→Atlases rīki→Atasīt pēc krāsas 

(Tools→Selection tools→Select by color); nospiežot  ikonu rīkjoslā vai ar taustiĦiem Shift+O. 

2.6.2. PārveidotājtaustiĦi 

Maăiskās nūjiĦas rīkam nav specifisku pārveidotājtaustiĦu, tikai tie, kas darbojas visos atlases rīkos. 

Vairāk informācijas meklējiet sadaĜā Atlases rīki. 

2.6.3. Darbošanās ar rīku 

Atlase sākas līdz ar klikšėi uz attēla un par piemēru tiek Ħemts pirmais izvēlētais pikselis. Pārvietojot peli 

ar nospiestu kreiso pogu, var mainīt atlases rādiusu. Lai pārvietotu atlasi, lasiet sadaĜu Atlases 

pārvietošana. Pārvietošana notiek ar bulttaustiĦiem, nevis peli. 
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2.6.4. Opcijas 
 

Ilustrācija 9.14. Krāsu atlases rīka opcijas 

 
 

Krāsu atlases rīka opcijas var atvērt ar dubultklikšėi uz  ikonas Rīkjoslā. 

Režīms; Krop Ĝojumnov ērse; Malu atstarpošana ( Mode, Antialiasing, Feather edges ) 

Opcijas, kas kopīgas visiem atlases rīkiem. 

Līdzīgas kr āsas (Similar colors ) 

Šī opcija nosaka atlases rādiusu no sākumpunkta. 

2.7. Šėēres (Scissors) 
 

Ilustrācija 9.15. Šėēru ikona Rīkjoslā 

 
 

 

Interesants rīks ir Šėēres – tam ir kopīgas īpašības ar Laso un CeĜa rīku un ir arī savas īpašības. Tās ir 

noderīgas, kad vēlaties atlasīt laukumu, kas kontrastē ar citu objektu. Lai lietotu Šėēres, ar klikšėu 

palīdzību nosaka „kontroles mezglus” uz objekta robežām, caur kuriem rīks veido savienojumus, Ħemot 

vērā objekta kontrastējošo robežu. Ja paveicas, Šėēru rīks viegli atlasīs nepieciešamo attēla daĜu. 

Katrs nākamais peles klikšėis uz attēla veido jaunu mezglu, kas tiek automātiski savienots ar iepriekšējo, 

pielāgojoties kontrastējošajai kontūrai. Lai pabeigtu atlasi, kursors jānovieto uz sākumpunkta (tā izskats 

mainās) un jānoklikšėina. Izliekumu var mainīt, veidojot jaunus mezglus vai pārvietojot jau esošos. Kad 

rezultāts Jūs apmierina, noklikšėiniet atlases centrā, lai to pabeigtu. 

Diemžēl šim rīkam ir dažas nepilnības, kas neĜauj precīzi atlasīt vēlamo objektu. Tāpēc jāpārslēdzas uz 

ĀtrāsMaskas (QuickMask) režīmu un jāizmanto zīmēšanas rīki, lai izlabotu neprecizitātes. 
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2.7.1. Aktivizēšana 

Šėēres var aktivizēt caur attēla loga izvēlni Rīki→Atlases rīki→Šėēres (Tools→Selection 

tools→Intelligent Scissors); nospiežot ikonu rīkjoslā vai ar taustiĦu  i . 

2.7.2. PārveidotājtaustiĦi 

Maăiskās nūjiĦas rīkam nav specifisku pārveidotājtaustiĦu, tikai tie, kas darbojas visos atlases rīkos. 

Vairāk informācijas meklējiet sadaĜā Atlases rīki. 

2.7.3. Darbošanās ar rīku 

Kā jau minēts iepriekš, klikšėis ar šo rīku rada mezglus, pēc kuriem vadās atlase. Visus mezglus, 

izĦemot pirmo un pēdējo, var pārvietot atlases veidošanas laikā. Kad atlase ir pabeigta, mainās kursora 

izskats – tās iekšpusē kursors ir bultiĦa ar šėērēm, uz atlases robežas kursors ir bultiĦa ar + zīmi, bet 

ārpus atlases kursoram ir aizlieguma zīme. Atlasi apstiprina ar klikšėi tās iekšpusē. 
 

UZMANĪBU 

Uzmanieties no klikšėa līknes iekšpusē pirms atlase ir pabeigta. Tiklīdz esat to pārveidojis par atlasi, 

atsaukšana novedīs pie nulles, un visi Jūsu rūpīgi atzīmētie mezgli būs pazuduši. 
 

Lai pārvietotu atlasi, lasiet sadaĜu Atlases pārvietošana. 

2.7.4. Opcijas 
 

Ilustrācija 9.16. Šėēru rīka opcijas 

 
 

Šėēru rīka opcijas var atvērt ar dubultklikšėi uz  ikonas Rīkjoslā. 

Interakt īvā robeža ( Interactive booundry ) 

Ja aktivizēta šī opcija, kontroles mezgla pārvietošana norādīs atlases robežu. Ja šī opcija nav 

aktivizēta, mezgli tiks savienoti ar taisnu līniju un Jūs neredzēsiet rezultātu, līdz būsiet pabeiguši 

atlasi. Ja Jūsu dators ir pārāk lēns, šīs opcijas izslēgšana var ietaupīt atmiĦu. 
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2.8. Priekšplāna atlases rīks (Foreground select tool) 
 

Ilustrācija 9.17. Priekšplāna atlases rīka ikona Rīkjoslā 

 
 

Šis rīks Ĝauj atdalīt aktīvā slāĦa priekšplānu no atlases. 

2.8.1. Lietošanas norādījumi 

Atlasei ar šo rīku ir pāris soĜi: 

1. Nevīžīgi atlasiet priekšplānu, kuru vēlaties atdalīt. Kad izvēlaties šo rīku, peles kursors pārvēršas 

par laso. Atlasiet pēc iespējas mazāk fona. 

Tiklīdz atlaidīsiet peles pogu, attēla neatlasīto daĜu nosedz tumši zila maska. Ja atlase nav 

slēgta, tās galapunkti automātiski savienojas ar taisnu līniju. Peles kursors pārvēršas par Otas 

ikonu nākamajam solim. 
 

Ilustrācija 9.18. Nevīžīgi atlasīts priekšplāns 

 

2. Izmantojot Otas rīku, uzzīmējiet līniju pāri priekšplānam, pākrāsojot pāri krāsām, kuras būtu 

jāsaglabā. Līnijas krāsai nav nozīmes. Uzmanieties no fona pikseĜu aizskaršanas. 
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Ilustrācija 9.19. Līnija priekšplānā 

 

3. Pēc peles pogas atlaišanas neatlasītie laukumi ir tumši: 
 

Ilustrācija 9.20. Laukums, kas tiks atlasīts 

 

4. Nospiediet Enter, lai iegūtu vēlamo atlasi: 
 

Ilustrācija 9.21. Atlasīts priekšplāns 

 

2.8.2. Aktivizēšana 

Priekšplāna atlases rīku var aktivizēt caur attēla loga izvēlni Rīki→Atlases rīki→Priekšplāna atlase 

(Tools→Selection tools→Foreground select) vai nospiežot  ikonu Rīkjoslā. 

2.8.3. PārveidotājtaustiĦi 

Ctrl 

Nospiežot Ctrl taustiĦu, varat pārslēgties starp fona un priekšplāna iezīmēšanu. 
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2.8.4. Opcijas 
 

Ilustrācija 9.22. Priekšplāna atlases rīka opcijas 

 
 

Priekšplāna atlases rīka opcijas var atvērt ar dubultklikšėi uz  ikonas Rīkjoslā. 

Režīms; Krop Ĝojumnov ērse; Malu atstarpošana ( Mode, Antialiasing, Feather edges ) 

Opcijas, kas kopīgas visiem atlases rīkiem. 

Blakusesošie ( Contigous ) 

Ja aktivizēta šī opcija, atlasīta tiks tikai triepienam blakusesošā daĜa. Citādi tiktu atlasīti visi 

izvēlētās krāsas laukumi. 

Interakt īvā bagātināšana 

Atzīmēt priekšplānu (Mark foreground) 

Noklusējuma opcija. Zīmēšanai tiek izmantota priekšplāna krāsa. 

Atzīmēt fonu (Mark background) 

Peles kursors pārvēršas par mazu dzēšgumiju ar mīnusa zīmi. Tiek izmantota fona krāsa. 

Atlases pikseĜi šajā krāsā tiek „izdēsti” un tie tiks atlasīti. 

Maza ota/Liela ota (Small brush/Large brush) 

Slīdnis Ĝauj pielāgot otas izmēru. 

Nogludin āšana (Smoothing ) 

Slīdnis Ĝauj aizvākt sīkus caurumus atlasē. 

Priekšskat ījuma kr āsa (Preview Color ) 

Varat izvēlēties starp Sarkanu (Red), ZaĜu (Green) vai Zilu (Blue) fona maskas krāsu. 

Krāsu jūtība (Color Sensitivity ) 

Ja attēlā ir daudz vienādas krāsas pikseĜu dažādos toĦos, Jūs varat palielināt šīs krāsas jūtību. 
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3. Otu rīki 

3.1. Kopīgās raksturpazīmes 
 

Ilustrācija 9.23. Otu rīki 

 
 

GIMP rīku joslā ir trīspadsmit „otu rīku”. To kopīgā pazīme ir tā, ka visi tiek izmantoti, pārvietojot kursoru 

attēlā un veidojot triepienus. 

Četri no tiem: 

o Zīmulis (Pencil) 

o Ota (Paintbrush) 

o Pulverizators (Airbrush) 

o Tinte (Ink tool) 

Uzvedas tāpat, kā parasta „ota”. Pārējie izmanto otu, lai pārveidotu attēlu ne tikai zīmējot tam pāri: 

o Krāsu spainītis (Bucket fill) aizpilda laukumu ar krāsu; 

o Gradients (Gradient) aizpilda laukumu ar krāsu pāreju; 

o Dzēšgumija (Eraser) dzēš; 

o Klonēšanas rīks (Clone tool) kopē no citas attēla vietas; 

o Perspektīvas klons (Perspective clone) kopē izvēlētā perspektīvā; 

o Dziedēšanas rīks (Heal tool) labo sīkus defektus; 

o Saritināšanas rīks (Convolve tool) saasina vai apmiglo; 

o Pludināšanas rīks (Smudge tool) izsmērē; 

o Dedzināšanas rīks (Burn tool) izgaismo vai aptumšo. 

Grafiskās planšetes izmantošanas priekšrocība peles vietā vislabāk parādās tieši darbojoties ar otu 

rīkiem – tā ir labāka kontrole. Šiem rīkiem ir „spiediena jūtības” opcijas, kas ir izmantojamas tikai ar 

grafisko planšeti. 
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3.1.1. PārveidotājtaustiĦi 

Ctrl 

Ctrl taustiĦa nospiešana rada īpašu efektu ikvienam otu rīkam, izĦemot Tinti. Zīmuli, Pulverizatoru, 

Otu, Dzēšgumiju un Pludināšanas rīkus tas pārslēdz uz „krāsu savācēja” režīmu, kas Ĝauj izvēlēties 

priekšplāna (Dzēšgumijai – fona) krāsu. Klonēšanas rīku Ctrl taustiĦš pārslēdz uz režīmu, kurā var 

izvēlēties kopējamo vietu attēlā. Saritināšanas rīku Ctrl taustiĦš pārslēdz starp apmiglošanu un 

saasināšanu. 

Shift  

Shift tautiĦa nospiešana darbojas vienādi uz visiem rīkiem – tā rīku pārslēdz uz „taisnu” režīmu. Lai 

uzzīmētu taisnu līniju ar jebkuru no otu rīkiem, vispirms noklikšėiniet uz sākumpunkta un tad 

nospiediet Shift. Kamēr Jūs to turat nospiestu, Jūs redzat tievu palīglīniju, kas savieno 

sākumpunktu ar pašreizējo kursora atrašanās vietu. Ja, turot Shift, noklikšėināsiet vēlreiz, 

izveidosies taisna līnija. 
 

Ctrl  + Shift  

Abu taustiĦu nospiešana pārslēdz rīku piespiedu taisnas līnijas režīmā – līnijas orientāciju nosaka 

tuvākie 15 grādi, tāpēc varat novilkt perfekti taisnu vai diagonālu līniju. 

3.1.2. Opcijas 
 

Ilustrācija 9.24. Rīka opcijas, kas vienādas viesiem zīmēšanas rīkiem 

 

 

Daudziem otu rīkiem ir kopīgas opcijas. Katra rīka specifiskās opcijas aprakstītas rīkam veltītajā sadaĜā. 

Režīms (Mode ) 

Režīma atklājamais lodziĦš piedāvā dažādus zīmēšanas režīmus. Vieglākais veids kā saprast, ko 

krāsa dara ar attēlu, ir iedomāties, ka tā tiek uzklāta uz aktīvā slāĦa virskārtas. Režīma opcija ir 

pieejama tikai rīkiem, kas pievieno krāsu, piemēram, Zīmulim, Pulverizatoram, Otai, Tintei un 

Klonēšanas rīkiem. Pārējiem rīkiem šī opcija nav pieejama. 
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Intensit āte (Opacity ) 

Intensitātes slīdnis nosaka otas caurspīdības līmeni. Intensitātes maiĦa Rīka opcijās rada tādu 

pašu efektu kā SlāĦa intensitātes maiĦa. Tā kontrolē otu rīku „stiprumu”. Dzēšgumijas gadījumā 

princips ir cits – jo lielāka intensitāte, jo vairāk caurspīdības iegūst tās rezultātā. 

Ota (Brush ) 

Ota nosaka, cik lielas izmaiĦas attēlā rīks veic. Visi otu rīki, izĦemot Tinti, izmanto vienu un to pašu 

otu komplektu. Krāsas stājas spēkā tikai rīkiem, kam tās ir svarīgas – Zīmulim, Otai vai 

Pulverizatoram. Pārējiem otu rīkiem svarīga ir tikai intensitāte. 

Līmenis ( Scale ) 

Šī opcija Ĝauj precīzi izvēlēties otas izmēru. Jūs varat izmantot bulttaustiĦus, lai mainītu izmēru par 

0.01 vai augšupšėiršanas un lejupšėiršanas taustiĦus, lai mainītu izmēru par 0.05. 

Spiedienj ūtība (Pressure Sensitivity ) 

Tai ir nozīme tikai izmantojot grafisko planšeti. Var izvēlēties starp piecām iespējām: intensitāte 

(opacity), stiprums (hardness), ātrums (rate), izmērs (size) un krāsa (color). Šīs iespējas darbojas 

arī kopā, tāpēc var izvēlēties kaut vai visas. Katram rīkam parādītas tikai svarīgās. Ko tās dara: 

Intensitāte (Opacity) 

Tās ietekme aprakstīta augstāk. 

Stiprums (Hardness) 

Šī opcijas attiecas uz otām ar nevienmērīgām malām. Jo stiprāk spiežat, jo tumšākas malas 

kĜūs. 

Ātrums (Rate) 

Šī opcija attiecas uz Pulverizatoru, Saritināšanas un Pludināšanas rīku, jo tiem visiem ir uz 

laiku balstīti efekti. Stiprāks uzspiediens liek tiem darboties ātrāk. 

Izmērs (Size) 

Stiprāks uzspiediens palielinās otu skarto laukumu. 

Krāsa (Color) 

Šī opcija attiecas tikai uz zīmēšanas rīkiem: Zīmuli, Otu un Pulverizatoru, un tikai izmantojot 

krāsas no gradienta. Stiprāks uzspiediens liek tiem izmantot augstākas gradienta krāsas. 

Pavājināšanās (Fade-out ) 

Šī opcija liek pavājināties triepienam pēc noteikta attāluma. Vieglāk pamanāma šī opcija ir 

zīmēšanas rīkiem, taču to var piemērot visiem otu rīkiem. 

Piemērot tr īci (Apply jitter ) 

Triepieni veidojas no secīgām otu zīmēm, kad tās ir tuvu viena otrai, veidojas vienmērīga līnija. 

Šajā opcijā otu zīmes ir izmētātas noteiktā attālumā, ko var pielādot ar Daudzuma (Quantity) slīdni. 
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Ilustrācija 9.25. Trīces piemērs 

 
No augšas: bez trīces, trīce=1, trīce=4. 

 

Pieaugoši ( Incremental ) 

Ja šī opcija nav aktivizēta, maksimālo viena triepiena efektu nosaka intensitāte. Ja šī opcija ir 

aktivizēta, katrs atkārtots otas triepiens palielinās tā efektu, tomēr tā intensitāte nepārsniegs 

uzstādīto. 

3.2. Zīmēšanas rīki (Painting tools) 
 

Ilustrācija 9.26. Zīmēšanas piemērs 

 
Trīs triepieni uzzīmēti ar vienu otu (kreisajā stūrī) izmantojot Zīmuli (pa kreisi), Otu (vidū) un Pulverizatoru (pa labi) 

 

Šīs grupas rīki ir GIMP pamata zīmēšanas rīki un tiem ir tik daudz kopīgu īpašību, ka mēs tos apskatīsim 

vienā sadaĜā. Visu otu rīku raksturpazīmes ir aprakstītas sadaĜā Kopīgās raksturpazīmes. 

Zīmulis ir primitīvākais rīks šajā grupā – tas viedo asus triepienus bez kropĜojumlabojuma. Zīmulis ir šīs 

grupas visbiežāk lietotais rīks. Pulverizators ir vispielāgojamākais un kontrolējamākais – vienīgais, kura 

krāsas daudzums atkarīgs no izmantošanas ātruma. Tomēr šī pielāgojamība padara to grūtāk lietojumu 

par Otu. 

Visi šie rīki izmanto vienu un to pašu otu komplektu un tiem ir vienādas opcijas krāsu izvēlē vai nu no 

paletes vai no gradienta. Visi ir spēj zīmēt dažādos režīmos. 

3.2.1. PārveidotājtaustiĦi 

Ctrl 

Ctrl taustiĦa nospiešana katru no šiem rīkiem pārslēdz Krāsu savācēja (Color picker) režīmā – 

klikšėis uz kāda no attēla pikseĜiem uzstāda tādu pašu priekšplāna krāsu. 
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3.2.2. Opcijas 

Režīms (Mode ) 

Režīma izmetamais saraksts piedāvā zīmēšanas režīmu klāstu. Pamatā šie režīmi ir tādi paši, kas 

SlāĦu dialogā. Taču trīs režīmi ir īpaši: 

Izkliedēšanas režīms (Dissolve mode) 
 

Ilustrācija 9.27. Izkliedēšanas režīma (Dissolve mode) piemērs 

 
Ar Pulverizatoru zīmēti triepieni, izmantojot vienu un to pašu otu. Pa kreisi: Normāls režīms, pa labi: 

Izkliedēšanas režīms. 

Krāsu dzēšana (Color erase) 
 

Ilustrācija 9.28. Krāsu dzēšanas režīma piemērs 

 

 
 

Šīs režīms dzēš priekšplāna krāsu, aizvietojot to ar daĜēju caurspīdību. Šīs režīms darbojas 

tikai slāĦos ar alfa kanālu. 

Gradients ( Gradient ) 
 

Ilustrācija 9.29. Gradienta opcijas zīmēšanas rīkiem 

 
 

Priekšplāna krāsas vietā, izvēloties opciju „Izmantot krāsu no gradienta” (Use color from gradient), 

varat zīmēt ar gradientu, liekot krāsām triepienā mainīties. 

Ir vairākas opcijas, lai kontrolētu gradienta izmantošanu un izkārtojumu: 

Gradients (Gradient) 

Redzams pašreizējā gradienta paraugs. Klikšėis uz tā izsauc Gradienta Pārslēgu (Gradient 

selector), kas Ĝauj izvēlēties citu krāsu salikumu. 
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Pretējs (Reverse) 

Šī opcija liek triepienam sākties ar beidzamo krāsu. 

Garums (Lenght) 

Šī opcija nosaka viena pilna gradienta cikla garumu. Varat izvēlēties citas vienības izvēlnē 

Vienības (Units). 

Atkārtot (Repeat) 
 

Ilustrācija 9.30. Trīs gradienta atkārtojuma veidu piemērs, izmantojot gradientu „Abstract2” 

 
Gradients „Abstract2” 

 
None 

 
Sawtooth 

 
Trīsstūrveida (Triangular) 

 

Šī opcija atbild par to, kas notiks, ja triepiens būs garāks par augstāk minēto garumu. Ir trīs 

iespējas. 
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3.3. Krāsu spainītis (Bucket fill) 
 

Ilustrācija 9.31. Krāsu spainīša ikona Rīkjoslā 

 
 

Šis rīks aizpilda atlasi ar patreizējo priekšplāna krāsu. Ja pirms aizkrāsošanas nospiedīsiet Shift 

taustiĦu, tas izmantos fona krāsu. Atkarībā no rīka uzstādījumiem, tas vai nu aizpildīs visu atlasi vai tikai 

tās daĜu, kurā ir līdzīgas krāsas. Rīka opcijas nosaka arī krāsas caurspīdību. 

Krāsa daudzums atkarīgs no izvēlētā Aizpildīšanas SliekšĦa (Fill treshold). Tas nosaka, cik tālu krāsa 

izpletīsies. Aizpildīšana sākas no punkta, kurā noklikšėināt un turpinās līdz krāsa vai alfa vērtība kĜūst  

„pārāk atšėirīga”. 

Kad aizpildāt objektus caurspīdīgā slānī (piemēram, teksta simbolus) citā krāsā kā iepriekš, reizēm 

vecās krāsas paliekas ir redzams ap objekta robežām. Tas ir zemā Aizpildīšanas sliekšĦa dēĜ. 

3.3.1. Aktivizēšana 

Krāsu spainīti var aktivizēt caur attēla loga izvēlni Rīki→Zīmēšanas rīki→Krāsu spainis (Tools→Paint 

tools→Bucket fill); nospiežot  ikonu Rīkjoslā vai ar Shift+B taustiĦiem. 

3.3.2. PārveidotājtaustiĦi 

o Ctrl  ieslēdz BG vai FG krāsu aizpildi. 

o Shift  pārslēdz starp komandām Aizpildīt Līdzīgas krāsas vai Aizpildīt Atlasi. 
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Ilustrācija 9.32. Krāsu spainīša opcijas 

 
 

Krāsu spainīša opcijas var atvērt veicot dubultklikšėi uz  ikonas. 

Režīms (Mode ) 

Skatiet sadaĜu Zīmēšanas rīki. 

Aizpildes veids ( Fill type ) 

FG krāsas aizpilde (FG color fill) 

Izmanto aktīvo priekšplāna krāsu. 

BG krāsas aizpilde (BG color fill) 

Izmanto aktīvo fona krāsu. 

Aizpildīšana pēc modeĜa (Pattern Fill) 

Krāsas vietā izmanto izvēlēto modeli, ko var izvēlēties atvāžamajā lodziĦā. 

Ietekmes lauks ( Affected area ) 

Aizpildīt visu atlasi (Fill whole selection) 

Šī opcija Ĝauj aizpildīt iepriekš izveidoto atlasi vai visu attēlu. Ātrāks veids ir priekšplāna, fona 

vai modeĜa krāsas pārvilkšana un nomešana uz atlases. 

Aizpildīt līdzīgas krāsas (Fill similar colors) 

Pēc noklusējuma rīks aizpilda krāsas laukumu ap izvēlēto pikseli. Krāsu līdzību nosaka 

spilgtuma slieksnis vai ar kursoru izvēlētā vērtība. 

Līdzīgu kr āsu mekl ēšana (Finding similar colors ) 

Aizpildīt caurspīdīgos laukumus (Fill transparent area) 

Šī opcija Ĝauj aizpildīt laukumus ar zemu intensitāti. 

Parauga apvienošana (Sample merged) 

Šī iespēja ieslēdz paraugošanu no visiem slāĦiem. Ja šī opcija ir aktivizēta, aizpildīšanu var 

veikt zemākajā slāni, Ħemot vērā krāsu informāciju no augstāk esošā. 

Slieksnis (Threshold) 

Slīdnis nosaka līmeni, kādā mēra krāsu aizpildīšanas robežām. Jo austāks uzstādījums, jo 

lielāks attēla laukums tiks aizpildīts. 
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Aizpildīt pēc (Fill by) 

Ar šīs opcijas palīdzību Jūs varat izvēlēties, kuru attēla sastāvdaĜu GIMP izmantos, lai 

aprēėinātu krāsu līdzību un noteiktu aizpildes laukumu. 

Jūs varat izvēlēties no sekojošām sastāvdaĜām: Salikts (Composite), Sarkans (Red), ZaĜš 

(Green), Zils (Blue), Nokrāsa (Hue), Piesātinātība (Saturation) vai Vērtība (Value). 

3.4. Pārejas rīks (Blend tool) 
 

Ilustrācija 9.33. Pārejas rīka ikona Rīkjoslā 

 
 

Pēc noklusējuma šis rīks aizpilda atlasi ar fona un priekšplāna krāsas pāreju, bet tam ir arī citas opcijas. 

Lai izveidotu pāreju, velciet kursoru virzienā, kurā vēlaties to izveidot un atlaidiet peles pogu. Pārejas 

mīkstums atkarīgs no pārvilkšanas attāluma. 

Divas svarīgākās opcijas ir Gradients (Gradient) un Forma (Shape). Gradienta aktivizēšana Rīka opciju 

dialogā Ĝauj izvēlēties kādu no GIMP piedāvātajiem variantiem, bet Jūs varat izveidot arī savus. 

Formai ir vienpadsmit iespējas, kas aprakstītas zemāk. Formas opcija ir interesanta ar to, ka tā liek 

gradientam sekot atlases formai, lai ari cik sarežăīta tā būtu. 

3.4.1. Aktivizēšana 

Pārejas rīku var aktivizēt caur attēla loga izvēlni Rīki→Zīmēšanas rīki→Pāreja (Tools→Painting 

tools→Blend), nospiežot  ikonu Rīkjoslā vai izmantojot L taustiĦu. 

3.4.2. PārveidotājtaustiĦi 

Ctrl izmanto, lai izveidotu taisnu pāreju, ko nosaka tuvāk esošais 15 grādu leĦėis. 
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3.4.3. Opcijas 
 

Ilustrācija 9.34. Pārejas rīka opcijas 

 
 

Pārejas rīka opcijas var atvērt veicot dubultklikšėi uz  ikonas. 

Režīms; Intensit āte (Mode; Opacity ) 

Skaties sadaĜu Otu rīki. 

Gradients ( Gradient ) 

Iespējams izvēlēties gradientu no atvāžamā saraksta. Izvēles rūtiĦa Pretēji (Reverse) apmaina 

vietām fona un priekšplāna krāsas vai maina gradienta izkārojumu. 

Nob īde (Offset ) 

Nobīdes vērtība Ĝauj palielināt gradienta slīpumu. Šī opcija nedarbojas vairumā formu. 
 

Ilustrācija 9.35. Nobīdes piemērs 

 
Augšā: Nobīde=0, lejā nobīde=50%. 

 

Forma ( Shape ) 

GIMP piedāvā 11 formas, kuras var izvēlēties atvāžamajā sarakstā. 
 

Ilustrācija 9.36. Gradienta formu piemēri 

 Lineārs (Linear) 

 Bilineārs (Bi-Linear) 

 Radiāls (Radial) 

 Kvadrāts (Square) 

 Formēts pēc leĦėa (Shaped angular) 
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 Formēts pēc lodes (Shaped spherical) 

 Formēts pēc iedobuma (Shaped dimpled) 

 Simetriski konisks (Conical symmetrical) 

 Asimetriski konisks (Conical asymmetrical) 

 Spirāle pulkst. rādītāja virzienā (Spiral clockwise) 

  Spirāle pret pulkst. rādītāju (Spiral counterclockwise) 
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3.5. Dzēšgumija (Eraser) 
 

Ilustrācija 9.37. Dzēšgumijas ikona Rīkjoslā 

 
 

Dzēšgumiju izmanto, lai dzēstu krāsu laukumus aktīvajā slānī vai šī slāĦa atlasē. Ja Dzēšgumiju lieto uz 

objekta, kas neatbalsta caurspīdību (atlases kanālā, slāĦa maskā, fona slānī bez alfa kanāla), dzēšana 

atstāj melnus plankumus. Citādi dzēšana veido pilnīgu vai daĜēju caurspīdību, atkarībā no rīka opcijām. 

Ja nepieciešams pilnībā dzēst pikseĜu grupu, būtu jāizvēlas „Asas malas” (Hard edge) rīka opcijās. 

PADOMS 

Izmantojot grafisko planšeti, lietojiet zīmuĜa otru galu kā dzēšgumiju – noklikšėiniet ar zīmuĜa otru galu uz 

Dzēšgumijas rīka ikonas Rīkjoslā. Tā turpinās darboties kā dzēšgumija, līdz izvēlēsieties citu rīku. 

3.5.1. Aktivizēšana 

Dzēšgumiju var aktivizēt caur attēla loga izvēlni Rīki→Zīmēšanas rīki→Dzēšgumija (Tools→Painting 

tools→Eraser), nospiežot  ikonu Rīkjoslā vai izmantojot Shift + E taustiĦus. 

3.5.2. PārveidotājtaustiĦi 

Ctrl 

Ctrl nospiešana pārvērš dzēšgumiju par Krāsu savākšanas rīku, kas izvēlas krāsu, noklikšėinot uz 

tās. Atšėirībā no citiem otu rīkiem, Dzēšgumija izmanto fona krāsu. 

Alt 

Alt taustiĦa turēšana pārslēdz Dzēšgumiju at-dzēšanas režīmā, kas aprakstīts zemāk. Dažās 

operētājsistēmās jāizmanto Alt + Shift kombinācija. 



 

112 

3.5.3. Opcijas 
 

Ilustrācija 9.38. Dzēšgumijas opcijas 

 
 

Ota; Spiedienj ūtība; Pavājināšanās, Pieaugoši, Asas malas ( Brush; Pressure sensitivity; Fade 

out; Incremental; Hard edge ) 

Skatieties sadaĜu Otu rīki. 

Intensit āte (Opacity) 

Slīdnis nosaka rīka „stiprumu”. Darbojoties slānī ar alfa kanālu, lielāka intensitāte vairo 

caurspīdību. 

At-Dzēšana (Anti erase) 

Šī opcija var at-dzēst attēla laukumus pat tad, ja tie ir pilnīgi caurspīdīgi. Šī opcija darbojas tikai 

slāĦos ar alfa kanālu. 
 

PADOMS 

Dzēšgumiju varat izmantot, lai mainītu peldošas atlases formu. Dzēšana apgriež atlases malas. 
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3.6. Tinte (Ink) 
 

Ilustrācija 9.39. Tintes ikona Rīkjoslā 

 

 

Tintes rīks simulē tintes pildspalvu ar kontrolējamu spalvu, lai zīmētu nepārtrauktus triepienus ar malām, 

kam piemērota kropĜojumnovērse. Spalvas izmērs, forma un leĦėis var tikt pielāgoti, lai noteiktu triepienu 

izskatu. 

3.6.1. Aktivizēšana 

Tinti var aktivizēt caur attēla loga izvēlni Rīki→Zīmēšanas rīki→Tinte (Tools→Painting tools→Ink), 

nospiežot  ikonu Rīkjoslā vai izmantojot K taustiĦu. 

3.6.2. PārveidotājtaustiĦi 

Šim rīkam nav specifisku pārveidotājtaustiĦu. 

3.6.3. Opcijas 
 

Ilustrācija 9.40. Tintes opcijas 

 
 

Tintes opcijas var atvērt veicot dubultklikšėi uz  ikonas. 
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Režīms (Mode ) 

Skatiet sadaĜu Zīmēšanas rīki. 

Intensit āte (Opacity ) 

Skaties sadaĜu Otu rīki. 

Pielāgomi ( Adjustment ) 

Izmērs (Size) 

Kontrolē spalvas izmēru – no 0 (tieva) līdz 20 (bieza). 

LeĦėis (Angle) 

Kontrolē spalvas leĦėi (horizontāli). 

Jūtība (Sensitivity) 

Izmērs (Size) 

Kontrolē maksimālo spalvas izmēru no 0 līdz 20. 

Pacēlums (Tilt) 

Kontrolē spalvas pacēlumu (horizontāli). 

Ātrums (Speed) 

Kontrolē spalvas izmēru atkarībā no zīmēšanas ātrumu. Jo lielāks ātrums, jo tievāka spalva. 

Veids un Forma ( Type and shape ) 

Veids 

Iespējami trīs spalvas veidi – apaĜa (round), rombveida (diamond) vai kvadrātveida (square). 

Forma 

Spalvas formu var mainīt, ar peles pogu pieturot maz kvadrātiĦu formas ikonas centrā un to 

kustinot. 
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3.7. Klonēšana (Clone tool) 
 

Ilustrācija 9.41. Klonēšanas ikona Rīkjoslā 

 
 

Klonēšanas rīks lieto aktīvo otu, lai kopētu laukumus no attēla vai modeĜa. Tam ir vairāki pielietojumi, 

taču visizplatītākais ir digitālo fotogrāfiju nepilnību maskēšana. 

Ja vēlaties klonēt attēla daĜu, Jums GIMP ir jāpasaka priekšā, no kurienes jākopē. To dara turot Ctrl 

taustiĦu un klikšėinot izvēlētajā attēla vietā. Līdz nebūsiet to izdarījis, Klonēšanas rīks nedarbosies. 

3.7.1. Aktivizēšana 

Klonēšanas rīku var aktivizēt caur attēla loga izvēlni Rīki→Zīmēšanas rīki→Klonēt (Tools→Painting 

tools→Clone), nospiežot  ikonu Rīkjoslā vai izmantojot c taustiĦu. 

3.7.2. PārveidotājtaustiĦi 

Ctrl 

Ctrl taustiĦu izmanto klonēšanas avota izvēlei. To dara turot nospiestu Ctrl taustiĦu un klikšėinot 

izvēlētajā attēla slānī. 
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3.7.3. Opcijas 

 

Ilustrācija 9.42. Klonēšanas rīka opcijas 

 
 

Ota; Spiedienj ūtība; Pavājināšanās, Pieaugoši, Asas malas ( Brush; Pressure sensitivity; Fade 

out; Incremental; Hard edge ) 

Skatieties sadaĜu Otu rīki. 

Avots ( Source ) 

Šī opcija nosaka, vai dati tiks klonēti no modeĜa vai attēla. 

Attēls (Image) 

Ja izvēlaties šo opciju, Jums GIMP ir jānorāda, no kura slāĦa notiks klonēšana, pieturot Ctrl 

taustiĦu un klikšėinot uz tā. 

Modelis (Pattern) 

Atveras modeĜu dialogs, no kura varat izvēlēties modeli. 

Līdzināšana (Alignment ) 

Līdzināšanas režīms nosaka attiecību starp otas un avota novietojumu. 
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3.8. Dziedēšanas rīks (Heal tool) 
 

Ilustrācija 9.43. Dziedēšanas rīka ikona Rīkjoslā 

 
 

Dziedēšanas rīka darbības princips ir līdzīgs Klonēšanas rīkam, taču tas ir daudz „gudrāks” sīku defektu 

pielabošanā. Tipiskais pielietojums ir krunciĦu izlīdzināšana fotogrāfijās. Lai to izdarītu pikseĜi tiek 

pārkopēti, Ħemot vērā galamērėa datus. 

Lai to izmantotu, vispirms izvēlieties otu, kuras izmērs piemērots defekta izmēram. Tad turiet nospiestu 

Ctrl taustiĦu un izvēlieties klonēšanas avotu. Atlaidiet Ctrl taustiĦu un pārvelciet avotu virs defekta. 

Noklikšėiniet. Ja defekts ir nenozīmīgs, tas drīz vien tiks izlabots. Ja tas ir ievērojamāks, atkārtojiet šo 

procedūru līdz apmierinošam rezultātam. 

3.8.1. Aktivizēšana 

Dziedēšanas rīku var aktivizēt caur attēla loga izvēlni Rīki→Zīmēšanas rīki→Dziedēt (Tools→Painting 

tools→Heal), nospiežot  ikonu Rīkjoslā vai izmantojot H taustiĦu. 

3.8.2. PārveidotājtaustiĦi 

Ctrl 

Ctrl taustiĦu izmanto klonēšanas avota izvēlei. To dara turot nospiestu Ctrl taustiĦu un klikšėinot 

izvēlētajā attēla slānī. 

Shift 

Kad avots ir izvēlēts, nospiežot šo pogu Jūs redzēsiet tievu palīglīniju, kas savieno iepriekš izvēlēto 

laukumu un kursora patreizējo atrašanās vietu. Pēc atkārtota klikšėa, turot Shift taustiĦu, rīks 

„sadziedēs” pa šo līniju. 
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3.8.3. Opcijas 
 

Ilustrācija 9.44. Dziedēšanas rīka opcijas 

 
 

Dziedēšanas rīka var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

Dziedēšanas rīka opcijas sakrīt ar aprakstītajām pie Klonēšanas rīka. 
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3.9. Perspektīvas klonēšanas rīks (Perspective clone tool) 
 

Ilustrācija 9.45. Perspektīvas klonēšanas rīka ikona Rīkjoslā 

 
 

Šis rīks Ĝauj klonēt objektus ievērojot perspektīvu. Vispirms izvēlieties izzušanas punktus, atėeksējiet 

opciju Pārveidot perspektīvas līmeni (Modify perspective plane). Tad atėeksējiet opciju Perspektīvas 

klonēšana (Perspective clone) un darbojieties tāpat kā ar Klonēšanas rīku. 

3.9.1. Aktivizēšana 

Perspēktīvas klonēšanas rīku var aktivizēt caur attēla loga izvēlni Rīki→Zīmēšanas rīki→Perspektīvas 

klonēšana (Tools→Painting tools→Perspective clone) vai nospiežot  ikonu Rīkjoslā. 

3.9.2. PārveidotājtaustiĦi 

Ctrl 

Ctrl + klikšėis Ĝauj izvēlēties citu klonēšanas avotu. 

Shift 

Kad ir izvēlēts klonēšanas avots un nospiesta šī poga, tieva līnija savieno iepriekš izvēlēto punktu 

un kursora atrašanās vietu. Pēc atkārtota klikšėa, turot Shift taustiĦu, rīks klonēs pa šo līniju. 



 

120 

3.9.3. Opcijas 
 

Ilustrācija 9.46. Perspektīvas klonēšanas rīka opcijas 

 
 

Perspektīvas klonēšanas rīka opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

Rīka opcijas ir kopējas ar Klonēšanas rīku. 

3.9.4. Piemērs 
 

Ilustrācija 9.47. Perspektīvas klona piemērs 

 
Atėeksēta opcija Pārveidot perspektīvas līmeni, izvēlēti izzušanas punkti 

 

Atėeksēta opcija Perspektīvas klonēšana, tika klonēs baltais četrstūris. 
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3.10. Saritināšanas rīks (Convolve tool) 
 

Ilustrācija 9.48. Saritināšanas rīka ikona Rīkjoslā 

 
 

Saritināšanas rīks izmanto otu, vai lokāli apmiglotu vai saasinātu attēlu. Apmiglošana var būt noderīga, 

ja kāds objekts attēlā pārāk izceĜas. Triepiena virzienam nav nozīmes. 

Saasināšanas režīmā rīks palielina kontrastu vietā, kur tiek izmantots. 

Abi režīmi darbojas pieaugoši: otas vairākkārtēja pārvietošana vienā vietā palielina efektu. Ātruma 

kontrole Ĝauj pielāgot izmaiĦu ātrumu. Intensitātes kontrole ierobežo apmiglošanas daudzumu, ko rada 

viens otas triepiens, neskatoties uz atkārtojuma reizēm. 

3.10.1. Aktivizēšana 

Saritināšanas rīku var aktivizēt caur attēla loga izvēlni Rīki→Zīmēšanas rīki→Saritināšanas rīks 

(Tools→Painting tools→Convolve), nospiežot  ikonu Rīkjoslā vai ar taustiĦu V. 

3.10.2. PārveidotājtaustiĦi 

Ctrl 

Turot to nospiestu, rīks pārslēdzas starp Apmiglošanas un Saasināšanas režīmiem. 
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3.10.3. Opcijas 
 

Ilustrācija 9.49. Saritināšanas rīka opcijas 

 
 

Saritināšanas rīka opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

Visas Saritināšanas rīka opcijas ir līdzīgas Otu rīku opcijām. 
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3.11. Pludināšanas rīks (Smudge tool) 
 

Ilustrācija 9.50. Pludināšanas rīka ikona Rīkjoslā 

 
 

Pludināšanas rīks izmanto otu, lai izpludinātu aktīvā slāĦa vai atlases krāsas. Tas sapludina blakus 

esošās krāsas Jūsu uzstādītā attālumā. 

3.11.1. Aktivizēšana 

Pludināšanas rīku var aktivizēt caur attēla loga izvēlni Rīki→Zīmēšanas rīki→Pludināt (Tools→Painting 

tools→Smudge), nospiežot  ikonu Rīkjoslā vai ar taustiĦu S. 

3.11.2. PārveidotājtaustiĦi 

Shift 

Šis taustiĦš ieslēdz Pludināšanas rīka „taisno režīmu”. Turot nospiestu Shift, Jūsu zīmētā līnija būs 

taisna. 

Ctrl 

Ctrl+Shift izmantošana palīdz izveidot taisnu leĦėi, kuru nosaka tuvākie 15 grādi. 

3.11.3. Opcijas 
 

Ilustrācija 9.51. Pludināšanas rīka opcijas 

 
 

Pludināšanas rīka opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

Opciju aprakstu skatiet sadaĜā Otu rīki. 
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3.12. Dedzināšanas rīks (Burn tool) 
 

Ilustrācija 9.52. Dedzināšanas rīka ikona Rīkjoslā 

 
 

Dedzināšanas rīku izmanto, lai izgaismotu vai aptumšotu attēla krāsas. Režīms nosaka ietekmējamo 

pikseĜu veidu. 

3.12.1. Aktivizēšana 

Dedzināšanas rīku var aktivizēt caur attēla loga izvēlni Rīki→Zīmēšanas rīki→Dedzināt (Tools→Painting 

tools→Dodge) vai nospiežot  ikonu Rīkjoslā. 

3.12.2. PārveidotājtaustiĦi 

Ctrl  + D 

Šī taustiĦu kombinācija pārslēgsies starp Izlocīšanās un dedzināšanas režīmiem 

Ctrl 

Pārslēdz starp izlocīšanās un dedzināšanas veidiem. IzmaiĦas spēkā, kamēr Ctrl ir nospiests. 

Shift 

Ieslēdz rīka „taisnas līnijas” režīmu. Turot nospiestu šo taustiĦu iespējama taisna līnija. 
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3.12.3. Opcijas 
 

Ilustrācija 9.53. Dedzināšanas rīka opcijas 

 
 

Dedzināšanas rīka opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

 

Veids ( Type) 

Iespējama izvēle starp aptumšošanu un izgaismošanu. 

Režīms (Mode ) 

o Ēnas (Shadows) liek rīkam darboties ar tumšākajiem pikseĜiem 

o PustoĦi (Midtones) liek tīkam darboties ar pustoĦiem. 

o Gaisma (Highlights) liek rīkam darboties ar gaišajiem pikseĜiem. 

Ekspoz īcija ( Exposure ) 

Ekspozīcija nosaka, cik spēcīgi rīks darbosies. Slīdni var novietot diapazonā no 0 līdz 100. 
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4. Pārveidošanas rīki (Transform tools) 

4.1. Kopīgas raksturpazīmes 
 

Ilustrācija 9.54. Transformāciju rīku pārskats 

 
3 

Pārveidošanas rīku izvēlnē Jūs atradīsiet astoĦus rīkus, kas pārveido attēla vai tā elementa atrašanās 

vietu un veidu. Katram pārveidošanas rīkam ir Opciju un Informācijas dialogs. 

4.1.1. Opcijas 
 

Ilustrācija 9.55. Pārveidošanas rīku kopīgās opcijas 

 
 

Vairumam pārveidošanas rīku ir kopīgas opcijas, kuras apskatīsim tālā. Katra rīka specifiskās opcijas 

meklējiet attiecīgā rīka sadaĜā. 

Pārveidošana 

GIMP piedāvā ievēlēties vienu no trīs attēla elementiem, uz kuru iedarbosies rīks. 

o Kad aktivizējat pirmo pogu , rīks darbojas aktīvajā slānī. Ja tajā neatrodas 

neviena atlase, tiks pārveidots viss slānis. 

o Kad aktivizējat otro pogu , rīks darbojas tikai ar atlases kontūru (vai visu slāni, 

ja tajā nav atlases). 

o Kad aktivizējat trešo pogu , rīks darbojas tikai ar ceĜu (path). 
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Virziens ( Direction ) 

Šī opcija nosaka pārveidošanas virzienu. Lai pārveidotu atlasi vai slāni, jāizmanto rokturi. Pēc 

darba beigām objekts pagriežas izvēlētajā veidā. 

Labošanas rotācija (Corrective rotation) ir paredzēta ăeometrisku nepilnību labošanai digitālajās 

fotogrāfijās. 

Iestarpin āšana ( Interpolation ) 

Iestarpināšanas atvāžamais saraksts Ĝauj izvēlēties pārveides kvalitāti. 

Izgriešana ( Clipping ) 

Pēc pārveidošanas attēls var kĜūt lielāks. Šī opcija attēlu apgriezīs līdz iepriekšējam izmēram. 

Pielāgot (Adjust) 

Slānis tiek palielināts līdz pagrieztā objekta izmēram. 

Izgriezt (Clip) 

Objekts tiek apgriezts līdz slāĦa izmēram un liekās malas dzēstas. 

Priekšskat ījums ( Preview ) 

Kontūra (Outline) 

Attēla perimetru ieskauj rāmis ar rokturi katrā stūrī. 

Režăis (Grid) 

Attēlam uzliek režăi ar rokturiem.  

Attēls (Image) 

Priekšskatījums ir attēla kopija, kas novietota uz tā. 

Režăis+Attēls (Grid+Image) 

Vienlaicīgi darbojas abas opcijas. 

Priekšskatījums paredzēts lielākai pašpārliecinātībai. 

Režăa opcijas Ĝauj izvēlēties tā līniju skaitu. Režăa platināšana (Grid line spacing) Ĝauj izvēlēties 

attālumu starp režăa līnijām. 
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4.2. Pārvietošanas rīks (Move tool) 
 

Ilustrācija 9.56. Pārvietošanas rīka ikona Rīkjoslā 

 
 

Šis rīks paredzēts slāānu, atlašu, ceĜu un režăus pārvietošanai. Tas darbojas arī ar tekstu. 

4.2.1. Aktivizēšana 

Pārvietošanas rīku var aktivizēt caur attēla loga izvēlni Rīki→Pārveidošanas rīki→Pārvietot 

(Tools→Transform tools→Move), nospiežot  ikonu Rīkjoslā vai ar taustiĦu M. Pārvietošanas rīks tiek 

automātiski aktivizēts pēc režăa izveidošanas. 
 

PIEZĪME 

Atstarpes taustiĦa nospiešana jebkuru rīku īslaicīgi pārvērš par Pārvietošanas rīku. 

4.2.2. Opcijas 
 

Ilustrācija 9.57. Pārvietošanas rīka opcijas 

 

Dedzināšanas rīka opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

Režīms (Mode ) 

Par režīmiem lasiet sadaĜā Pārveidošanas rīku opcijas. 

Rīka pārsl ēdzējs (Tool toggle ) 

o Izvēlēties slāni vai režăi (Pick a layer or guide): Attēlā ar daudz slāĦiem, peles kursors 

pārvēršas par bultiĦu, kas atrodas uz aktīvā slāĦa elementa.  

o Pārvietot aktīvo slāni (Move the current layer): Pārvietojas tikai aktīvais slānis. 
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4.2.3. Pārvietošanas rīka kopsavilkums 

Atlases p ārvietošana 

Pārvietošanas rīks Ĝauj pārvietot tikai atlases kontūru. 

SlāĦa pārvietošana 

Pārvietošanas režīmam jābūt Slānis (Layer). 

Režăa pārvietošana 

Kad izĦemat režăi no lineāla, Pārvietošanas rīks tiek automātiski aktivizēts. Kad kursors atrodas 

virs režăa, tas paliek sarkans un Jūs varat to pārvietot. 

Teksta p ārvietošana 

Katram tekstam ir savs slānis, kas tā var tikt pārvietots. Lai to izdarītu, jāklikšėina uz teksta 

simbola. 
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4.3. Izlīdzināšanas rīks (Align tool) 
 

Ilustrācija 9.58. Izlīdzināšanas rīka ikona Rīkjoslā 

 
 

Izlīdzināšanas rīks noder slāĦu ar vairākiem objektiem izlīdzināšanā. Kad rīks ir aktivizēts, kursors 

pārvēršas par roku. Uzklikšėinot uz slāĦa elementa (Shift + klikšėis vairākiem), kas tiks pārvietots. Rīka 

opcijas Ĝauj izvēlēties dažādus pārvietojuma veidus. Tāpat varat izvēlēties, pēc kura slāĦa, atlases vai 

objekta izvēlētais slānis tiek izlīdzināts. Šo objektu sauc par mērėi. 

4.3.1. Aktivizēšana 

Izlīdzināšanas rīku var aktivizēt caur attēla loga izvēlni Rīki→Pārveidošanas rīki→Izlīdzināt 

(Tools→Transform tools→Align), nospiežot  ikonu Rīkjoslā vai ar taustiĦu Q. 

4.3.2. PārveidotājtaustiĦi 

Shift 

Turot nospiestu Shift taustiĦu varat izvēlēties vairākus slāĦus. 
 

PADOMS 

Reizēm vairākus slāĦus vieglāk izvēlēties izmatojot „gumijas” tehniku: noklikšėiniet kaut kur ārpus 

iedomāta taisnstūra, kurā atrodas vajadzīgie slāĦi. Tas uzvelciet četrstūri – visi tajā iekĜautie slāĦi ir 

izvēlēti. 
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4.3.3. Opcijas 
 

Ilustrācija 9.59. Izlīdzināšanas opcijas 

 

Izlīdzināšanas rīka opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

Izlīdzināt (Align ) 

Pēc (Relative to) 

Nosaka objektu, pēc kura tiks izlīdzināts izvēlētais slānis. 

o Pirmā vienība (First item): pirmā izvēlētā vienība. 

o Attēls (Image): par mērėi izvēlētais attēls. 

o Atlase (Selection): mazākais taisnstūris, kurā iekĜauta aktīvā atlase. 

o Aktīvais kanāls (Active Channel) 

o Aktīvais ceĜš (Active path): šī opcija pagaidām nedarbojas. 

 

Šīs pogas darbojas tikai aktīvajā slānī. Tās izmanto slāĦa izlīdzināšanai. 

Sadal ījums ( Distrubute ) 

 

Šīs pogas atšėiras tikai ar to, ka nosaka nobīdi, pēc kādas izvēlētie slāĦi tiks izlīdzināti. 

Nobīde (Offset) 

Šī opcija nosaka nobīdes izmēru, pēc kādas mērėis tiks pielīdzināt slānim. Vērtība var būt 

pozitīva vai negatīva. 
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4.4. Apgraizīšanas rīks (Crop tool) 
 

Ilustrācija 9.60. Apgraizīšanas rīka ikona Rīkjoslā 

 
 

Apgraizīšanas rīks paredzēts attēla malu apgriešanai. Tas darbojas visos attēla slāĦos vienlaicīgi. To 

bieži izmanto, lai vairāk izveltu attēla objektu. Bet tas noder arī attēla izmēra maiĦai. 

IzmērmaiĦas rokturi Ĝauj mainīt atlases izmēru. Lai to pārvietotu, noklikšėiniet taisnstūra iekšpusē. 

Pārvietojot atlasi aiz stūra, pa panākt izmēra maiĦu, nezaudējot malu proporcijas. Lai apstiprinātu 

apgraizīšanu, nospiediet Enter taustiĦu. 

4.4.1. Aktivizēšana 

Apgraizīšanas rīku var aktivizēt caur attēla loga izvēlni Rīki→Pārveidošanas rīki→Apgraizīt 

(Tools→Transform tools→Crop), nospiežot  ikonu Rīkjoslā vai ar taustiĦus Shift + C. 

4.4.2. PārveidotājtaustiĦi 

Kad turat nospiestu peles kreiso pogu virs attēla: 

o Ctrl ieslēdz rīka Izplest no centra (Expand from center) opciju 

o Shift ieslēdz opciju Fiksēts (Fixed), kas fiksē dažas dimensijas. 
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4.4.3. Opcijas 
 

Ilustrācija 9.61. Apgraizīšanas rīka opcijas 

 
 

Apgraizīšanas rīka opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

Tikai akt īvo sl āni (Current layer only ) 

Šī opcija liek rīkam darboties tikai aktīvajā slānī. 

PieĜaut augšanu ( Allow growing ) 

Šī opcija Ĝauj apgraizīt vai mainīt izmēru ārpus attēla vai slāĦa robežām. 

Izplest no centra ( Expand form center ) 

Ka ir aktivizēta šī opcija, apgraizīšanas taisnstūris izplešas no pirmā noklikšėinātā pikseĜa kā 

centra. Šo opciju ar ieslēgt ar Ctrl taustiĦu, zīmējot taisnstūri. 

Novietojums ( Position ) 

Šie divi lauciĦi nosaka taisnstūra novietojumu (koordinātes). Tās tiek izteiktas pikseĜos, taču Jūs 

varat mainīt mērvienības. 

Izcelt ( Hightlight ) 

Šī opcija ieslēdz tumšo masku ap iezīmēto trijstūri. 



 

134 

4.5. Rotēšanas rīks (Rotate tool) 
 

Ilustrācija 9.62. Rotēšanas rīka ikona Rīkjoslā 

 
 

Šīs rīks paredzēts aktīvā slāĦa, atlases vai ceĜa rotēšanai. Kad uzklikšėināt uz objekta, parādās 

Rotēšanas informācijas (Rotation information) dialogs. Tajā Jūs varat uzstādīt rotēšanas asis un leĦėi. 

To var izdarīt arī ar peli pārvelkot attēlam vai rotēšanas punktam. 

4.5.1. Aktivizēšana 

Rotēšanas rīku var aktivizēt caur attēla loga izvēlni Rīki→Pārveidošanas rīki→Rotēt (Tools→Transform 

tools→Crop), nospiežot  ikonu Rīkjoslā vai ar taustiĦiem Shift + R. 

4.5.2. PārveidotājtaustiĦi 

Ctrl 

Ctrl nospiešana liks objektam rotēt 15 grādu soĜos. 

4.5.3. Opcijas 
 

Ilustrācija 9.63. Rotēšanas rīka opcijas 

 
 

Rotēšanas rīka opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 
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Main īt virzienu ( Transform direction ) 

Šī opcija maina rotēšanas virzienu. 

Ierobežojumi ( Constraints ) 

Šī opcija Ĝaus rotēt tikai par 15 grādu intervālos. 

Pārējās šī rīka opcijas ir līdzīgas cietiem šīs grupas rīkiem un apskatītas sadaĜa Pārveidošanas rīki. 
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4.6. Apmešanas rīks (Flip tool) 
 

Ilustrācija 9.64. Apmešanas rīka ikona Rīkjoslā 

 
 

Apmešanas rīks dod iespēju veidot atlašu, slāĦu vai attēlu horizontālus vai vertikālus spoguĜattēlus. Kad 

atlase ir apmesta, rodas jauna peldošā atlase. Šo rīku var izmantot atspulgu veidošanā. 

4.6.1. Aktivizēšana 

Apmešanas rīku var aktivizēt caur attēla loga izvēlni Rīki→Pārveidošanas rīki→Apmest 

(Tools→Transform tools→Flip), nospiežot  ikonu Rīkjoslā vai ar taustiĦiem Shift + F. 

4.6.2. PārveidotājtaustiĦi 

Ctrl 

ěauj pārslēgties starp vertikālo un horizontālo apmešanu. 

4.6.3. Opcijas 
 

Ilustrācija 9.65. Apmešanas rīka opcijas 

 
 

Apmešanas rīka opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

Apmešanas veids ( Flip type ) 

Nosaka, vai apmešana notiks horizontāli vai vertikāli. 
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5. Citi rīki 

5.1. Krāsu savācējs (Color picker) 
 

Ilustrācija 9.66. Krāsu savācēja ikona Rīkjoslā 

 
 

Krāsu savācēju lieto, lai izvēlētos krāsu no jebkura atvērta attēla. Noklikšėinot uz kāda punkta attēlā, 

priekšplāna krāsas mainās uz izvēlētā pikseĜa krāsu. Pēc noklusējuma rīks darbojas aktīvajā slānī, taču 

izvēloties opciju Parauga apvienošana (Sample merge), rīks Ħem vērā īsto attēla krāsu. Tiek izmantotas 

tikai redzamo slāĦu krāsas. Pēc krāsas izvēles atveras Informācijas lodziĦš (Info window). 

5.1.1. Aktivizēšana 

Krāsu savācēju var aktivizēt caur attēla loga izvēlni Rīki→Krāsu savācējs (Tools→Color picker), 

nospiežot  ikonu Rīkjoslā vai ar taustiĦu O. Nospiežot taustiĦu Ctrl zīmēšanas rīka izmantošanas 

brīdī, tas pārvēršas par Krāsu savācēju. 

5.1.2. PārveidotājtaustiĦi 

Ctrl 

Pārslēdz rīka izmantoto krāsu starp priekšplāna un fona krāsām. 

Shift 

Turot nospiestu Shift taustiĦu un klikšėinot uz kāda pikseĜa, atveras Krāsu informācijas logs (Color 

information window). 
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5.1.3. Opcijas 
 

Ilustrācija 9.67. Krāsu savācēja opcijas 

 
 

Krāsu savācēja opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

Paraugu apvienošana ( Sample merged ) 

Krāsu paraugs tiks Ħemts no visiem attēla redzamajiem slāĦiem. 

Parauga vid ējā vērt ība (Sample average ) 

Rādiusa (Radius) slīdnis nosaka krāsu savācēja gala lielumu, līdz ar to laukumu, no kura tiks 

Ħemts paraugs. 

Savākšanas rež īms (Pick mode ) 

Tikai savākt (Pick only) 

Izvēlētā pikseĜa krāsa tiks tikai parādīta Informācijas dialogā, bet ne pielietota. 

Uzlikt kā priekšplāna krāsu (Set foreground color) 

Izvēlētā pikseĜa krāsa būs priekšplāna krāsa. 

Uzlikt kā fona krāsu (Set background color) 

Izvēlētā pikseĜa krāsa būs fona krāsa. 

Pievienot paletei (Add to palette) 

Izvēlētā krāsa tiek pievienota aktīvajai paletei. 

Lietot inform ācijas logu ( Use info window ) 

Šī opcija liek atvērties informācijas lodziĦam. To dara arī Shift taustiĦš. 
 

Ilustrācija 9.68. Krāsu savācēja informācijas lodziĦš 
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5.2. Lupa (Magnify) 
 

Ilustrācija 9.69. Lupas ikona Rīkjoslā 

 
 

Lupu lieto, lai pietuvinātu attēlu. Ja noklikšėināt uz attēla, lupa darbojas uz visu attēlu. Ja ar šo rīku 

iezīmējat taisnstūri, tiek pietuvināta tās iekšpuse. 

5.2.1. Aktivizēšana 

Lupu var aktivizēt caur attēla loga izvēlni Rīki→Lupa (Tools→Magnify), nospiežot  ikonu Rīkjoslā. 

5.2.2. PārveidotājtaustiĦi 

Ctrl 

Šis taustiĦš pārslēdz lupas režīmu starp tuvināšanu un tālināšanu. 

5.2.3. Opcijas 
 

Ilustrācija 9.70. Lupas opcijas 

 
 

Lupas opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

ěaut loga izm ērmaiĦu (Allow window resizing ) 

Šī opcija Ĝauj mainīt audekla izmēru līdz ar attēla palielināšanu vai samazināšanu. 

Rīka pārsl ēdzējs (Tool toggle ) 

Ir iespēja izvēlēties starp Tuvināšanu (Zoom-in) vai Tālināšanu (Zoom-out). 
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5.3. Teksts (Text) 
 

Ilustrācija 9.71. Teksta ikona Rīkjoslā 

 
 

Teksta rīks ir paredzēts teksta ievietošanai attēlā. Kad ar šo rīku noklikšėina uz attēla, parādās Teksta 

redaktora dialogs (Text editor), kurā Jums jāieraksta teksts, un teksta slānis tiek pievienots SlāĦu 

dialogā. Teksta opcija dialogā varat mainīt fontu, krāsu un izmēru, kā arī to izlīdzināt. 

5.3.1. Aktivizēšana 

Teksta rīku var aktivizēt caur attēla loga izvēlni Rīki→Teksts (Tools→Text), nospiežot  ikonu Rīkjoslā 

vai ar T taustiĦa palīdzību. 

5.3.2. Opcijas 
 

Ilustrācija 9.72. Teksta rīka opcijas 

 
 

Teksta rīka opcijas var atvērt veicot dubultklikšėi uz  ikonas Rīkjoslā. 

 

Fonts ( Font ) 

Iespēja izvēlēties fontu no Jūsu datorā esošajiem. 
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Izmērs (Size) 

Nosaka fonta vai atsevišėu simbolu krāsu. 

Palīdzība (Hinting ) 

Uzlabo mazu burtu izskatu. 

Piespiedu pal īdzība (Force auto-hinting ) 

Automātiski uzlabo mazu burtu vai simbolu izskatu. 

Krop Ĝojumnov ērse (Antialiasing ) 

Nogludina teksta līnijas. Šī opcija ievērojami uzlabo teksta izskatu. 

Krāsa (Color ) 

Nākamo simbolu krāsa. Melna pēc noklusējuma. Krāsu izvēlas no krāsu dialoga lodziĦa, kas 

atveras, kad izvēlēts krāsas piemērs. 
 

PADOMS 

Jūs varat arī pārvilkt krāsu no krāsu dialoga uz tekstu, lai to iekrāsotu. 
 

Izlīdzināt (Justify ) 

Izlīdzina tekstu pēc izvēlētajiem parametriem. 

Atkāpe (Indent ) 

Nosaka pirmās rindiĦas atkāpi no kreisās puses. 

Atstarpe starp rindi Ħām (Line spacing ) 

Nosaka atstarpi starp teksta rindiĦām. Skaitlis nosaka pikseĜu skaitu starp rindiĦām. 

Burtu atstarpe ( Letter spacing ) 

Nosaka atstarpi starp teksta simboliem. 

 


